Foros del Web » Programando para Internet » PHP »

Problemas serios al Generar Thumbnails!!

Estas en el tema de Problemas serios al Generar Thumbnails!! en el foro de PHP en Foros del Web. Antes que nada un saludo. Tengo un serio problema en el cual necesito ayuda. Poseo una galería que genera thumbnails de las imagenes para luego ...
  #1 (permalink)  
Antiguo 27/08/2005, 09:22
 
Fecha de Ingreso: febrero-2005
Mensajes: 7
Antigüedad: 12 años, 10 meses
Puntos: 0
Problemas serios al Generar Thumbnails!!

Antes que nada un saludo. Tengo un serio problema en el cual necesito ayuda.

Poseo una galería que genera thumbnails de las imagenes para luego verlas en su tamaño normal.

Pero ojo estos thumb los estoy generando "al vuelo", es decir que no tengo dos imagenes (pequeña y grande) sino que al generar la galería lo mismo hago con los thumb. Hasta aqui todo bien.

¿CUAL ES EL PROBLEMA? Bueno sencillo, sin conocer la razón cuando la página de la galería se recarga, comienzan a roperse las imagenes, y al final en una recarga adicional sencillamente sale el error:

Forbidden
You don't have permission to access /noticiainteres.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
--------------------------------------------------------------------------------
Apache/1.3.33 Server at www.avisa.org.ve Port 80

Y lo extraño de todo esto es que el error lo vota aleatoriamente, es decir, puede ocurrir tanto en la primera recarga, como en la 100 no hay nada definido.

Pero más extraño aún es lo siguiente: Solo ocurre en Explorer y Mozilla nada más, en el Opera todo bello.

Por si es de ayuda para que me ayuden (valga la redundancia) les paso los siguiente vinculos:

1.- Ejemplo de una mis galerías donde ocurre el error:
http://www.avisa.org.ve/noticiainteres.php?id=10

2.- Tutorial original de la galería:
http://www.fedeblog.com.ar/83-Galera...es-con-PHP.htm

Otro detalle que tambien creo que puede afectar: El error solo ocurre en las páginas que tengo alojadas con iguanahosting, porque tengo una pagina alojada en otro servidor y no ocurre el error en ningun navegador.

http://www.transmundial.org.ve/pedrito/galeria.php

En verdad agradezco de antemano toda la ayuda que me puedan dar.

Jonver Arias
  #2 (permalink)  
Antiguo 27/08/2005, 09:34
 
Fecha de Ingreso: junio-2005
Mensajes: 981
Antigüedad: 12 años, 6 meses
Puntos: 2
Que tal? Entre a la galería y efectivamente es muy aleatorio con el error, con la pauta de que tienes otro hosting y allí no ocurre, diría que es el hosting el que provoca el error. Revise el script y parece estar todo en orden y no hay nada que me de la pauta de que el script sea el responsable.

Espero que sirva de algo mi opinión. Saludos.
  #3 (permalink)  
Antiguo 28/08/2005, 10:26
 
Fecha de Ingreso: febrero-2005
Mensajes: 7
Antigüedad: 12 años, 10 meses
Puntos: 0
Hola a todos!

Me veo en el deber moral de dar a conocer no la solución del problema que tengo, más si la razón de su causa.

Y es algo tan sencillo como que el servidor no sirve... No sabemos porque pero el problema del script de los thumbnails viene dado por que supuestamente tienen algún sistema para evitar que sobrecargue el servidor y esto lo hace dando un error de forbidden.

Hice la prueba en tres servidores diferentes, lo que me da pie a concluir que esta es la razón.

De igual forma si alguien conoce como solucionar este inconveniente, le estaré grandemente agradecido.

Recuerdo a todos que mi alojamiento está hecho en www.iguanahosting.com.

Gracias por la ayuda.

Jonver Arias...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:58.