Foros del Web » Programando para Internet » PHP »

Problemas al subir al servidor

Estas en el tema de Problemas al subir al servidor en el foro de PHP en Foros del Web. Hola a todos y ante todo Feliz Navidad. Mi pregunta es la siguiente. Estoy desarrollando un sitio en php y todo va bien a nivel ...
  #1 (permalink)  
Antiguo 23/12/2005, 02:50
 
Fecha de Ingreso: diciembre-2005
Mensajes: 88
Antigüedad: 12 años
Puntos: 0
Problemas al subir al servidor

Hola a todos y ante todo Feliz Navidad.

Mi pregunta es la siguiente.

Estoy desarrollando un sitio en php y todo va bien a nivel local. Estoy utilizando el wamp server que para los que no lo conozcan te instala apache+php+mysql con dos clicks (es mas comodo para usuarios windows).

La cosa es que va muy bien la web, ya esta terminada y todo funciona perfectamente (incluso la parte de administracion de usuarios que para mi es un milagro). El problema viene cuando subo la pagina al servidor donde irá alojada, y es que, el codigo HTML lo interpreta bien, pero el codigo PHP no lo interpreta. Pregunto si tienen instalado php en el servidor y me dicen que si que esta instalado pero no me dicen la version, si es la 4 o la 5 (en la que yo voy programando).

Por ejemplo tengo el siguiente código:
<?php
if ($_SESSION['usuario']<>"")
{ //mostramos el menu
include ("menu.php");
}
?>
Bien, pues la salida de texto que tengo es
"") {//mostramos el menu include ("menu.php"); } ?>

Si os fijais, muestra solo a partir de <> como si se saltara la variable $_SESSION['usuario'] por lo que creo que puede ser de la version de php.

Alguien puede decirme porque puede ser.

Gracias y feliz navidad a todos.

PD: El servidor es arsys.
  #2 (permalink)  
Antiguo 23/12/2005, 05:56
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Según lo que indicas .. PHP no se está ejecutando correctamente.

Revisa si realmente tienes PHP instalado y funcionando en tu servidor:
Código PHP:
<?
phpinfo
();
?>
Guardalo como info.php y lo subes a tu servidor (/public_html/ o directorio donde dejes tus páginas HTML comunes.

Ejecutalo por el URL como cualquier otro Script (http://www.domino.tal/info.php) y observa. Ahí tendrías que ver información sobre PHP y su configuración (versión .. etc...) Si no ves nada o ves el código "PHP" en sí que pusistes . .insiste con tu proveedor sobre el problema. No pueden decirte que "si .. está habilitado PHP" sin decirte ni la versión que usan .. eso es poco "serio".

Un saludo,
  #3 (permalink)  
Antiguo 23/12/2005, 06:10
 
Fecha de Ingreso: diciembre-2005
Mensajes: 88
Antigüedad: 12 años
Puntos: 0
jejeje

es curioso. He subido el archivo info.php con el codigo que me has dicho (sabia que se podia hacer, pero no se me habia ocurrido). Acto seguido me he ido a mi navegador y he puesto www.dominio.com/info.php y me sale un cuadro de dialogo que me da a elegir entre Abrir, Guardar y Cancelar...pero no me sale la version ni nada relativo.

por que puede ser? es la primera vez que me enfrento al lado oscuro xDDDD
  #4 (permalink)  
Antiguo 23/12/2005, 06:21
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Pues con ese antecedente .. en tu servicio de hosting NO tienes soporte PHP o no se usa así (a "lo peor" tienes que colocar tus .php scripts en cgi-bin/ .. no es muy común pero alguna vez ví algún servidor que exigia esto).

Lo mas recomendable es que insistas con tu proveedor y que te aseguren si realmente dispones de PHP para tu sitio y como usarlo si corresponde. Explicales que has intentado hacer esa prueba básica que te propuse.

Un saludo,
  #5 (permalink)  
Antiguo 23/12/2005, 06:25
 
Fecha de Ingreso: diciembre-2005
Mensajes: 88
Antigüedad: 12 años
Puntos: 0
Gracias por tu ayuda.

La estructura que me sale en el FTP cuando conecto son dos carpetas, una es HTML y la otra es DATA, no creo que haya que meter los scripts en data no? pero bueno, yo estoy con eso, que no me soporta php, ahora llamare otra vez para insistirles.

Gracias y feliz navidad xDD
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:03.