Foros del Web » Programando para Internet » PHP »

procesar variables por url

Estas en el tema de procesar variables por url en el foro de PHP en Foros del Web. Hola a todos. Tengo el siguiente problema: Tengo un enlace donde le quiero pasar ademas una variable , algo asi como: ><a href="tareas2.php?actualizar=1&equipo=$equipos> PERO CUANDO ...
  #1 (permalink)  
Antiguo 30/03/2004, 08:20
 
Fecha de Ingreso: marzo-2004
Mensajes: 550
Antigüedad: 13 años, 8 meses
Puntos: 5
Sonrisa procesar variables por url

Hola a todos. Tengo el siguiente problema:

Tengo un enlace donde le quiero pasar ademas una variable , algo asi como:

><a href="tareas2.php?actualizar=1&equipo=$equipos>

PERO CUANDO RECOJO LAS VARIABLES EN LA PAGINA TAREAS2.PHP el valor que obtengo en la variable $equipo no es el valor de la variable $equipos sino la palabra $equipos.

¿como se hace para poder pasar el valor de una variable por este enlace?
  #2 (permalink)  
Antiguo 30/03/2004, 08:49
 
Fecha de Ingreso: marzo-2004
Mensajes: 550
Antigüedad: 13 años, 8 meses
Puntos: 5
Soy yo otra vez. La linea donde me ocurre este problema es:

$equipos=fgets($Conexion,128); aqui leo la variable por socket

echo '<li><a href="tareas2.php actualizar=1&equipo=$equipos" target="tareas" >'.$equipos.'</a></li>';

Debe se algun problema de comas pero no se donde estara el error.

Gracias otra vez.
  #3 (permalink)  
Antiguo 30/03/2004, 09:40
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Si usas:
><a href="tareas2.php?actualizar=1&equipo=$equipos>

debes mandar a "imprimir" el valor de tu variable ..

Código PHP:
><a href="tareas2.php?actualizar=1&equipo=<? echo $equipos ?>>
si usas el echo ...... para todo el código HTML+tus variables debes usar comillas dobles y escapar las comillas dobles cuando las requieras o al reves (con comillas simples) .. PHP no interpreta lo que esté entre comillas simples ..

Código PHP:
echo "<li><a href=\"tareas2.php actualizar=1&equipo=\"".$equipos."\" target=\"tareas\" >".$equipos."</a></li>"
Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.

Última edición por Cluster; 30/03/2004 a las 09:48
  #4 (permalink)  
Antiguo 30/03/2004, 09:55
 
Fecha de Ingreso: marzo-2004
Mensajes: 550
Antigüedad: 13 años, 8 meses
Puntos: 5
gracias. Ahora si me funciona. Lo que pasa es que no me encuentra la pagina destino y antes si lo hacia.
¿sera la etiqueta target la que estara mal?
aunque en la pagina donde tengo declarado los frames tengo:

<frame src="tareas2.php" name="tareas" noresize>

asi que no se porque no me enlaza con la pagina.
  #5 (permalink)  
Antiguo 30/03/2004, 10:01
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
mm Los problemas de HTML ya son del foro de HTML.. es decir, que PHP ya cumplió su parte ... ahora toca que revises el uso/sintax correcto de tus etiquetas HTML de frame ..

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:03.