Foros del Web » Programando para Internet » PHP »

Que podrá ser??

Estas en el tema de Que podrá ser?? en el foro de PHP en Foros del Web. Tengo esto en php <? mysql_connect("localhost","",""); $result=mysql_db_query("caxainte_2","select * from tabla"); $url1 = "http://www.pagina.com/img/"; while ($row = mysql_fetch_array($result)) { echo "<a href=\"script.php?idpa=".$row["idpa"]."\"><img src=\"".$url1.$row["bang"]."\"></a>"; } ?> Cuando ...
  #1 (permalink)  
Antiguo 10/05/2003, 11:55
Avatar de Salome  
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 1.032
Antigüedad: 15 años, 1 mes
Puntos: 1
Busqueda Que podrá ser??

Tengo esto en php

<?
mysql_connect("localhost","","");
$result=mysql_db_query("caxainte_2","select * from tabla");
$url1 = "http://www.pagina.com/img/";
while ($row = mysql_fetch_array($result))
{
echo "<a href=\"script.php?idpa=".$row["idpa"]."\"><img src=\"".$url1.$row["bang"]."\"></a>";
}
?>

Cuando llamo a este script... no me muestra la imagen.. pero al dar click sobre donde deberia ir la imagen.. pues si me lleva los datos que necesito.. y para donde los necesito.. el problema es no poder ver la imagen... y no se por que?....

Pues, la imagen si esta guardada en el directorio img y en el campo donde tengo bang esta el nombre de la imagen y el id es el correcto.. pero no se porque no muestra la imagen... alguna idea..
  #2 (permalink)  
Antiguo 10/05/2003, 12:34
Avatar de ArrauKano  
Fecha de Ingreso: noviembre-2002
Ubicación: Santiago
Mensajes: 664
Antigüedad: 15 años, 1 mes
Puntos: 4
revizaste el codigo HTML q te resulto de esa consulta?
__________________
Blog | Tecnosquad
  #3 (permalink)  
Antiguo 10/05/2003, 12:46
Avatar de Salome  
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 1.032
Antigüedad: 15 años, 1 mes
Puntos: 1
El codigo html.. no entiendo...
  #4 (permalink)  
Antiguo 10/05/2003, 13:05
 
Fecha de Ingreso: febrero-2003
Ubicación: Viña del Mar
Mensajes: 85
Antigüedad: 14 años, 9 meses
Puntos: 2
ufff..!!

mira hay dos cosas...

1ro si *el problema es no poder ver la imagen* significa que en vez de la imagen sale un cuadro blanco con una equis (X) roja.. significa que no se esta armando bien el nombre de la imagen...

revisa tu BD y verifica que existan datos en la columna "bang" ( si es que existe la columna "bang")

2do que se esta armando bien el nombre de la imagen pero simplemente la imagen no existe ^_^


¿como ver el codigo HTML?

en el IE btn_derecho->Ver codigo Fuente
__________________
http://www.zypper.cl/blues.gif
(web-hosting)

  #5 (permalink)  
Antiguo 10/05/2003, 14:15
Avatar de Salome  
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 1.032
Antigüedad: 15 años, 1 mes
Puntos: 1
Bueno pues el codigo html ya lo habia revisado, al igual que el campo en la base de datos existe asi como el archivo.. pero bueno ya resolvi el lio....

Lo que pasa es que al dar la $url1 me estaba tragando un letra del nombre jumm vaya creo que a todos nos ha pasado alguna vez....

Saludos.. y gracias.. aaahhh por cierto el codigo que pase en el primer mensaje funciona de maravilla!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:52.