Foros del Web » Programando para Internet » PHP »

Que me Recomiendas .??

Estas en el tema de Que me Recomiendas .?? en el foro de PHP en Foros del Web. Tengo Instalado en mi Pc. el PWS (Personal Web Services) y he echo varios(pocos) codigos de ASP. que ahorita estan trabajando... pero quiero tambien programar ...
  #1 (permalink)  
Antiguo 30/07/2003, 08:02
 
Fecha de Ingreso: noviembre-2002
Ubicación: Monterrey N.L. Mexico
Mensajes: 141
Antigüedad: 15 años, 1 mes
Puntos: 0
Que me Recomiendas .??

Tengo Instalado en mi Pc. el PWS (Personal Web Services)
y he echo varios(pocos) codigos de ASP. que ahorita estan trabajando... pero quiero tambien programar en PHP...

por lo que he leido.. es Bajar archivo PHP4.#.#. e instalarlo
en Win98, Me y que puede Trabajar con IIS, PWS, y con un APACHE...

DUDAS...

-> Puedo Trabajar (Bien) con el PWS... o es necesario bajar el
Apache.. ???

-> Si instalo el Apache...es necesario Desinstalar el PWS. ??

-> Instalado el Apache... mis codigos que tengo de ASP..
Trabajan .????

Pueden Ayudarme ..???
Saludos
Luis.R.Acosta
  #2 (permalink)  
Antiguo 30/07/2003, 08:29
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Bueno, si instalas PHP en PWS, estas instalando la version CGI, la cual tiene algunos inconvenientes respecto a la modulo de Apache, como no poder usar la autentificacion HTTP y alguna cosilla mas.

Si puedes tener instalado PWS y Apache a la vez. Si no necesitas que esten funcionando a la vez, es solo apagar uno y encender el otro. Si quieres que esten los dos funcionando, debes cambiar la configuracion de uno de ellos para que en lugar de "escuchar" en el puerto 80, que escuche el puerto 8080, por ejemplo. Luego, para acceder a las paginas de ese servidor deberias poner http://localhost:8080 .

Y en principio Apache creo que no soporta ASP. Bueno, existe un mod asp que se basa en PERL pero creo que solo simila las paginas ASP escritas en PERLScript, no las de VBScript ni JScript. Y habia un soft de chilisoft (ahora creo que es de SUN) que permitia ejecutar paginas ASP en UNIX (creo).

Resumiendo, tus opciones son instalar PHP en PWS o tener PWS y Apache.

Espero haber sido de ayuda.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:28.