Foros del Web » Programando para Internet » PHP »

¿que me sobra?

Estas en el tema de ¿que me sobra? en el foro de PHP en Foros del Web. en un script muestro una imagen de la forma siguiente: <img src="<? echo 'fotos/'.$array[foto1];?>" width="200" border="0"> pero ahora quiero que me muestre esa imagen pero ...
  #1 (permalink)  
Antiguo 14/03/2006, 13:37
Avatar de pereztroff  
Fecha de Ingreso: junio-2002
Ubicación: En la Internet.
Mensajes: 4.068
Antigüedad: 15 años, 6 meses
Puntos: 5
¿que me sobra?

en un script muestro una imagen de la forma siguiente:
<img src="<? echo 'fotos/'.$array[foto1];?>" width="200" border="0">

pero ahora quiero que me muestre esa imagen pero con una marca de agua...
puse esto pero no me muestra bien la imagen ¿que me sobra o falta?

<img src="makeimg.php?photo='<? echo 'fotos/'.$array[foto];?>'" width="200" border="0">

gracias
  #2 (permalink)  
Antiguo 14/03/2006, 14:56
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Pero ... tu "makeimg.php" hace su cometido bien? (probandolo por una llamada directa en el URL: http://www.nose.nose/makeimg.php?photo=.....)

Si no indicas el código de ese "makeimg.php" es complicado ver donde pueda estar el problema .. También es necesario asegurar que $array[foto] tenga el valor esperado (en tu código fuente HTML generado lo puedes ver desde tu navegador ver->código fuente).

Un saludo,
  #3 (permalink)  
Antiguo 14/03/2006, 16:08
Avatar de pereztroff  
Fecha de Ingreso: junio-2002
Ubicación: En la Internet.
Mensajes: 4.068
Antigüedad: 15 años, 6 meses
Puntos: 5
segun el script que uso para marca de agua sobre una imagen jpg
deberi usarse como <img src="makeimg.php?photo=original_photo.jpg">

y funciona perfectamente con una imagen en concreto, lo que intentoesa adaptarlo a como mi script muestra las imagenes.

gracias
  #4 (permalink)  
Antiguo 14/03/2006, 19:04
okram
Invitado
 
Mensajes: n/a
Puntos:
Cita:
Iniciado por pereztroff
<img src="makeimg.php?photo='<? echo 'fotos/'.$array[foto];?>'" width="200" border="0">
me parece que el valor para photo no debe estar entre comillas, algo asi:

Código HTML:
<img src="makeimg.php?photo=<? echo 'fotos/'.$array[foto];?>" width="200" border="0"> 
Si con eso no se soluciona tu problema, prueba hacer un echo del $array[foto] para ver si trae consigo algun dato.

Si aun asi el problema persiste, es necesario que postees el codigo de makeimg.php
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:21.