Foros del Web » Programando para Internet » PHP »

Query funciona correctamente en phpmyadmin, pero no en mi página php

Estas en el tema de Query funciona correctamente en phpmyadmin, pero no en mi página php en el foro de PHP en Foros del Web. Hola a todos, perdon que el titulo sea tan generico, pero no se como ponerlo, el tema es el siguiente. Tengo el siguiente query: Código ...
  #1 (permalink)  
Antiguo 21/07/2010, 18:14
 
Fecha de Ingreso: agosto-2009
Mensajes: 2
Antigüedad: 10 años, 2 meses
Puntos: 0
Exclamación Query funciona correctamente en phpmyadmin, pero no en mi página php

Hola a todos, perdon que el titulo sea tan generico, pero no se como ponerlo, el tema es el siguiente.

Tengo el siguiente query:

Código PHP:
$q_productos "SELECT productos.ID, productos.NOMBRE_PRODUCTO, marcas.NOMBRE_MARCA, categorias.NOMBRE_CATEGORIA
                 FROM panacom_web.marcas, panacom_web.productos, panacom_web.categorias
                 WHERE productos.MARCA = marcas.ID AND productos.CATEGORIA = categorias.ID"

cuando lo corro en phpmyadmin ó cualquier cliente MySQL corre excelente, pero cuando lo ejecuto de esta forma en php, no funciona:
Código PHP:
$productos mysql_query($q_marcas$con) or die(mysql_error()); 
Devuelve el error:

Código HTML:
Query was empty
Yo me imagino que ha de ser algo bien sencillo, y realmente no me considero nuevo programando en mysql ó sql pero en php si...

Espero alguién pueda ayudarme.

Saludos
  #2 (permalink)  
Antiguo 21/07/2010, 18:34
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 13 años, 4 meses
Puntos: 2135
Respuesta: Query funciona correctamente en phpmyadmin, pero no en mi página php

Pues por lo que veo tu estas asignando a $q_productos, pero cuando vas a ejecutar usas $q_marcas la cual no es la variable que estas usando.

Saludos.
  #3 (permalink)  
Antiguo 21/07/2010, 18:44
 
Fecha de Ingreso: agosto-2009
Mensajes: 2
Antigüedad: 10 años, 2 meses
Puntos: 0
Respuesta: Query funciona correctamente en phpmyadmin, pero no en mi página php

Gracias GatorV, lo siento, talves sea el sueño el que ya no me deja poner atención a lo que estoy haciendo.

Gracias

Etiquetas: correctamente, phpmyadmin, query
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:27.