Foros del Web » Programando para Internet » PHP »

Redirección manteniendo el SID

Estas en el tema de Redirección manteniendo el SID en el foro de PHP en Foros del Web. Hola. Tengo un login.php que redirecciona a una página u otra dependiendo de las variables que reciba por el post etc. Lo típico, vamos. El ...
  #1 (permalink)  
Antiguo 19/04/2004, 06:39
 
Fecha de Ingreso: noviembre-2003
Ubicación: Alicante
Mensajes: 52
Antigüedad: 14 años
Puntos: 0
Redirección manteniendo el SID

Hola.

Tengo un login.php que redirecciona a una página u otra dependiendo de las variables que reciba por el post etc. Lo típico, vamos. El problema es que localmente (en mi servidor en mi pc) lo hace perfectamente, sin embargo en el servidor de hosting que tenemos contratado no. Me explico:

// Reenviamos a la pagina principal
header("Location: index.php");
// Si pongo este header, localmente funciona; en el servidor lo único que hace es quedarse en la barra de navegación en el archivo login.php y no redirecciona a ningún sitio. No hay código HTML escrito anteriormente

echo "<META HTTP-EQUIV=Refresh CONTENT=0;URL=index.php>";
// Si pongo esto sí redirecciona, pero no me mantiene el SID (identificador de sesión) y por lo tanto me crea una nueva sesion y no se identifica correctamente.

¿Alguna sugerencia? Mil gracias

Saludos
  #2 (permalink)  
Antiguo 19/04/2004, 07:03
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Para el error que no redirecciona con header(), pon:
Código PHP:
error_reporting(E_ALL); 
para ver si hay algun error. Tambien mira el valor de la directiva display_errors. Puede ser que en tu servidor este deshabilitada la funcion de mostrar mensajes de error, y por eso no te muestra ningun mensaje, aunque pueda haber errores.

Y para pasar el SID por URL, en www.php.net/session te explican como hacerlo.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #3 (permalink)  
Antiguo 19/04/2004, 08:00
 
Fecha de Ingreso: noviembre-2003
Ubicación: Alicante
Mensajes: 52
Antigüedad: 14 años
Puntos: 0
Muchas gracias por tu respuesta Josemi.

Al final lo he tenido que hacer con:

<META HTTP-EQUIV=Refresh CONTENT=0;URL=index.php?<?php echo SID;?> >

ya que aún con el error_reporting(E_ALL); no me daba ningún error, y teniendo activado el display_errors en el servidor. Ahora ya no hay problemas.

Lo dicho, ¡muchas gracias!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:18.