Foros del Web » Programando para Internet » PHP »

register_globals en .htaccess

Estas en el tema de register_globals en .htaccess en el foro de PHP en Foros del Web. Hola, resulta qe necesito en mi hosting donde tengo alojado un website, cambiar el valor de register_globals a on... ok, me dicen que en el ...
  #1 (permalink)  
Antiguo 19/10/2005, 16:18
Avatar de Salome  
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 1.032
Antigüedad: 15 años, 1 mes
Puntos: 1
register_globals en .htaccess

Hola, resulta qe necesito en mi hosting donde tengo alojado un website, cambiar el valor de register_globals a on...

ok, me dicen que en el .htacces ponga esto

php_value register_globals 1

y si efectivamente revisando el phpinfo() me encuentro con que el register_globals cambia a on pero solo en local value porque en master value queda en off y bueno la aplicación en no quiere funcionar con los POST y los GET, no se puede desarrollar de nuevo o hacer el cambio en todas las variables, asi que se requiere que esa directiva este en on..

será que solo es ese el problema que el master value de register_globals esta en off? o puede ser algo más...?? y como puedo cambiarlo desde el .htacces??

Gracias!!!
  #2 (permalink)  
Antiguo 19/10/2005, 18:37
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Esa información de tu php.ini .. justamente el valor de "master value" es lo que php.ini se configuró .. y el "local value" indica que en ese script/directorio se está forzando otra configuración (en tu caso por qué lo haces con tu .htacces).

Lo que manda siempre es tu "local value" .. que "normalmente" suele ser = al "master value" (cuando sólo se altera el php.ini) pero .. no en tu caso como ya estás observando.

En resumen .. ya hicistes el cambio bien .. (haz tus pruebas para salir de dudas). La información que se te presente lo corrobora.

Un saludo,
  #3 (permalink)  
Antiguo 20/10/2005, 09:48
Avatar de Salome  
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 1.032
Antigüedad: 15 años, 1 mes
Puntos: 1
Pues bueno, supuestamente el cambio esta bien... el register_global esta en on, pero local el master dicen en el hosting que por seguridad no lo cambian.. asi que al final no se si eso me esta afectando la aplicación.... porque que otra cosa puede ser?

Monte la aplicación en un ambiente de pruebas.. con php5.0 y tuve que poner el register_global en on porque asi se necesitaba.. y ambos local value y master value han quedado en on, clar que se hizo desde el php.ini... y funciona correctamente, pero en el hosting como lo comenté arriba..no funciona!!
  #4 (permalink)  
Antiguo 20/10/2005, 10:46
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Hacen bien los de tu servicio de hosting diciendote que no van a cambiar dicha directiva .. Adpata tu la aplicación (si, ya sé que puede ser laborioso ..)

Por lo demás, con el .htacces que usas debería funcionar. Consultales a los Srs. de tu servicio de hosting si es que no permiten ese tipo de cambios también via el .htaccess ...

Un saludo,
  #5 (permalink)  
Antiguo 20/10/2005, 11:51
Avatar de Salome  
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 1.032
Antigüedad: 15 años, 1 mes
Puntos: 1
el .htaccess ya lo modifique y pues en el phpinfo() me muestra efectivamente que tengo el local value en on de register globals, por eso se me hace extraño que no funcione.. el problema es que no es solo una aplicación son tres .. y bueno deben funcionar... necesito es saber si algo más puede estar afectando.. el problema solo se presenta con los GET y los POST.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:22.