Foros del Web » Programando para Internet » PHP »

Requisitos PHP para migrar a 4.1.7

Estas en el tema de Requisitos PHP para migrar a 4.1.7 en el foro de PHP en Foros del Web. Hola ! Habitualmente trabajo con PHP, en concreto uso la versión 4.3.3. Tengo una versión mysql bastante antigua y como he visto el incremento de ...
  #1 (permalink)  
Antiguo 24/11/2005, 11:57
 
Fecha de Ingreso: julio-2004
Ubicación: Málaga
Mensajes: 133
Antigüedad: 13 años, 4 meses
Puntos: 1
Requisitos PHP para migrar a 4.1.7

Hola ! Habitualmente trabajo con PHP, en concreto uso la versión 4.3.3. Tengo una versión mysql bastante antigua y como he visto el incremento de funcionalidad de las nuevas versiones (caché de queries, integridad referencial etc) me gustaría actualizar a la versión 4.1 o posterior.

¿Qué versión PHP soporta esta configuración que funcione correctamente? y qué pasos de instalación debo conocer.

Muchas gracias y un saludo.
  #2 (permalink)  
Antiguo 24/11/2005, 12:35
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
(caché de queries, integridad referencial etc)

Esto que mencionas se refiere a la versión de tu Motor de Base de datos que uses .. supongo que te referiras as Mysql?

Concreta mejor las versiones de "Mysql?" que usas y hacia donde quieres migrar ..por qué creo que te refieres a Mysql 3.x o 4.0.x hacia una 4.1.x o incluso 5.x (que ya está lista para usarla en desarrollo).

Un saludo,
  #3 (permalink)  
Antiguo 24/11/2005, 13:32
 
Fecha de Ingreso: julio-2004
Ubicación: Málaga
Mensajes: 133
Antigüedad: 13 años, 4 meses
Puntos: 1
Hola Cluster. Cierto, con el despiste se me olvido concretar que me refiero a MySQL. Ahora uso una MySQL 4.0.x con un PHP 4.3.3 y me gustaría migrar a mySQL 4.1.7 (lo de la 5 todavía me parece pronto aunque ya he liedo que incluye hasta procedimientos almacenados). Me gustaría saber que versión de PHP deberé usar (ya he visto que no me conecta con la que ahora tengo), sé que necesito las librerias mysqli.dll y creo haber visto que sólo están en versiones posteriores a PHP 5. ¿Estoy en lo cierto?

Bueno, a ver si me puedes guiar un poco sobre que versión PHP usar y si necesitaré algo más además de la activación de dicha libreria en el php.ini

Un saludo.
  #4 (permalink)  
Antiguo 24/11/2005, 14:00
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Puedes usar Mysql 4.1.x sobre cualquier versión de PHP. Tambien puedes usar las extensiones mysql (no es obligatorio usar mysqli pero si recomendable para obtener más beneficios: www.php.net/mysqli) para conectarte a Mysql 4.1.x; lo que obtendras si lo haces así será un error tipo:

Cita:
Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client...
Eso se produce por qué Mysql 4.1.x no gestiona igual los usuarios de Mysql vs a las versiones anteriores (desde 4.1.x de Msyql son encritadas las contraseñas de los usuarios) .. En definitiva, puedes usar igualmente esta versión de Mysql pero convirtiendo los usuarios a viejo estilo de gestión de contraseñas:

http://dev.mysql.com/doc/mysql/en/Old_client.html

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:17.