Foros del Web » Programando para Internet » PHP »

Seguridad en PHP5.

Estas en el tema de Seguridad en PHP5. en el foro de PHP en Foros del Web. Estoy tratando de conseguir servicios de hosting, y la mayoria no tiene PHP5. estoy provando www.tangowebs.com y me dicen que la version 5 de PHP ...
  #1 (permalink)  
Antiguo 03/02/2006, 14:34
Avatar de Calisco  
Fecha de Ingreso: marzo-2004
Ubicación: Neuquen
Mensajes: 732
Antigüedad: 13 años, 9 meses
Puntos: 4
Seguridad en PHP5.

Estoy tratando de conseguir servicios de hosting, y la mayoria no tiene PHP5.
estoy provando www.tangowebs.com y me dicen que la version 5 de PHP tiene algunos bugs de seguridad; pero eso no la han instaldo en sus servers.
Que grado de certeza tiene esto ?

Saludos.
__________________
| Cabeza De Raton |
  #2 (permalink)  
Antiguo 03/02/2006, 14:39
Avatar de nicolaspar  
Fecha de Ingreso: noviembre-2004
Ubicación: Villa Ballester Bs-As|Ar
Mensajes: 2.002
Antigüedad: 13 años
Puntos: 34
Ninguno!!!

http://www.php.net/releases.php

Lo mismo esta pasando con mysql 4.1 :/
__________________
Mi punto de partida es Que Bueno Lo Nuevo
  #3 (permalink)  
Antiguo 06/02/2006, 05:31
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Bug .. tiene todo en esta vida ..

Para bien o para mal PHP se caracteriza por hacer público todo tipo de Bug y solventarlo lo antes posible con el lanzamiento de una nueva revisión de PHP (por eso PHP disponde de tanto "n°" para definir su versión: x.y.z).

La escusa que te dá tu proveedor me parece absurda y desmesurada.

Aquí lo único que sucede entre usar PHP 4.x y 5.x es que NO es del todo compatible hacia abajo PHP 5 vs 4 .. hay funciones concretas que podrían no funcionar igual y temas que se tratan de diferente forma. Son muy concretos .. pero seguro que un proveedor cualquiera si cambia de versión de PHP tendría más quejas de programadores que no quieren migrar sus aplicaciones a PHP 5.x o realizar los ajustes necesarios que seguir como estaban.

Lo único que podemos hacer nosostros como "usuarios" de esos servicios de hosting es decir: "Ok, necesito PHP 5 .. UDs. no me lo proporcionan .. me busco otro proveedor". Así . conforme pierdan clientes ya se plantearán instalar PHP 5 (o incluso tener ambas versiones si se lo plantean bien ..).

Un saludo,
  #4 (permalink)  
Antiguo 06/02/2006, 11:18
Avatar de Calisco  
Fecha de Ingreso: marzo-2004
Ubicación: Neuquen
Mensajes: 732
Antigüedad: 13 años, 9 meses
Puntos: 4
Y eso es lo que yo digo. Porque no creo que sea tan dificil para una empresa que se dedique vender hosting ofrecer PHP4 y PHP5. El tema es que la mayoria de los hosting que estuve averiguando tipo planes resellers no tienen PHP5.
__________________
| Cabeza De Raton |
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:10.