Foros del Web » Programando para Internet » PHP »

Sesión no guarda valores

Estas en el tema de Sesión no guarda valores en el foro de PHP en Foros del Web. Llevo un tiempo usando sesiones para la seguridad de mis páginas, y siempre me han funcionado estupendo. Eso hasta hoy, que no sé por qué ...
  #1 (permalink)  
Antiguo 19/08/2006, 20:05
Avatar de quinqui  
Fecha de Ingreso: agosto-2004
Ubicación: Chile!
Mensajes: 776
Antigüedad: 13 años, 3 meses
Puntos: 56
Sesión no guarda valores

Llevo un tiempo usando sesiones para la seguridad de mis páginas, y siempre me han funcionado estupendo.

Eso hasta hoy, que no sé por qué extraña razón, no me está guardando los valores que yo indico en las variables de sesión, por lo que, como es de entender, no me deja entrar a mis páginas seguras.

El asunto va así (los nombres de archivo que doy son sólo a modo de ejemplo):

- Tengo una página simple (ingreso.htm) con el formulario Login que, al ser enviado, llama a otro archivo (login.php) que procesa el llamado, crea la sesión y redirecciona a la página segura (segura.php).

- Lo normal es que, en esta página segura, que inicia ante todo con el famoso "session_start();", pregunto por la variable $_SESSION["login"] (creada en login.php), la cual de tener un valor positivo, permite mostrar el contenido de la página segura; de lo contrario, muestra el texto "Acceso Denegado".

Pues bien, a mí me está mostrando ese mensajito. Sé que no es que no esté creando la sesión, pues yo guardo el SID en mi base de datos, y cuando reviso dicho registro, aparece guardado (ergo, existe).

El sistema me funciona de maravilla en mi servidor local de pruebas (apache bajo windows), sin embargo no funciona en el servidor remoto (pagado); lo loco es que otras páginas seguras que tengo subidas en el mismo servidor remoto SÍ me funcionan perfectamente ........

¿Será que el servidor no me permite tener más de una cantidad limitada de páginas con sesión?

Esop. Espero su respuesta. Muchas gracias de antemano.
__________________
pipus.... vieeeeeji plomius!!!
*quinqui site*
  #2 (permalink)  
Antiguo 19/08/2006, 20:16
Avatar de quinqui  
Fecha de Ingreso: agosto-2004
Ubicación: Chile!
Mensajes: 776
Antigüedad: 13 años, 3 meses
Puntos: 56
No han pasado ni diez minutos y lo he solucionado. Sin embargo, de una manera que no creo verdadera...

Lo que he hecho ha sido abrir la página segura en otra ventana ¬_¬... (darle nombre al Target del Formulario)... No me termino de creer que sólo por eso cambie tanto el asunto y me deje entrar a la página segura...

Espero vuestro comentario. Gracias! ^^U
__________________
pipus.... vieeeeeji plomius!!!
*quinqui site*
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:21.