Foros del Web » Programando para Internet » PHP »

session.auto_start en mi pagina como solucionarlo

Estas en el tema de session.auto_start en mi pagina como solucionarlo en el foro de PHP en Foros del Web. hola, me presenta el siguiente error en mi pagina: Fatal error: Unknown(): The script tried to execute a method or access a property of an ...
  #1 (permalink)  
Antiguo 17/08/2006, 13:55
 
Fecha de Ingreso: abril-2005
Ubicación: en Santa Cruz - España
Mensajes: 429
Antigüedad: 12 años, 8 meses
Puntos: 1
session.auto_start en mi pagina como solucionarlo

hola,

me presenta el siguiente error en mi pagina:

Fatal error: Unknown(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition <b>navigationhistory</b> of the object you are trying to operate on was loaded _before_ the session was started in D:\Inetpub\virtual\herracruz.com\herramientas\incl udes\application_top.php on line 311

leyendo algunos articulos este error se debe a que en el php.ini se debe colocar session.auto_start off
mi problema es que no tengo acceso al servidor y mi proveedor de hosting dice que no puede cambiarlo. La solucion que encontre es que en el archivo .htaccess debo colocar:

<IfModule mod_php4.c>
php_value session.auto_start 0
</IfModule>

pero no entiendo en cual archivo .htaccess?? es que cada carpeta tiene un .htaccess y no se en cual colocarlo.
y otro dato es que me dijeron los archivos .htaccess no tienen efectos en un servidor IIS.

bye.
  #2 (permalink)  
Antiguo 17/08/2006, 15:18
Avatar de ZiTAL  
Fecha de Ingreso: marzo-2004
Ubicación: Bermio (Bizkaia)
Mensajes: 1.545
Antigüedad: 13 años, 9 meses
Puntos: 62
;)

prueba en el .htaccess donde esta el script
__________________
http://zital.no-ip.org
____________________

Euskerie ahuen eta bijotzan
  #3 (permalink)  
Antiguo 17/08/2006, 15:37
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 11 años, 6 meses
Puntos: 2122
Pues aunque el articulo es correcto ese problema es comun cuando guardas un objeto en una variable de sesion, y no incluyes el codigo de la definicion de la clase ANTES que iniciar tu sesion es decir, suponiendo que en $_SESSION['objeto'] guardes tu clase pasa esto:
Código PHP:
session_start();
$_SESSION['objeto']->hazAlgo(); 
Te marca un error como el de arriba en cambio:
Código PHP:
include( "path/hacia/la/clase.php" );
session_start();
$_SESSION['objeto']->hazAlgo(); 
Ya no te marca ningun error.
  #4 (permalink)  
Antiguo 17/08/2006, 16:11
 
Fecha de Ingreso: abril-2005
Ubicación: en Santa Cruz - España
Mensajes: 429
Antigüedad: 12 años, 8 meses
Puntos: 1
Gracias por sus respuestas y por su grandissima ayuda.

zital intente colocarlo en el htaccess donde esta el script pero el problema tambien radica en que tengo varios include de diferentes carpetas eso influira??
o sera que no lo reconoce por el servidor iis???
  #5 (permalink)  
Antiguo 17/08/2006, 16:13
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 11 años, 6 meses
Puntos: 2122
IIS desafortunadamente no soporta .htaccess :(
  #6 (permalink)  
Antiguo 21/08/2006, 09:24
 
Fecha de Ingreso: abril-2005
Ubicación: en Santa Cruz - España
Mensajes: 429
Antigüedad: 12 años, 8 meses
Puntos: 1
entonces la unica solucion es hacer que mi proveedor me active desde el php.ini
o tampoco seria una solucion??
  #7 (permalink)  
Antiguo 21/08/2006, 09:45
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 11 años, 6 meses
Puntos: 2122
Asi es, tu posible solucion es pedirle a tu proveedor que te desactive el session_autostart.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:13.