Foros del Web » Programando para Internet » PHP »

Session y versiones

Estas en el tema de Session y versiones en el foro de PHP en Foros del Web. Hola, estoy intentando usar sesiones, pero con este código simple: <? session_register('contador'); ?> <HTML> <HEAD> <TITLE>contador.php</TITLE> </HEAD> <BODY> <? If (isset($contador)==0) {$contador=0;} ++$contador; echo "<a ...
  #1 (permalink)  
Antiguo 27/04/2004, 06:44
lrn
 
Fecha de Ingreso: marzo-2004
Mensajes: 40
Antigüedad: 13 años, 8 meses
Puntos: 0
Session y versiones

Hola, estoy intentando usar sesiones, pero con este código simple:

<?
session_register('contador');
?>
<HTML>
<HEAD>
<TITLE>contador.php</TITLE>
</HEAD>
<BODY>
<?
If (isset($contador)==0)
{$contador=0;}
++$contador;
echo "<a href=\"contador.php\">Has recargado esta página $contador veces</a>";
?>
</BODY>
</HTML>


tengo los siguientes errores:

Warning: open(/tmp\sess_9de41506850b15dde0a810a9d7523cc7, O_RDWR) failed: m (2) in C:\apache\htdocs\index.php on line 2
Has recargado esta página 1 veces
Warning: open(/tmp\sess_9de41506850b15dde0a810a9d7523cc7, O_RDWR) failed: m (2) in Unknown on line 0

Warning: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

Respecto a la version que uso de php es:

PHP Version 4.0.5
System Windows NT 5.1 build 2600
Build Date Apr 30 2001
Server API CGI
Virtual Directory Support enabled
Configuration File (php.ini) Path C:\apache\php\php.ini
ZEND_DEBUG disabled
Thread Safety enabled

Pienso que es posible que se deba al CGI. Estaría muy agradecido si alguien me ilustrase acerca del problema que tengo, en caso de que mi version de PhPTriad (es lo que uso) no soporte sesiones me gustaria que alguien me dijese que PhPTriad para Windows Xp puedo bajarme que la soporte. Muchas gracias a todos.
  #2 (permalink)  
Antiguo 27/04/2004, 07:02
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Revisa http://www.maestrosdelweb.com/editorial/phpmysqlap/ , la seccion de configuracion de php.ini

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #3 (permalink)  
Antiguo 27/04/2004, 09:19
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
(Y si usas PHP 4.1.0 en adelante .. NO uses session_register() .. usa los arrays superglobales $_SESSION y trabaja con ellas .. Es más seguro: www.php.net/session )

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:20.