Foros del Web » Programando para Internet » PHP »

session_start() me causa error

Estas en el tema de session_start() me causa error en el foro de PHP en Foros del Web. session_start(), me genera un error cuando lo ejecuto, sabe alguien por que puede ser?, dee igual forma cuando uso funciones para generar graficos me generan ...
  #1 (permalink)  
Antiguo 20/03/2003, 07:20
 
Fecha de Ingreso: marzo-2003
Ubicación: Bogota
Mensajes: 83
Antigüedad: 14 años, 8 meses
Puntos: 0
Pregunta session_start() me causa error

session_start(), me genera un error cuando lo ejecuto, sabe alguien por que puede ser?, dee igual forma cuando uso funciones para generar graficos me generan errores (tengo instalado el apache y trabajo en plataforma windows), soy nuevo en esto será que me falta implemartarle algo a la confifuracion del php?

Mil Gracias

WILLIAM FERNANDO
  #2 (permalink)  
Antiguo 20/03/2003, 08:07
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cuando digas "esto o lo otro" me genera un "error" .. DETALLA el error textual que te diga PHP!!!! ..

Pero bueno .. haciendo de adivino creo q será por:

Edita tu php.ini (cuando lo modifiques reinicia tu Apache):
(el php.ini q debes modificar es el que tengas en tu c:\windows\system .. En tado caso el php.ini que "manda" es el que diga tu phpinfo() ...)

Sesiones:
session.save_path = c:\php\sessiones

(indica un directorio que exista en tu PC . por ejemplo crea uno como ese del ejemplo)

Extensiones (en general):
extension_dir = c:\php\extensions

(busca tu directorio extensions\ bajo el directorio de instalación de tu PHP .. ahí tendras un monton de php_xxx.dll que son las extensiones como las de las librerias GD ...)

Libreria GD Activación:
;extension= php_gd.dll

Quitale el ; delante de la extensión que quieras activar.

Reinicia tu Apache y haz un:
Código PHP:
<?
phpinfo
();
?>
Ahí veras las extensiones q instalastes y toda la información de PHP ..

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 20/03/2003, 08:31
Avatar de DINASEN  
Fecha de Ingreso: marzo-2003
Mensajes: 997
Antigüedad: 14 años, 9 meses
Puntos: 1
la libreria ;extension= php_gd.dll
para que es exactamente?¿?

Por que yo la tengo comentada y me funciona bien las sesiones

Un Saludo
  #4 (permalink)  
Antiguo 20/03/2003, 09:14
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126

DINASEN .. lee bien .. Las librerias GD son para gestionar graficos via PHP .. (usa el manual de pHP .. ahí veras información de uso)

En la pregunta se pedia "como usar sessiones" y "como usar esas librerias" ..

Un saludo,
  #5 (permalink)  
Antiguo 20/03/2003, 09:16
Avatar de DINASEN  
Fecha de Ingreso: marzo-2003
Mensajes: 997
Antigüedad: 14 años, 9 meses
Puntos: 1
uffffffffffffffffffff
perdon...jejejejjjejejje

Gracias

Un Saludo
  #6 (permalink)  
Antiguo 20/03/2003, 11:37
 
Fecha de Ingreso: marzo-2003
Ubicación: Bogota
Mensajes: 83
Antigüedad: 14 años, 8 meses
Puntos: 0
mila gracias, pero no me funcionan las imagenes

[Saludos:
Le agradezco por la información sobre las Sesiones, funcionaron de maravilla,

Sin embargo al querer generar imágenes me siguen apareciendo errores:

Ya active la librería de GD , el script es el siguiente:
<?
Header ("Content-type: image/gif");
$im = imagecreate (400, 30);
$black = ImageColorAllocate ($im, 0, 0, 0);
$white = ImageColorAllocate ($im, 255, 255, 255);
ImageGif ($im);
ImageDestroy ($im);
?>

y el error generado es:

Warning: ImageGif: No GIF support in this PHP build in c:\archivos de programa\apache group\apache\htdocs\pruebas\bot.php on line 6

Es decir el ejecutar “ImageGif($im)”.


Gracias por su ayuda
Cordialmente
  #7 (permalink)  
Antiguo 20/03/2003, 11:46
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Warning: ImageGif: No GIF support in this PHP build in c:\archivos de programa\apache group\apache\htdocs\pruebas\bot.php on line 6

Pues el error te lo dice todo .. eso sí en ingles (usa un traductor tipo los servicios de itools.com o algo así ..)

Te dice textualmetne que las funcioens para gestionar imagenes tipo GIF no están disponibles en esa version de las librerias GD q tienes ...

El formato GIF no es GNU .. es propietario de Compuserver si no recuerdo mal .. el caso q tiene (c) el uso de esos algoritmo para -Crear- GIF .. Así q desapareció de las librerias GD el uso de GIF desde hace unas cuantas versiones atras ... Usa cualquier otro formato de los que acepta: png, jpeg ..

Ahora recien para PHP 4.3.2 se va a dar soporte para formato GIF pero solo en modo -Lectura- ..

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:02.