Foros del Web » Programando para Internet » PHP »

Undefied variable pasada por URL en PHP

Estas en el tema de Undefied variable pasada por URL en PHP en el foro de PHP en Foros del Web. Hola a todos: Os cuento cual es mi problema: Estoy desarrollando un site, donde paso algunos parametros por URL, para busqueda en bases de datos ...
  #1 (permalink)  
Antiguo 20/07/2003, 05:16
 
Fecha de Ingreso: junio-2003
Mensajes: 778
Antigüedad: 14 años, 6 meses
Puntos: 1
Undefied variable pasada por URL en PHP

Hola a todos:

Os cuento cual es mi problema:

Estoy desarrollando un site, donde paso algunos parametros por URL, para busqueda en bases de datos MySQL (nombre tabla de la base de datos) y probando en el navegador desde el servidor remoto no tengo ningun problema, pero probando en servidor local (Apache) me dice que la variable no esta definida y me saca el siguiente error:

Notice: Undefined variable: sg in c:\archivos de programa\apache group\apache\htdocs\nuevaweb\escuelas\croquis.php on line 46
cada vez que los scripts recurren a esa variable...

A que puede ser debido??

Gracias
  #2 (permalink)  
Antiguo 20/07/2003, 05:37
 
Fecha de Ingreso: junio-2003
Mensajes: 778
Antigüedad: 14 años, 6 meses
Puntos: 1
Hola :

Ya esta solucionado...

El problema estaba en el orden de las declaraciones de variables.
Estaba utilizando las variables recogidas de la URL sin haberlas declarado con anterioridad...

aaaaaaaaaaaaaaayyyyyy....

Un saludo a todos
  #3 (permalink)  
Antiguo 13/03/2006, 08:20
Avatar de rafaconpu  
Fecha de Ingreso: febrero-2006
Mensajes: 331
Antigüedad: 11 años, 9 meses
Puntos: 3
Ayuda por favor

Hola.

Tengo un problema parecido al tuyo.

Tengo el index.php en el que tengo 4 banderas (espanol, ingles, aleman, frances).

Cada vez que pulso una banderita cargo: web.php?lang=es (para españa)

Entonces cuando se carga web.php quiero recuperar la variable "lang" para ver que valor contiene y cargar un fichero de idiomas u otro dependiendo de su valor.

web.php contiene dos frames y cuando en cada frame pongo esto otro:

$HTTP_GET_VARS['lang'];

me dice que Undefinide index lang in line .... en fin que por lo que parece no está definida la variable.

¿Qué puedo hacer? La culpa creo que están en los frames, pero habrá alguna forma de solucionarlo (eso espero). Ojalá puedas echarme una mano. Gracias.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:26.