Foros del Web » Programando para Internet » PHP »

undefinied variable.... ¿porque?

Estas en el tema de undefinied variable.... ¿porque? en el foro de PHP en Foros del Web. Acabo de instalarme la nueva versión de php, la 4.2.3. Antes todo me iba bien con la versión 4.1.2, pero ahora no me reconoce las ...
  #1 (permalink)  
Antiguo 13/09/2002, 15:38
 
Fecha de Ingreso: septiembre-2002
Ubicación: Tarragona
Mensajes: 7
Antigüedad: 15 años, 3 meses
Puntos: 0
undefinied variable.... ¿porque?

Acabo de instalarme la nueva versión de php, la 4.2.3. Antes todo me iba bien con la versión 4.1.2, pero ahora no me reconoce las variables que paso por la url sin haber tocado nada de código. Curiosamente el PHPMyAdmin sí funciona, eso que tiene paso de variables por url. Ejemplo de una url:

http://localhost/reivax%20world/recop.php?pg=0

Aquí no me reconoce $pg ¿Hay que configurar algo al haber instalado una versión nueva de php? Mi server es el IIS 5 bajo XP.

Saludos!
  #2 (permalink)  
Antiguo 13/09/2002, 15:58
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: undefinied variable.... ¿porque?

Revisa la configuracion de tu PHP (php.ini) .. ahi veras la directiva:

registre_globals = OFF .. pasala a ON para trabajar a la "antigüa" ...

Te recuerdo tambien que este hecho de distribuir PHP con esa directiva a OFF es por algo .. asi q date una vuelta por www.php.net e informate sobre el array "superglobal" ($_GET[] .. $_POST .. etc).

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:14.