Foros del Web » Programando para Internet » PHP »

unlink no me funciona en...

Estas en el tema de unlink no me funciona en... en el foro de PHP en Foros del Web. hola estoy utilizando el unlink para borrar archivos, y he comprobado que me funciona en A: y en D: (una particion de mi disco duro), ...
  #1 (permalink)  
Antiguo 11/01/2004, 06:03
 
Fecha de Ingreso: noviembre-2002
Mensajes: 1.135
Antigüedad: 15 años, 1 mes
Puntos: 2
Exclamación unlink no me funciona en...

hola

estoy utilizando el unlink para borrar archivos, y he comprobado que me funciona en A: y en D: (una particion de mi disco duro), pero en C: no funciona, me dice Permiso Denegado.

dadme un ejemplo concreto para que lo pruebe

gracias
  #2 (permalink)  
Antiguo 11/01/2004, 11:35
 
Fecha de Ingreso: noviembre-2002
Mensajes: 1.135
Antigüedad: 15 años, 1 mes
Puntos: 2
estoy trabajando con IIS, y he probado lo que dicen en varios posts

panel de control>Herramientas administrativas>
administracion de equipos>servicios y aplicaciones>
>servicios ISS>sitio web predeterminado

para configurar los permisos. Pero no hay modo de que me borre en C:
  #3 (permalink)  
Antiguo 11/01/2004, 11:43
 
Fecha de Ingreso: agosto-2002
Ubicación: Colón - Entre Rios - Argentina
Mensajes: 647
Antigüedad: 15 años, 4 meses
Puntos: 8
Si trabajas en NT o XP podra ser que intervengan los permisos del S.O.. ¿estas loggeado con permisos de administrador?

Tambien prueba utilizar chmod() para cambiar los permisos antes de borrarlo a ver que pasa.
Código PHP:
chmod($archivo0777) ; // o algo asi
unlink($archivo); 
Saludos.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:45.