Foros del Web » Programando para Internet » PHP »

upgradeo de php sobre linux y configuracion de bases de datos

Estas en el tema de upgradeo de php sobre linux y configuracion de bases de datos en el foro de PHP en Foros del Web. Hola a todos: Tengo algunas inquietudes que quisiera aclarar, trabajo sobre Red Hat Advanced 3: 1- Quisiera saber cuales son los pasos para upgradear de ...
  #1 (permalink)  
Antiguo 25/05/2005, 11:32
 
Fecha de Ingreso: junio-2004
Mensajes: 185
Antigüedad: 13 años, 6 meses
Puntos: 0
Pregunta upgradeo de php sobre linux y configuracion de bases de datos

Hola a todos:

Tengo algunas inquietudes que quisiera aclarar, trabajo sobre Red Hat Advanced 3:

1- Quisiera saber cuales son los pasos para upgradear de php 4 a php 5 en Red Hat ???

2- Tambien quisiera saber cuales son los pasos a seguir para configurar el php para que tenga soporte de bases de datos postgres ??? En windows es bastante sencillo.


Les agradecería que me ayudaran
Saludos
  #2 (permalink)  
Antiguo 25/05/2005, 13:52
Avatar de sism82  
Fecha de Ingreso: octubre-2003
Ubicación: Guadalajara
Mensajes: 865
Antigüedad: 14 años, 1 mes
Puntos: 1
parece que lo que buscas es un tutorial, uno muy bueno es google.com

saludos
  #3 (permalink)  
Antiguo 25/05/2005, 15:59
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Puedes revisar la documentación oficial de PHP .. ahí veras como "compilar" PHP con las opciones y extensiones que requieras:


http://www.php.net/manual/en/install.unix.php
http://www.php.net/postgresql

También puedes buscarte los RPM adecuados (o comando yum) para instalar PHP y extensiones.. En PHP normalmente no se "upgradea" (refiriendose a sólo cambiar unos cuantos archivos de la instalación original) sino que se desintala todo y se reinstala todo, entre otras cosas por qué por ejemplo extensiones de PHP suelen ser y se compilan para la versión de PHP que se use concretamente .. en otras ocasiones cambia el "php.ini" .. etc ... Lo más sano es partir de una instalación nueva.

(tendras que ver otro manual de instalación de PostgreSQL para Linux)

Un saludo,
  #4 (permalink)  
Antiguo 26/05/2005, 14:11
 
Fecha de Ingreso: junio-2004
Mensajes: 185
Antigüedad: 13 años, 6 meses
Puntos: 0
Gracias por su respuesta Cluster.
Voy a compilar y luego les digo como me fue.

Saludos
  #5 (permalink)  
Antiguo 27/05/2005, 11:41
 
Fecha de Ingreso: junio-2004
Mensajes: 185
Antigüedad: 13 años, 6 meses
Puntos: 0
Hola a todos:

No consigo configurar apache 2 con php 5, trabajo con Red Hat Advanced Server 3. Apache ya instalado

Cuando compilo php5 tal y como dice el manual de instalacion hago lo siguiente:

1- En el manual dice:

./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql

y yo ejecuto:

./configure --with-pgsql

pues en /etc/httpd es donde esta el apache que trae por default el Red Hat y no hay ninguna carpeta dentro de el que contenga apache2/bin/apxs, asi que por eso no pongo esa opcion.

2- make
3- make install

4- Voy al httpd.conf y tal como dice el manual de instalacion pongo:

LoadModule php5_module libexec/libphp5.so

y

AddType application/x-httpd-php .php .phtml



pero cuando reinicio el apaqche, que en Red Hat se hace con service httpd restart,me da este error:

Cannot load /etc/httpd/libexec/libphp5.so into server: /etc/httpd/libexec/libphp5.so: cannot open shared object file: No such file or directory


Alguien me podria decir por que me da este error y como hacerlo bien.

Gracias de antemano
Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:52.