Foros del Web » Programando para Internet » PHP »

Upload de archivos, error por configuracion del servidor

Estas en el tema de Upload de archivos, error por configuracion del servidor en el foro de PHP en Foros del Web. Estaba haciendo un script para subir imagenes al servidor, esto tomando un codigo de ejemplo entontrado en este foro, y en local funcionaba correctamente, pero ...
  #1 (permalink)  
Antiguo 20/01/2006, 22:46
 
Fecha de Ingreso: marzo-2005
Mensajes: 28
Antigüedad: 12 años, 9 meses
Puntos: 0
Sonrisa Upload de archivos, error por configuracion del servidor

Estaba haciendo un script para subir imagenes al servidor, esto tomando un codigo de ejemplo entontrado en este foro, y en local funcionaba correctamente, pero a la hora de subirlo al servidor, este me mostraba un error, andube checando y ese error es debido a que el servidor, por seguridad, no permite accesar a algunos directorios, y pues como el upload de la imagen se hace al directorio tmp o algo asi, pues no me deja copiarlo de alli a un directorio publico para ser visualizado por los visitantes del sitio, tambien encontre que la solucion es que cambien la configuracion del servidor para que permita accesar a esos directorios, pero pues como es por serguridad, no sera cambiado eso.

y pues como se que hay script que aun con esa configuracion permiten subir archivos, pues me gustaria saber si alguien tiene algun codigo de ejemplo, o alguna idea de como hacerlo.

Gracias
  #2 (permalink)  
Antiguo 21/01/2006, 00:44
Avatar de jam1138
/** @package Moderador */
 
Fecha de Ingreso: julio-2004
Ubicación: sèveR led onieR lE
Mensajes: 9.368
Antigüedad: 13 años, 4 meses
Puntos: 101
Cita:
pero a la hora de subirlo al servidor, este me mostraba un error
¿qué error?, ¿con qué código?, ¿cuál ejemplo?...
http://www.forosdelweb.com/f18/como-preguntar-foro-php-cosas-tener-cuenta-295415/


Cita:
y pues como se que hay script que aun con esa configuracion permiten subir archivos, pues me gustaria saber si alguien tiene algun codigo de ejemplo, o alguna idea de como hacerlo.
... haciendola de adivino, quizá estés usando la función copy() bajo safe_mode; en su lugar usa move_uploaded_file(). Tienes un ejemplo general en las FAQ (#12).

Suerte!
__________________
٩(͡๏̯͡๏)۶
» Cómo hacer preguntas de manera inteligente «

"100 años después, la revolución no es con armas, es intelectual y digital"
  #3 (permalink)  
Antiguo 21/01/2006, 15:41
 
Fecha de Ingreso: marzo-2005
Mensajes: 28
Antigüedad: 12 años, 9 meses
Puntos: 0
Pues en efecto, si usaba la funcion COPY y pues alli era donde saltaba el error.

Acabo de cabiar esa funcion con move_uploaded_file y vuelve a funcionar correctamente el script, tanto en local como en el servidor.

Gracias por tu ayuda.

Y respecto a que la informacion no esta mostrada completamente, pues tienes razon, cuando participaba en foros de programacion ese era uno de los motivos por los cuales mejor saltaba a otro mensaje, por tal motivo cuando a mi me tocaba hacer alguna pregunta, trataba de ser lo mas claro posible, sin embargo era frustante ver que entre mas detallada (logica, codigos, imagenes) menos eran las respuestas que recibia asi que por eso, tambien en esta ocacion segui el mismo patron. Y el resultado? pues que en la primera respuesta, aunque a regañadientes (por la falta de mas informacion) se ha dado en el clavo.

Saludos y gracias por tu ayuda.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:53.