Foros del Web » Programando para Internet » PHP »

wap con php, HELP!!

Estas en el tema de wap con php, HELP!! en el foro de PHP en Foros del Web. Hola a todos los maestros del PHP, espero que me ayuden Tengo Windows 2000 server en la cual he instalado apache y php como modulo. ...
  #1 (permalink)  
Antiguo 21/04/2003, 11:54
Avatar de estanislaorc  
Fecha de Ingreso: abril-2003
Ubicación: Peru
Mensajes: 58
Antigüedad: 14 años, 7 meses
Puntos: 0
Pregunta wap con php, HELP!!

Hola a todos los maestros del PHP, espero que me ayuden

Tengo Windows 2000 server en la cual he instalado apache y php como modulo.
Ademas tengo instalado Openwave 5.1(emulador wap).
Estoy interesado en lo que es hacer aplicaciones wap, he realizado algunos ejemplillos con wml y si resultan bien. Pero cuando inserto codigo php para combinar con wml sale mensaje de error.
No se que tengo ke agregar en mi archivo de configuracion del apache o del php.

Atte:estanislaorc
__________________
Web developer
  #2 (permalink)  
Antiguo 21/04/2003, 13:26
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Pues en principio lo que es PHP no tienes que tocar nada .. Solo tienes que respetar la sintax própia de WML como así lo respetas cuando haces apliacaciones para navegadores y usas HTML/javascript ...

Si pones el código que usas y el error que te "dá" .. será mas facil darte alguna solución ...

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 21/04/2003, 14:12
Avatar de estanislaorc  
Fecha de Ingreso: abril-2003
Ubicación: Peru
Mensajes: 58
Antigüedad: 14 años, 7 meses
Puntos: 0
El codigo es el siguiente:
<?
header("Content-type: text/vnd.wap.wml");
?>
<wml>
<card id='home'>
<p>
<? echo "Hola" ; ?>
<p>
</card>
</wml>

y el mensaje de error es:
translation failed for content-type: text/vnd.wap.wml
¿se tiene que hacer algo en la configuracion del apache?
__________________
Web developer
  #4 (permalink)  
Antiguo 21/04/2003, 17:50
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
No sé que significa ese error .. pero en:
http://www.phpbuilder.com/columns/index.php3?cat=all

En la sección WAP tienes 4 artículos sobre PHP+WML ...

En uno de esos artículos hablan de configurar Apache con el módulo mod_rewrite .. Ademas de habilitar las extensiones .wml asociandolas al interprete PHP .. En el resto tienes ejemplos ..

Ademas en los ejemplos se usan las cabeceras XML completas para WML:
php

Código PHP:
<?
Header
("Content-type: text/vnd.wap.wml"); 
Header("Cache-Control: no-cache, must-revalidate"); 
Header("Pragma: no-cache"); 
echo (
"<?xml version='1.0'?>"); 
?> 

<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN" 
    "http://www.wapforum.org/DTD/wml_1.1.xml" > 
<wml> 
etc ... tu código ..
Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #5 (permalink)  
Antiguo 24/12/2004, 14:06
Avatar de gildus  
Fecha de Ingreso: agosto-2003
Mensajes: 1.495
Antigüedad: 14 años, 4 meses
Puntos: 105
Hola estanislaorc, que tu problema es que tienes el archivo guardado con la extension .wml, es decir no es un .php si no un .wml, y por eso te sale el error.

Crea de nuevo un archivo php (con el formato php) y sobre eso colocas los codigos de wml.

Saludos
Gildus
__________________
.: Gildus :.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:40.