Foros del Web » Programando para Internet » PHP »

Warning PHP Startup

Estas en el tema de Warning PHP Startup en el foro de PHP en Foros del Web. PHP Warning: PHP Startup: Unable to load dynamic library 'C:\Program Files\PHP\ext\php_gd2.dll' - No se puede encontrar el módulo especificado. in Unknown on line 0 ¿Alguien ...
  #1 (permalink)  
Antiguo 11/07/2006, 07:25
 
Fecha de Ingreso: junio-2003
Mensajes: 318
Antigüedad: 14 años, 5 meses
Puntos: 0
Pregunta Warning PHP Startup

PHP Warning: PHP Startup: Unable to load dynamic library 'C:\Program Files\PHP\ext\php_gd2.dll' - No se puede encontrar el módulo especificado. in Unknown on line 0


¿Alguien podría darme luz al respecto de este error?
En principio la librería esta subida y con la ruta correcta.
¿Puede ser que php y mysql están rulando bajo windows?
Gracias como siempre a todos
  #2 (permalink)  
Antiguo 11/07/2006, 07:40
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Que significa "la librería está subida"? (no será "habilitada" desde tu php.ini)

Seguro que estás usando la versión GD de la extensión correspondiente (para windows el php_gd2.dll) correspondiente a la versión exacta PHP que usas?

La directiva:
extension_dir = .. apunta al directorio (con ruta completa y absoluta) donde están esas php_xxx.dll ?

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 11/07/2006, 07:53
 
Fecha de Ingreso: junio-2003
Mensajes: 318
Antigüedad: 14 años, 5 meses
Puntos: 0
Tal y como dices la libreria está habilitada.

¿Me quieres decir que existen diferentes php_gd2.dll dependiendo de la versión de php que usas?

La ruta es la correcta.

Gracias por darme luz.
  #4 (permalink)  
Antiguo 11/07/2006, 09:02
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
El detalle es que las php_xxx.dll en windows para PHP se "compilan" para la versión concreta de PHP que uno usa .. Esas php_xxx.dll se distribuyen con PHP (cuando te bajas la versión "Zip package") .. Hago el comentario por qué hay mucha gente (no sé si es tu caso) que por A o B motivo no tiene tal extensión .. la busca en la red y la "copia" en su directorio extensions/ ... en esos casos no suele coincidir o faltan otras .dll auxiliares (librerias) .. el error típico en esos casos es es el que describes.

Por lo demás GD en sí no requiere (en windows) de nada más (niguna otra .dll ..) las librerías GD viene pre-compiladas como parte del "core" de PHP+la extensión. (No es como otras extensiones que si que requieren de librerías .dll extra).

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:44.