Foros del Web » Programando para Internet » PHP »

Webs modulares... ¿es esto correcto?

Estas en el tema de Webs modulares... ¿es esto correcto? en el foro de PHP en Foros del Web. Hola, miren como podrán saber o no, me estoy iniciando en php, y una de las primeras cosas que estoy haciendo son las webs modulares ...
  #1 (permalink)  
Antiguo 13/10/2003, 09:09
Avatar de philipppe  
Fecha de Ingreso: marzo-2002
Ubicación: Uruguay
Mensajes: 706
Antigüedad: 15 años, 8 meses
Puntos: 0
Pregunta Webs modulares... ¿es esto correcto?

Hola, miren como podrán saber o no, me estoy iniciando en php, y una de las primeras cosas que estoy haciendo son las webs modulares [id=nº], me baso en el código de las faqs. Si hago un include a un documento que no tiene etiquetas <html><body>... que creo que es lo correcto, el título de la web se mantiene independientemente de la página en que esté el usuario. Lo que hice fue quitar la etiqueta título de la página madre y colocarlo en las páginas que son incluidas. En consecuencia, el documento queda con dos <body> y dos <head>.
Quería saber si es correcto o alguna alternativa que lo sea, gracias por su ayuda
__________________
Plugin de AdSense para Wordpress: http://adsensei.org
  #2 (permalink)  
Antiguo 13/10/2003, 09:15
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Si no me equivoco, lo navegadores solo toman el primer bloque head. Asi que la solucion es quitar de la "madre" todo el HTML y ponerlo en todas las hijas.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #3 (permalink)  
Antiguo 13/10/2003, 09:37
Avatar de philipppe  
Fecha de Ingreso: marzo-2002
Ubicación: Uruguay
Mensajes: 706
Antigüedad: 15 años, 8 meses
Puntos: 0
Ok, muchas gracias. ¿De este modo es correcto?
Digo, de la otra forma funciona, pero es correcta?
Igualmente voy a usar tu forma, pero quería saber si la otra es correcta.
Gracias nuevamente
__________________
Plugin de AdSense para Wordpress: http://adsensei.org
  #4 (permalink)  
Antiguo 13/10/2003, 15:25
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Mira, si quieres pasate por www.w3c.org y usa su HTML validator. Te dira el numero de errores de la estructura HTML que tienes.

O repasa cualquier manual de HTML. Te dira que la estructura es un solo <html>, un solo <head> y un solo <body>. Todo lo demas es erroneo.

El "problema" es que los navegadores casi siempre han sido muy permisivos que este tipo de errores. Algunos. Por ejemplo, en el IExplorer puedes "olvidarte" cerrar tags como <td>, <tr> o <table> y el IExplorer lo muestra bien. Pero lo intentabas ver en Netscape y solo veias una pagina en blanco. Asi que el IExplorer ha creado malos diseñadores web.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #5 (permalink)  
Antiguo 13/10/2003, 17:11
Avatar de philipppe  
Fecha de Ingreso: marzo-2002
Ubicación: Uruguay
Mensajes: 706
Antigüedad: 15 años, 8 meses
Puntos: 0
Ok, gracias.
Otra cosa: conoces un programa o aplicación que que simule a varios navegadores para probar si se ven bien en otros.
__________________
Plugin de AdSense para Wordpress: http://adsensei.org
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:04.