Foros del Web » Programando para Internet » PHP »

Ya tengo instalado apache2 y php, ahora que?

Estas en el tema de Ya tengo instalado apache2 y php, ahora que? en el foro de PHP en Foros del Web. Hola, estoy empezando desde ceros con esto de la programación en php, por lo que empece por instalar el apache2 y php 4.3.4 en portatil ...
  #1 (permalink)  
Antiguo 20/11/2003, 08:45
 
Fecha de Ingreso: enero-2002
Ubicación: Bogotá
Mensajes: 438
Antigüedad: 15 años, 11 meses
Puntos: 2
Ya tengo instalado apache2 y php, ahora que?

Hola, estoy empezando desde ceros con esto de la programación en php, por lo que empece por instalar el apache2 y php 4.3.4 en portatil que tiene windows 98, pero he llegado a un punto en que no se que más hacer para empezar a programar.

Hay un ejemplo sencillo acerca de php el cual quiero mirar para ver si funciona pero la verdad es que no sucede nada, lo tengo en mi carpeta wwwroot del pws en un subdirectorio que ya tengo configurado como sitio web, pero como digo nada sucede.

Tengo que hacer configuraciones adicionales en el servidor apache o algo asi? Por ayudenme ya que tengo que aprender rápido.

Muchas gracias por la ayuda que me puedan brindar.
  #2 (permalink)  
Antiguo 20/11/2003, 08:53
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Si tienes apache, para que lo pones en el directorio del PWS. Tienes que ponerlo en el directorio del apache. Es en un subdirectorio llamado normalmente htdocs.

Ademas, debes tener ejecutando apache cuando abras el navegador y pongas en la barra de direcciones http://localhost/el_nombre_de_tu_fichero.php

Por cierto, no se si habras leido http://www.maestrosdelweb.com/editorial/phpmysqlap/ . Esta bastante bien y puede aclararte algunas dudas de configuracion.

Suerte.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #3 (permalink)  
Antiguo 20/11/2003, 09:07
 
Fecha de Ingreso: enero-2002
Ubicación: Bogotá
Mensajes: 438
Antigüedad: 15 años, 11 meses
Puntos: 2
Muchas gracias por tu ayuda, ahora me sale el siguiente error:

Error 403 de HTTP
403.1 Prohibido: prohibido el acceso de ejecución

Este error puede producirse si intenta ejecutar un programa CGI, ISAPI u otro programa ejecutable desde un directorio que no permite ejecutar programas.

Póngase en contacto con el administrador del servidor Web si el problema persiste.
  #4 (permalink)  
Antiguo 20/11/2003, 09:16
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Extraño ese error. Porque me suena que es un error de PWS. ¿Lo tienes funcionando? Es que como has comentado que lo tienes, pues no se si te habras hecho un lio con los servidores web. Comprueba cual es el que esta funcionando y si estan los dos, en que puerto esta cada uno (uno estara en el 80, y ese sera el que responda a localhost, el otro responderia a localhost:8080 si escucha en el puerto 8080).

Y apaga el PWS, si es que instalaste y configuraste Apache para funcionar con PHP (y es con apache con el que quieres andar).

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:52.