Foros del Web » Soporte técnico » Ayuda General »

Fórmula en excel

Estas en el tema de Fórmula en excel en el foro de Ayuda General en Foros del Web. Estimado/a, Tengo la sgte tabla en excel Es un crucigrama (o algo parecido), lo que necesito hacer es que al colocar las letras correctas en ...
  #1 (permalink)  
Antiguo 07/03/2019, 12:01
Avatar de causita  
Fecha de Ingreso: mayo-2002
Ubicación: Lima-Perú
Mensajes: 2.040
Antigüedad: 17 años, 6 meses
Puntos: 8
Fórmula en excel

Estimado/a,

Tengo la sgte tabla en excel


Es un crucigrama (o algo parecido), lo que necesito hacer es que al colocar las letras correctas en la columna señalada (las 7 letras), se muestre un mensaje en otra celda al lado del crucigrama. ¿es posible?

Ahora, si es posible validar las 7 palabras (y no solo las 7 letras) para mostrar el mensaje sería mejor aún.

Espero haya manera de poder hacerlo.

Gracias
__________________
|| no hay pregunta tonta....lo q hay son tontos q no preguntan || d-.-b

El Causita
  #2 (permalink)  
Antiguo 12/03/2019, 12:45
Avatar de Rafael
Modegráfico
 
Fecha de Ingreso: marzo-2003
Mensajes: 9.023
Antigüedad: 16 años, 8 meses
Puntos: 1820
Respuesta: Fórmula en excel

Ouch. Sí se puede, pero va a ser bastante manual.

1. Pon en otro lado las fórmulas, tal vez en otra hoja. Todas las fórmulas van en otra celda, el crucigrama no lleva nada. La redacción específica luego la compruebas, ahorita lo estoy escribiendo si revisar la sintáxis específica.

2. Valida las letras de cada casilla: =SI(C1="Z",1,0)

3. Suma las letras correctas: SI(C1+C2+C3=3, "Correcto La palabra es ZAP",0)

4. Usa formato condicional para tener todo en negro, hasta que la respuesta sea diferente a 0, por lo que se coloreará.




---


A la larga se puede "automatizar", poniendo en la hoja 1 el crucigrama, y en la hoja dos la solución al crucigrama.


Haces lo mismo que en mi ejemplo primero, pero ahora comparas la celda de la hoja 1 con la de la hoja 2 para que sean validadas. Algo así:


=SI(Hoja1C1=Hoja2C2,1,0)


Repito, la sintaxis revísala, es sólo la idea del procedimiento.


---


Para validar el mensaje completo, suma los resultados de las palabras. En el punto 3 anterior, en lugar de poner el mensaje de texto, pon SI(C1+C2+C3=3,1,0)


Y en otra celda suma las palabras correctas, en lugar de las letras correctas.


Puedes entonces jugar con las casillas validadoras. Pensemos que las casillas validadoras de las palabras están en la columna P y la de la frase esta en la columa Q:


Si P1+P2+P3 = 1,0


---


La premisa es que cada respuesta correcta, letra o palabra van sumando puntos, y si tienen todos los puntos es que todas las letras están bien.

Última edición por Rafael; 12/03/2019 a las 12:52

Etiquetas: excel
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:53.