Foros del Web » Soporte técnico » Sistemas Operativos »

Problema con Win7 y Ubuntu en BIOS uefi

Estas en el tema de Problema con Win7 y Ubuntu en BIOS uefi en el foro de Sistemas Operativos en Foros del Web. Un saludo al foro: Recientemente me he hecho con un equipo por piezas, algo más actualizado que mi anterior sistema. En él, he intentado recrear ...
  #1 (permalink)  
Antiguo 17/09/2014, 13:08
Avatar de Alun  
Fecha de Ingreso: diciembre-2009
Ubicación: Liverpool
Mensajes: 140
Antigüedad: 10 años, 1 mes
Puntos: 4
Problema con Win7 y Ubuntu en BIOS uefi

Un saludo al foro:

Recientemente me he hecho con un equipo por piezas, algo más actualizado que mi anterior sistema. En él, he intentado recrear los sistemas que tenía en el anterior (windows + ubuntu). En definitiva, he intentado poner un windows 7 home premium (original, cd prestado) 64bit conviviendo con un ubuntu 14.04 64bit. Ambos los estoy intentando instalar en un HD SATA de 500GB, y así tener los otros dos (1 y 2TB) para datos. El problema es, primero, que al particionar el HD, no me deja extender una partición (no tenía ninguna extendida, todas primarias), y luego, creo que esto viene por el nuevo sistema de BIOS, los uefi, si tengo una única partición con windows 7, arranca bien, pero cuando hago más particiones para meter ubuntu, me da error al arrancar (archivo winload.efi ).
La pregunta es, ¿cómo puedo poner estos dos sistemas a convivir en mi equipo,y tener un dual boot como lo tenía antes? Aclaro: antes tenía un XP con un ubuntu en una placa con BIOS Legacy, sin uefi, ambos 32bit.

Mis características son estas:
Las particiones en el HD las he intentado hacer de esta forma:
Código:
-100GB NTFS primaria para Windows 7 (me creaba dos particiones de 100 y 128MB al principio del disco al instalarlo)
-2 GB primaria para la swap
-100GB ext4 primaria para Ubuntu
-Resto ext4 primaria para datos varios
Agradezco cualquier ayuda posible, sobretodo con el tema de las particiones, que me andan dando problemas, y con la BIOS uefi, que no la conozco muy bien aún...
Muchas gracias.
  #2 (permalink)  
Antiguo 24/09/2014, 23:03
Avatar de bahia201  
Fecha de Ingreso: marzo-2014
Mensajes: 188
Antigüedad: 5 años, 10 meses
Puntos: 13
Respuesta: Problema con Win7 y Ubuntu en BIOS uefi

Es por culpa del UEFI, el UEFI tiene varias “mejoras” de seguridad los cuales provocan problemas de este tipo. Lo que tienes que hacer es en el UEFI debe de haber una opción donde y como se llama depende de la marca de la motherboard lo único que te puedo ayudar es que debe de haber una opción que desactive la seguridad del UEFI, también otra que diga modo de arranque por default viene que arranque con UEFI lo debes cambiar a legacy.

La otra hasta donde tengo entendido UBUNTU y varias distros no soporta todavía el arranque con UEFI descarga la versión más nueva y prueba.

La otra vas a tener que borrar todas las particiones que se hallan generado cuando instalaste Windows la razón la instalación en modo UEFI crea particiones adicionales, el problema si dejas la instalación original estas particiones ya no son compatibles con el arranque legacy y te va a mandar un error que no encuentra el disco duro.

Saludos.

ADVERTENCIA
Si no estás seguro no le muevas al UEFI y asesórate con algún técnico es peligroso si le mueves algo que no es.

Etiquetas: boot, dual
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:56.