Foros del Web » Programación » .NET »

Problemas al iniciar Servicio Windows

Estas en el tema de Problemas al iniciar Servicio Windows en el foro de .NET en Foros del Web. Hola a todos! Soy nueva en el foro, escribo porque tengo un problemita, les cuento que estoy haciendo un servicio de windows local con vb ...
  #1 (permalink)  
Antiguo 04/09/2009, 17:01
 
Fecha de Ingreso: septiembre-2009
Mensajes: 5
Antigüedad: 5 años, 1 mes
Puntos: 0
Problemas al iniciar Servicio Windows

Hola a todos!

Soy nueva en el foro, escribo porque tengo un problemita, les cuento que estoy haciendo un servicio de windows local con vb net 2005, lo he creado simple, sin ninguna acción más que un mensaje. El problema radica que cuando lo quiero iniciar desde el administrador de Servicios de Windows, me sale el siguiente error :

"El servicio XYZ en el equipo local se inició y después se detuvo. Algunos servicios se detienen automáticamente sino son usados por ningún servicio o programa"

¿¿alguien puede ayudarme por favor?? He navegado mucho sin encontrar respuesta.

Saludos!
  #2 (permalink)  
Antiguo 08/09/2009, 09:24
Avatar de dwaks  
Fecha de Ingreso: agosto-2002
Ubicación: Panamá
Mensajes: 962
Antigüedad: 12 años, 2 meses
Puntos: 15
Respuesta: Problemas al iniciar Servicio Windows

Los desarrolladores de Windows Services ponen toda la lógica dentro de Clases y las van probando desde un Console Application, de esta forma si funciona en el Console funcionará en el Windows Services. Si un problema surge dentro de el window service se deberá leer sobre como crear un instalador de forma correcta desde el Visual Studio ó como asignar usuario para que le de mejores permisos al Servicio.

Trata de usar siempre un log para saber en que parte de tu código se genera un fallo, trata de usar siempre try y catch para tener control de los error y sucesos y saber que hacer si esto pasa.

Saludos,
  #3 (permalink)  
Antiguo 18/09/2009, 09:27
 
Fecha de Ingreso: septiembre-2009
Mensajes: 5
Antigüedad: 5 años, 1 mes
Puntos: 0
Respuesta: Problemas al iniciar Servicio Windows

Hola dwaks,

Antes que nada gracias por contestar! , te comento que he probado en otro equipo el servicio y sin problemas he podido iniciarlo, por lo que deduzco que el error está en alguna configuración de mi equipo, tengo windows vista ultimate y mi servicio lo generé con VS 2005, por otro lado en mi equipo no se registra nada en el eventlog, solo me indica que ha sido detenido.

Gracias seguiré buscando una respuesta.

Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:42.
SEO by vBSEO 3.3.2