Foros del Web » Programación para mayores de 30 ;) » .NET »

WCF - Problema con el web.config - No detecta la configuracion del Behavior.

Estas en el tema de WCF - Problema con el web.config - No detecta la configuracion del Behavior. en el foro de .NET en Foros del Web. Buenas noches foreros. He creado un WCF Service para ser hospedado vía IIS/WAS en .NET 4.0. He cambiado el nombre de mi Interfaz, y el ...
  #1 (permalink)  
Antiguo 05/01/2012, 21:41
 
Fecha de Ingreso: junio-2003
Ubicación: Asturias
Mensajes: 2.429
Antigüedad: 16 años, 5 meses
Puntos: 7
WCF - Problema con el web.config - No detecta la configuracion del Behavior.

Buenas noches foreros.

He creado un WCF Service para ser hospedado vía IIS/WAS en .NET 4.0.

He cambiado el nombre de mi Interfaz, y el nombre del servicio.

Ejecuté para ver el metadata y se ve perfectamente, pero claro, esta como basicHttp, y como yo lo quería para wsHttp, cambié el archivo de configuración:

Código:
<?xml version="1.0" encoding="utf-8"?>
<configuration>

  <system.web>
    <compilation debug="true" targetFramework="4.0" />
  </system.web>
  <system.serviceModel>
    
    <bindings>
      <wsHttpBinding>
        
        <binding name="wsHttpBindingDefault" >
          <security mode="TransportWithMessageCredential">
            <message clientCredentialType="UserName"/>
          </security>
        </binding>
      </wsHttpBinding>
    </bindings>
    
    <behaviors>      
      <serviceBehaviors>
        <behavior name="behaviorDefault">
          <serviceMetadata httpGetEnabled="true"/>
          <serviceDebug includeExceptionDetailInFaults="false"/>
        </behavior>
      </serviceBehaviors>
    </behaviors>

    <services>

      <service name="TicketOService" behaviorConfiguration="behaviorDefault">
        <endpoint binding="wsHttpBinding" bindingConfiguration="wsHttpBindingDefault"
                  contract="ITicketOService" />
      </service>
    </services>
    
    <serviceHostingEnvironment multipleSiteBindingsEnabled="true" />
  </system.serviceModel>
  
  
 <system.webServer>
    <modules runAllManagedModulesForAllRequests="true"/>
  </system.webServer>
  
</configuration>
El problema está en que cuando entro en mi servicio (http://localhost:7345/TicketOService.svc), me muestra que el metadata está desactivado, cuando estoy indicando claramente en el web.config que quiero publicarlo.

¿Sabén que está pasando?

En fin, espero puedan ayudarme, y desde ya.. les estoy muy agradecido por su tiempo.

Saludos.
__________________
Charlie.
  #2 (permalink)  
Antiguo 05/01/2012, 22:40
 
Fecha de Ingreso: junio-2003
Ubicación: Asturias
Mensajes: 2.429
Antigüedad: 16 años, 5 meses
Puntos: 7
Respuesta: WCF - Problema con el web.config - No detecta la configuracion del Behavio

Solucionado, tenía que poner la ruta completa de mi servicio y de mi contrato. Es decir, los namespaces.

Código:
      <service name="HSoft.TicketExpress.Service.TicketOService" behaviorConfiguration="behaviorDefault">
        <endpoint name="wsHttp" binding="wsHttpBinding" bindingConfiguration="wsHttpBindingDefault"
                  contract="HSoft.TicketExpress.Service.ITicketOService" />
__________________
Charlie.

Etiquetas: detecta, net, wcf
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:33.