Foros del Web » Soporte técnico » Audio y vídeo »

El AVI se 'ralentiza' en el reproductor

Estas en el tema de El AVI se 'ralentiza' en el reproductor en el foro de Audio y vídeo en Foros del Web. Muy buenas a todos. Alguna vez me he servido de vuestras dudas resueltas para sacar adelante las mías propias, pero no he encontrado nada referente ...
  #1 (permalink)  
Antiguo 14/01/2009, 08:59
 
Fecha de Ingreso: enero-2009
Mensajes: 5
Antigüedad: 8 años, 11 meses
Puntos: 0
El AVI se 'ralentiza' en el reproductor

Muy buenas a todos. Alguna vez me he servido de vuestras dudas resueltas para sacar adelante las mías propias, pero no he encontrado nada referente a lo que me ocurre:

Después de exportar en AVI con Premiere CS3 (he probado a exportarlo con todos los códecs que vienen), se reproduce siempre de forma correcta en el ordenador. El problema viene cuando lo pongo en el reproductor de DVD "de casa (que tiene divX)". Ya sea en formato CD de datos con el AVI o con un DVD hecho con NeroVisión a partir del mismo, el video se "ralentiza" al principio, como si le costase cargarlo, y poco a poco va cogiendo velocidad (sólo ocurre con una escena en concreto, que se repite al final, y se vuelve a ralentizar).
Está en formato PAL a 25 fps, y lo he sacado con muchas calidades diferentes (me salen archivos de entre 15 Mb a 2 Gb) y aunque lo recodifique varias veces (grabando el DVD y rippeandolo después, por ejemplo), el archivo resultante siempre vuelve a hacer lo mismo en el DVD (también he probado en varios reproductores DVD y nada). Insisto en que en el ordenador se ve siempre bien, es como si el DVD no "pudiese" con esa escena en concreto.

Mil perdones por enrollarme tanto, y muchas gracias de antemano por vuestro interés
  #2 (permalink)  
Antiguo 14/01/2009, 09:51
Colaborador
 
Fecha de Ingreso: agosto-2004
Mensajes: 1.611
Antigüedad: 13 años, 3 meses
Puntos: 47
Respuesta: El AVI se 'ralentiza' en el reproductor

[email protected] tonyrayito:
No dices de dónde salieron esos videos....
Revisa ese segmento que se está ralentizando, con el Gspot, y compara los parámetros con los parámetros del resto del video; es posible que haya alguna diferencia en algún parámetro y esté dando el problema.
Saludos...
  #3 (permalink)  
Antiguo 14/01/2009, 11:51
Avatar de RobiBaggio
Colaborador
 
Fecha de Ingreso: enero-2005
Ubicación: Mind
Mensajes: 13.554
Antigüedad: 12 años, 11 meses
Puntos: 150
Respuesta: El AVI se 'ralentiza' en el reproductor

Los creas con bitrate constante (CBR) o bitrate variable (VBR)?? esa escena tiene movimiento brusco??
  #4 (permalink)  
Antiguo 15/01/2009, 09:04
 
Fecha de Ingreso: enero-2009
Mensajes: 5
Antigüedad: 8 años, 11 meses
Puntos: 0
Respuesta: El AVI se 'ralentiza' en el reproductor

Uzziber, he probado a mirar con el Gspot, y todo parece estar en orden. Los originales son mpgs que saco de una Canon FS100 (graba en .MOD, pero el programa que trae los pasa a mpg).
RobiBaggio, sí, podría decirse que tiene un movimiento brusco, os explico:
Empieza la peli con un título, hasta ahí todo bien. De repente aparecen unos pies andando sobre un terreno de piedras bastante rápido, en blanco y negro y con el contraste bastante alto (de ahí que a lo mejor no 'pueda' el reproductor). Aquí es donde se frena. Luego, cuando cambia la escena, retoma la velocidad a ritmo normal y, al final, vuelve a salir la misma escena y vuelve a pasar.
Lo que me intriga es que, después de sacarlo en DVD con VBR, el DVD se ve bien en el reproductor, pero al "rippearlo" no. He probado a hacerlo de mil formas, incluyendo el cásico proceso de DVD2AVI, Virtualdub, etc, pero nada. Sé que lo correcto sería sacar el AVI directamente de Premiere, pero no encuentro tampoco la forma de controlar el bitrate etc para que no me salgan archivos de 300 megas para un vídeo de 3 min, que es lo que dura.
Otra explicación: ya sé que es estúpido empeñarse en reproducirlo en un DVD "casero" en formato AVI con divX o lo que sea si en formato DVD se ve bien, pero es para una especie de concurso y nos piden que lo entreguemos en AVI (y sé que lo van a reproducir en un reproductor de estos "de salón". Muchas gracias por vuestras respuestas, espero que me iluminéis con vuestra sabiduría pronto... jejeje. Gracias
  #5 (permalink)  
Antiguo 15/01/2009, 10:50
Avatar de RobiBaggio
Colaborador
 
Fecha de Ingreso: enero-2005
Ubicación: Mind
Mensajes: 13.554
Antigüedad: 12 años, 11 meses
Puntos: 150
Respuesta: El AVI se 'ralentiza' en el reproductor

Ok, vamos por partes, primero, exportas en DivX desde Premiere??? configuras el codec DivX??
  #6 (permalink)  
Antiguo 15/01/2009, 11:17
 
Fecha de Ingreso: enero-2009
Mensajes: 5
Antigüedad: 8 años, 11 meses
Puntos: 0
Respuesta: El AVI se 'ralentiza' en el reproductor

No, he probado a hacerlo de dos formas:

1. desde premiere saco un AVI sin comprimir (o poco comprimido, con un codec tipo Cinepack o Indeo), que aún así ocupa una barbaridad, por lo que uso un programilla de estos típicos "fácil de usar" para sacar un AVI con DivX a una calidad/tamaño aceptable (entre 1000 y 2000 kpbs).

2. Como me pasa esto, pruebo a sacar desde premiere un mpeg2 para dvd, y hago lo necesario para acabar teniendo un DVD que se reproduce perfectamente en el lector. Luego rippeo para sacar el AVI con Divx.

Ninguna de las 2 opciones me funciona (en el ordenador sí, en el reproductor de casa con DivX no), así que llegamos a la conclusión de que lo que falla es, como bien supones, la configuración del codec. Como habrás comprobado, tengo algunas nociones superficiales de estas cosas, pero en cuanto a esto de cómo configurar el codec, no tengo ni idea. He seguido un tutorial para rippear pelícuals "normales" desde el DVD, con una configuracion del codec (que es Xvid4, en este caso) en teoría adecuada para cualquier película "de la calle", y ni por esas, así que me estoy volviendo loco.
Si pudieses ayudarme te lo agradecería muchísimo, ya te digo que es una peli en blanco y negro, con el contraste bastante alto y que donde falla, al pricipio y al final, son movimientos rápidos/bruscos con muchos detallitos en la pantalla (piedras blancas y pantalones negros andando rápido). Mil gracias
  #7 (permalink)  
Antiguo 15/01/2009, 11:28
 
Fecha de Ingreso: enero-2009
Mensajes: 5
Antigüedad: 8 años, 11 meses
Puntos: 0
Respuesta: El AVI se 'ralentiza' en el reproductor

Bueno, he dicho que usaba Xvid, pero sólo en el caso del tutorial ese, me pasa lo mismo con el resto de códecs (mpeg4, divx, etc)
  #8 (permalink)  
Antiguo 15/01/2009, 12:07
Avatar de RobiBaggio
Colaborador
 
Fecha de Ingreso: enero-2005
Ubicación: Mind
Mensajes: 13.554
Antigüedad: 12 años, 11 meses
Puntos: 150
Respuesta: El AVI se 'ralentiza' en el reproductor

ok, esos codecs que usas para AVI (cinepack o indeo) no te sirven, prueba sacando un AVI sin compresión, te mandará un archivo gigante de muchos gigas por pocos minutos de video... Luego pasas ese archivo a DivX con algún convertidor que te acepte dos pasadas como el TMPGEnc 4.0 ... Premiere esta hecho para formatos estandar, fuera de eso se le complica algo la codificación, me parece que no puede ahcer directamete dos pasadas, entonces, deberías sacar algo con calidad total para cubrir el movimiento rápido, y luego reducirlo a un formato DivX usando dos pasadas y VBR para que asigne lo necesario al movimiento. Prueba y nos comentas.
  #9 (permalink)  
Antiguo 18/01/2009, 12:26
 
Fecha de Ingreso: enero-2009
Mensajes: 5
Antigüedad: 8 años, 11 meses
Puntos: 0
Respuesta: El AVI se 'ralentiza' en el reproductor

Ya está solucionado. Al final lo resolví de forma estúpida, no me hizo falta probar esto último que me dijiste: Al grabar el CD/DVD de datos con Nero Express y meter un archivo .AVI, te da la opción (en la barra desplegable) de "maximizar la compatibilidad del archivo con los reproductores de DVD compatibles con mpeg4", o algo así, reemplazando los códigos FourCC o no se qué leches; total, que pude grabar el archivo en calidad muy buena (unos 3000 kpbs) y se ve perfectamente en el reproductor.

Muchas gracias por el interés, cuando tenga dudas ya sé que este es mi foro
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:30.