Foros del Web » Soporte técnico » Audio y vídeo »

Problema al emitir wmv en una web

Estas en el tema de Problema al emitir wmv en una web en el foro de Audio y vídeo en Foros del Web. Hola a todos y gracias de antemano. Resulta que quería insertar en mi web una serie de vídeos en wmv para que se visualizaran cuando ...
  #1 (permalink)  
Antiguo 09/01/2008, 18:51
 
Fecha de Ingreso: enero-2008
Mensajes: 2
Antigüedad: 9 años, 11 meses
Puntos: 0
Problema al emitir wmv en una web

Hola a todos y gracias de antemano.

Resulta que quería insertar en mi web una serie de vídeos en wmv para que se visualizaran cuando el visitante quisiera. Busqué un poco por internet y encontré esto:

"Para añadir un video (avi, mpg, wmv, ram, rm...) o un archivo de audio (wma, mp3, mid...) puedes utilizar la directiva <embed> con los posibles parámetros:

src="fichero" Indica el nombre del fichero

autostart="xxx" Puedes usar true para que empieze a reproducir al cargar la página o false para tener que dar al play para empezar.

loop="xxx" Usa true para que al acabar vuelva a empezar, y false para que no lo haga.

hidden="false" Usa true para ocultar los botones, y false para que se muestren.

width="200" Ancho que ocupará (incluyendo controles)

height="200" Alto que ocupará (incluyendo controles)

Un ejemplo:

<embed src="archivos/mi_archivo.avi" loop=true autostart=false hidden=false width=400 height=200>

El ordenador donde se vea la página debe tener instalado y configurado un reproductor, p. ej. el Windows Media Player, y el codec del archivo si corresponde.

Nota: como suele pasar, no funcionará igual en todos los navegadores. Esto ha sido probado en Internet Explorer 6 a la perfección.

Un saludo"





Bien, lo probé y resulta. El video se ve de p*** m**** y tienes los botones de play, stop, REW, FF,etc. La única condición es que el visitante tenga un reproductor instalado pero creo que todo el mundo lo tenemos hoy en día. Pero hay un problema y es que cuando alguien accede a la web el video está parado y con la pantalla en negro. Hasta que alguien no le da al play, el vídeo permanece así. Y eso hace que la estética de la web se rompa.
La pregunta es sencilla, ¿Qué debo hacer, insertar,etc para que cuando alguien entre haya un fotograma de una imagen fija en el reproctor?. Puede ser el primer frame del video u otro que yo elija, eso me da igual pero no quiero que esté en negro.

Me podéis ayudar?

Última edición por RobiBaggio; 09/01/2008 a las 19:56 Razón: agregar ****
  #2 (permalink)  
Antiguo 09/01/2008, 20:00
Avatar de RobiBaggio
Colaborador
 
Fecha de Ingreso: enero-2005
Ubicación: Mind
Mensajes: 13.554
Antigüedad: 12 años, 10 meses
Puntos: 150
Re: Problema al emitir wmv en una web

[email protected] (nomás modera el lenguaje plis)

Podrías editar el video y dejar un fotograma al inicio, el que tu quieras... Si no funca eso, no creo que mediante HTML se pueda generar algo... Aunque les pese a muchos, creo que una muy buena solución a lo que buscas la encuentras en los reproductores de Flash 8, revisa este sitio donde tengo alguna galería de video, y ve cómo es mejor usar un comonente Flash a uno HTML, así no hya problema por que se tenga instalado el Media Player o el codec, ya que Flash viene en el 98% de las compus de todo el mundo...
  #3 (permalink)  
Antiguo 09/01/2008, 21:36
 
Fecha de Ingreso: enero-2008
Mensajes: 2
Antigüedad: 9 años, 11 meses
Puntos: 0
Re: Problema al emitir wmv en una web

Gracias por la respuesta.

No entiendo lo de "Podrías editar el video y dejar un fotograma al inicio".

Por otra parte, la posibilidad del flash la barajo pero al hacer la conversión del formato de video a flash el archivo acaba pesando siempre un poco más y tiene normalmente un poco menos de calidad. Por eso quería probar directamente con el vídeo antes que con flash. Además, así me ahorro un proceso más de conversión porque normalmente tengo mpeg2 que paso a wmv y luego a flv.
¿tienes alguna manera de simplificar y/o mejorar el proceso?
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:01.