Foros del Web » Creando para Internet » HTML »

3 preguntas acerca de: Imagen en tabla, link desde foto y audio en web

Estas en el tema de 3 preguntas acerca de: Imagen en tabla, link desde foto y audio en web en el foro de HTML en Foros del Web. Hola a todos, es la primera vez que hago un pagina web, un poco buscando de aquí y allá porque no sé apenas sobre informática. ...
  #1 (permalink)  
Antiguo 28/08/2008, 08:52
 
Fecha de Ingreso: agosto-2008
Mensajes: 5
Antigüedad: 9 años, 3 meses
Puntos: 0
3 preguntas acerca de: Imagen en tabla, link desde foto y audio en web

Hola a todos, es la primera vez que hago un pagina web, un poco buscando de aquí y allá porque no sé apenas sobre informática. Tengo no tres, sino millones de preguntas, pero hay algo en especial que me esta haciendo la vida imposible. Quiero colocar como imagen de fondo en una tabla. Sencilllo, teniendo en cuenta que funciona con todas las fotos menos con las dos que necesito, que son imagenes que he creado con Freehand y Photoshop. Otras imágenes que he creado yo funcionan, con lo cual no veo donde está error. En Dreamweaver se ven, pero ningún explorador las muestra (Internet Explorer, Safari y Firefox). ??????????!!!!!!!
2º misterio: Cómo puedo hacer para que al clicar sobre una imagen se abra una nueva ventana donde aparezca la imagen ampliada.
Y aquí está mi última duda. Conseguí introducir un image viewer, un reproductor de audio (externo a Dreamweaver), pero....¿cómo hago para insertar video?????!!
Os agradecería mucho que pudiérais ayudarme en esto,
Saludos,
Montse
  #2 (permalink)  
Antiguo 28/08/2008, 09:34
Avatar de poison_mayer  
Fecha de Ingreso: julio-2008
Mensajes: 69
Antigüedad: 9 años, 5 meses
Puntos: 2
Respuesta: 3 preguntas acerca de: Imagen en tabla, link desde foto y audio en web

Hola pocoyita

1- Qué extensiones tienen las imágenes que has creado? Trata utilizando imágenes con extensiones .jpg .gif .png.

2- Una vía sencilla puede ser esta <a href="imagen.gif" target="_blank"><img src="imagen.gif" alt="imagen" width="105" height="82" border="0" /></a>
donde al insertar la imagen cambias sus valores originales de width (ancho) y alto (height) por valores mas pequeños.

3- Para videos prueba algo de esto

test.mpg

mime type: video/mpeg
code :

<object data="data/test.mpg" type="video/mpeg" width="320" height="255">
<param name="src" value="data/test.mpg">
<param name="autoplay" value="false">
<param name="autoStart" value="0">
alt : <a href="data/test.mpg">test.mpg</a>
</object>

result :
alt : test.mpg
observed results in various browsers : Firefox 1.5 Firefox 1.0.7 Opera 9 Konqueror 3.5.2 Safari 2.0.4 IE 7rc1 IE 6 IE 5.5 IE 5.0.1 IE 4.0.1 IE Mac 5.2.3 Lynx 2.8.5
success success success success success success success success success success success degrade correctly
test.avi

mime type: video/avi
code :

<object data="data/test.avi" type="video/x-msvideo" width="320" height="255">
<param name="src" value="data/test.avi">
<param name="autoStart" value="0">
alt : <a href="data/test.avi">test.avi</a>
</object>

result :
alt : test.avi
observed results in various browsers : Firefox 1.5 Firefox 1.0.7 Opera 9 Konqueror 3.5.2 Safari 2.0.4 IE 7rc1 IE 6 IE 5.5 IE 5.0.1 IE 4.0.1 IE Mac 5.2.3 Lynx 2.8.5
success success success success success success success success success success success degrade correctly
test.wmv

mime type: video/x-ms-wmv
code :

<object type="video/x-ms-wmv" data="data/test.wmv" width="320" height="255">
<param name="src" value="data/test.wmv">
<param name="autoStart" value="0">
alt : <a href="data/test.wmv">test.wmv</a>
</object>

result :
alt : test.wmv
observed results in various browsers : Firefox 1.5 Firefox 1.0.7 Opera 9 Konqueror 3.5.2 Safari 2.0.4 IE 7rc1 IE 6 IE 5.5 IE 5.0.1 IE 4.0.1 IE Mac 5.2.3 Lynx 2.8.5
success success success success degrade correctly success success success success success degrade correctly degrade correctly
test.mov

mime type: video/quicktime
simple nested object tags
code :

<object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B"
codebase="http://www.apple.com/qtactivex/qtplugin.cab"
width="320" height="255">
<param name="src" value="data/test.mov" >
<param name="controller" value="true" >
<param name="autoplay" value="false">

<object type="video/quicktime" data="data/test.mov" width="320" height="255">
<param name="controller" value="true" >
<param name="autoplay" value="false">
alt : <a href="data/test.mov">test.mov</a>
</object>
</object>

result :
alt : test.mov
observed results in various browsers : Firefox 1.5 Firefox 1.0.7 Opera 9 Konqueror 3.5.2 Safari 2.0.4 IE 7rc1 IE 6 IE 5.5 IE 5.0.1 IE 4.0.1 IE Mac 5.2.3 Lynx 2.8.5
success success success success success success failed failed failed failed success degrade correctly

IE display the content of the first object, and a blank zone for the nested one.
nested object tags with IE conditional comments
code :

<object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B"
codebase="http://www.apple.com/qtactivex/qtplugin.cab"
width="320" height="255">
<param name="src" value="data/test.mov" >
<param name="controller" value="true" >
<param name="autoplay" value="false">

<!--[if gte IE 7]> <!-->
<object type="video/quicktime" data="data/test.mov" width="320" height="255">
<param name="controller" value="true" >
<param name="autoplay" value="false">
alt : <a href="data/test.mov">test.mov</a>
</object>
<!--<![endif]-->
<!--[if lt IE 7]>
alt : <a href="data/test.mov">test.mov</a>
<![endif]-->
</object>

result :
alt : test.mov
observed results in various browsers : Firefox 1.5 Firefox 1.0.7 Opera 9 Konqueror 3.5.2 Safari 2.0.4 IE 7rc1 IE 6 IE 5.5 IE 5.0.1 IE 4.0.1 IE Mac 5.2.3 Lynx 2.8.5
success success success success success success success success success failed success degrade correctly

IE4 don't understand the conditional comments, so he display a blank zone for the nested object. But the embed content is correctly display by the first one.
nested object tags, nested object hidden by css
code :

<style type="text/css">
/* class to hide nested objects in IE */
/* hides the second object from all versions of IE */
* html object.hiddenObjectForIE { display: none; }

/* display the second object only for IE5 Mac */
/* IE Mac \*//*/
* html object.hiddenObjectForIE { display: inline; }
/**/
</style>

code :

<object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B"
codebase="http://www.apple.com/qtactivex/qtplugin.cab"
width="320" height="255">
<param name="src" value="data/test.mov" >
<param name="controller" value="true" >
<param name="autoplay" value="false">

<object type="video/quicktime" data="data/test.mov"
width="320" height="255" class="hiddenObjectForIE">
<param name="controller" value="true" >
<param name="autoplay" value="false">
alt : <a href="data/test.mov">test.mov</a>
</object>
</object>

result :
alt : test.mov
observed results in various browsers : Firefox 1.5 Firefox 1.0.7 Opera 9 Konqueror 3.5.2 Safari 2.0.4 IE 7rc1 IE 6 IE 5.5 IE 5.0.1 IE 4.0.1 IE Mac 5.2.3 Lynx 2.8.5
success success success success success success success success success success success degrade correctly

espero te sirva
  #3 (permalink)  
Antiguo 28/08/2008, 09:41
Avatar de poison_mayer  
Fecha de Ingreso: julio-2008
Mensajes: 69
Antigüedad: 9 años, 5 meses
Puntos: 2
Respuesta: 3 preguntas acerca de: Imagen en tabla, link desde foto y audio en web

Hola pocoyita

1- Qué extensiones tienen las imágenes que has creado? Trata utilizando imágenes con extensiones .jpg .gif .png.

2- Una vía sencilla puede ser esta <a href="imagen.gif" target="_blank"><img src="imagen.gif" alt="imagen" width="105" height="82" border="0" /></a>
donde al insertar la imagen cambias sus valores originales de width (ancho) y alto (height) por valores mas pequeños.

3- Para videos prueba algo de esto

test.mpg

mime type: video/mpeg
code :

<object data="data/test.mpg" type="video/mpeg" width="320" height="255">
<param name="src" value="data/test.mpg">
<param name="autoplay" value="false">
<param name="autoStart" value="0">
alt : <a href="data/test.mpg">test.mpg</a>
</object>

result :
alt : test.mpg
observed results in various browsers : Firefox 1.5 Firefox 1.0.7 Opera 9 Konqueror 3.5.2 Safari 2.0.4 IE 7rc1 IE 6 IE 5.5 IE 5.0.1 IE 4.0.1 IE Mac 5.2.3 Lynx 2.8.5
success success success success success success success success success success success degrade correctly
test.avi

mime type: video/avi
code :

<object data="data/test.avi" type="video/x-msvideo" width="320" height="255">
<param name="src" value="data/test.avi">
<param name="autoStart" value="0">
alt : <a href="data/test.avi">test.avi</a>
</object>

result :
alt : test.avi
observed results in various browsers : Firefox 1.5 Firefox 1.0.7 Opera 9 Konqueror 3.5.2 Safari 2.0.4 IE 7rc1 IE 6 IE 5.5 IE 5.0.1 IE 4.0.1 IE Mac 5.2.3 Lynx 2.8.5
success success success success success success success success success success success degrade correctly
test.wmv

mime type: video/x-ms-wmv
code :

<object type="video/x-ms-wmv" data="data/test.wmv" width="320" height="255">
<param name="src" value="data/test.wmv">
<param name="autoStart" value="0">
alt : <a href="data/test.wmv">test.wmv</a>
</object>

result :
alt : test.wmv
observed results in various browsers : Firefox 1.5 Firefox 1.0.7 Opera 9 Konqueror 3.5.2 Safari 2.0.4 IE 7rc1 IE 6 IE 5.5 IE 5.0.1 IE 4.0.1 IE Mac 5.2.3 Lynx 2.8.5
success success success success degrade correctly success success success success success degrade correctly degrade correctly
test.mov

mime type: video/quicktime
simple nested object tags
code :

<object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B"
codebase="http://www.apple.com/qtactivex/qtplugin.cab"
width="320" height="255">
<param name="src" value="data/test.mov" >
<param name="controller" value="true" >
<param name="autoplay" value="false">

<object type="video/quicktime" data="data/test.mov" width="320" height="255">
<param name="controller" value="true" >
<param name="autoplay" value="false">
alt : <a href="data/test.mov">test.mov</a>
</object>
</object>

result :
alt : test.mov
observed results in various browsers : Firefox 1.5 Firefox 1.0.7 Opera 9 Konqueror 3.5.2 Safari 2.0.4 IE 7rc1 IE 6 IE 5.5 IE 5.0.1 IE 4.0.1 IE Mac 5.2.3 Lynx 2.8.5
success success success success success success failed failed failed failed success degrade correctly

IE display the content of the first object, and a blank zone for the nested one.
nested object tags with IE conditional comments
code :

<object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B"
codebase="http://www.apple.com/qtactivex/qtplugin.cab"
width="320" height="255">
<param name="src" value="data/test.mov" >
<param name="controller" value="true" >
<param name="autoplay" value="false">

<!--[if gte IE 7]> <!-->
<object type="video/quicktime" data="data/test.mov" width="320" height="255">
<param name="controller" value="true" >
<param name="autoplay" value="false">
alt : <a href="data/test.mov">test.mov</a>
</object>
<!--<![endif]-->
<!--[if lt IE 7]>
alt : <a href="data/test.mov">test.mov</a>
<![endif]-->
</object>

result :
alt : test.mov
observed results in various browsers : Firefox 1.5 Firefox 1.0.7 Opera 9 Konqueror 3.5.2 Safari 2.0.4 IE 7rc1 IE 6 IE 5.5 IE 5.0.1 IE 4.0.1 IE Mac 5.2.3 Lynx 2.8.5
success success success success success success success success success failed success degrade correctly

IE4 don't understand the conditional comments, so he display a blank zone for the nested object. But the embed content is correctly display by the first one.
nested object tags, nested object hidden by css
code :

<style type="text/css">
/* class to hide nested objects in IE */
/* hides the second object from all versions of IE */
* html object.hiddenObjectForIE { display: none; }

/* display the second object only for IE5 Mac */
/* IE Mac \*//*/
* html object.hiddenObjectForIE { display: inline; }
/**/
</style>

code :

<object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B"
codebase="http://www.apple.com/qtactivex/qtplugin.cab"
width="320" height="255">
<param name="src" value="data/test.mov" >
<param name="controller" value="true" >
<param name="autoplay" value="false">

<object type="video/quicktime" data="data/test.mov"
width="320" height="255" class="hiddenObjectForIE">
<param name="controller" value="true" >
<param name="autoplay" value="false">
alt : <a href="data/test.mov">test.mov</a>
</object>
</object>

result :
alt : test.mov
observed results in various browsers : Firefox 1.5 Firefox 1.0.7 Opera 9 Konqueror 3.5.2 Safari 2.0.4 IE 7rc1 IE 6 IE 5.5 IE 5.0.1 IE 4.0.1 IE Mac 5.2.3 Lynx 2.8.5
success success success success success success success success success success success degrade correctly

espero te sirva
  #4 (permalink)  
Antiguo 28/08/2008, 12:30
 
Fecha de Ingreso: agosto-2008
Mensajes: 5
Antigüedad: 9 años, 3 meses
Puntos: 0
Respuesta: 3 preguntas acerca de: Imagen en tabla, link desde foto y audio en web

Muchas gracias, Poison_mayer!!!!

Probé con el código del video, funcionaaaaa!!
Sobre el problema con las imágenes que no se ven....són .jpg, pero he probado a guardarlas con distintas extensiones, .gif, .png... y tampoco no funciona.Me gustaría saber dónde está el fallo, no sé si en las fotos, en el dreamweaver, sé que no es el explorador, pq no se ven en ninguno.
Y con respecto al codigo que me has dado, las fotos están colocadas en un visor, dónde tengo que incluir el código?
Mil gracias otra vez
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:05.