Foros del Web » Creando para Internet » HTML »

agrege un frame y se fue todo

Estas en el tema de agrege un frame y se fue todo en el foro de HTML en Foros del Web. yo hice el header con menu incluido en otra seccion y lo puse con frame y al ponerle el frame desaparecio todo, ese frame esta ...
  #1 (permalink)  
Antiguo 06/08/2008, 16:55
Avatar de almagropaco_  
Fecha de Ingreso: marzo-2008
Ubicación: Mar del Plata
Mensajes: 854
Antigüedad: 9 años, 8 meses
Puntos: 25
agrege un frame y se fue todo

yo hice el header con menu incluido en otra seccion y lo puse con frame y al ponerle el frame desaparecio todo, ese frame esta a dentro de un div..
desaparecieron los otros divs:S

Por favor vizualicen con Firefox bueno, la pagina es www.tiburonmdp.com.ar/home.php
abajo del header tendria que haber 3 mas , bueno, se daran cuenta en el codigo fuente. que aca lo cito..

Código HTML:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="es"
xml:lang="es">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=spa" />
<title>TIBURON MDP | Sitio no oficial.</title>
<style type="text/css">
<!--
#Layer1 {
	position:absolute;
	left:2px;
	top:0px;
	width:392px;
	height:137px;
	z-index:1;
}
#Layer2 {
	position:absolute;
	left:-2px;
	top:2px;
	width:1023px;
	height:219px;
	z-index:1;
}
#Layer3 {
	position:absolute;
	left:2px;
	top:230px;
	width:177px;
	height:1395px;
	z-index:2;
	background-color: #009900;
}
#Layer4 {
	position:absolute;
	left:184px;
	top:230px;
	width:580px;
	height:1394px;
	z-index:3;
	background-color: #FFFFFF;
}
#Layer5 {
	position:absolute;
	left:787px;
	top:230px;
	width:203px;
	height:1395px;
	z-index:4;
}

-->
</style>
<style type="text/css">
<!--
body,td,th {
	font-family: Geneva, Arial, Helvetica, sans-serif;
	font-size: 12 px;
	color: YELLOW;
}

-->
</style>
<link rel="StyleSheet" href="estilo.css" type="text/css">

<script language="javascript">
<!--
mydate = new Date();
myday = mydate.getDay();
mymonth = mydate.getMonth();
myweekday= mydate.getDate();
weekday= myweekday;

if(myday == 0)
day = " Domingo "

else if(myday == 1)
day = " Lunes "

else if(myday == 2)
day = " Martes "

else if(myday == 3)
day = " Miercoles "

else if(myday == 4)
day = " Jueves "

else if(myday == 5)
day = " Viernes "

else if(myday == 6)
day = " Sabado "

if(mymonth == 0)
month = "Enero "

else if(mymonth ==1)
month = "Febrero "

else if(mymonth ==2)
month = "Marzo "

else if(mymonth ==3)
month = "Abril "

else if(mymonth ==4)
month = "Mayo "

else if(mymonth ==5)
month = "Junio "

else if(mymonth ==6)
month = "Julio "

else if(mymonth ==7)
month = "Agosto "

else if(mymonth ==8)
month = "Setiembre "

else if(mymonth ==9)
month = "Octubre "

else if(mymonth ==10)
month = "Noviembre "

else if(mymonth ==11)
month = "Diciembre "
// -->
</script>
<style type="text/css">
<!--
.Estilo1 {font-weight: bold}
-->

</style></head>

<body bgcolor="#000000">
<div id="Layer2"><font color="FFFFFF" size="2">
  <center><script>document.write("  Bienvenido, Hoy es"+ day);document.write(myweekday+" de "+month+ "");</script> y tu IP es 190.49.124.24</font></center>
<br>
<iframe src="http://www.tiburonmdp.com.ar/menu.html" width="1020" height="180">
</div>
<div class="Estilo2" id="Layer3">
  <script src="http://www.gmodules.com/ig/ifr?url=http://www.google.com/ig/modules/translatemypage.xml&up_source_language=es&w=160&h=60&title=&border=&output=js"></script>
  <br>
  <br>
  <center>Ultimo momento Ole</center>
  
  <iframe src=" http://static.grazr.com/gzpanel.html?view=o&theme=home_black&file=http://www.ole.clarin.com/diario/hoy/home.rss?hl=es&ned=es&q=&ie=UTF-8&output=rss " width="150" height="300">
<br>
<br>
<center>Ultimo momento Clarin</center>
<iframe src=" http://static.grazr.com/gzpanel.html?view=o&theme=home_black&file=http://www.clarin.com/diario/hoy/um/sumariorss.xml?hl=es&ned=es&q=Boca&ie=UTF-8&output=rss " width="150" height="300">
<br>
</div>
<div id="Layer4">
  <div align="center" class="Estilo1"><table background="verde.gif" height="10" width="600">
<tr>
<td><center>
  Bienvenidos a Tiburon MDP!
</center>

</td>

</tr>

</table>

</div>
  <font color="00000F" size="3"><center></center>
  </font></div>

<div id="Layer5">
  <iframe src="http://www.tiburonmdp.com.ar/derecha.php" width="203" height="1000">
</div>

</body>
</html> 

Otra cosa, con Opera no se como se vera.. tengo el firefox 3.

Pd: estoy editando la web con dreamweaver 8

Última edición por almagropaco_; 06/08/2008 a las 19:11
  #2 (permalink)  
Antiguo 07/08/2008, 00:24
Avatar de Julcar  
Fecha de Ingreso: noviembre-2007
Ubicación: C:\inetpub\wwwroot\Guayaquil
Mensajes: 1.500
Antigüedad: 10 años
Puntos: 53
Respuesta: agrege un frame y se fue todo

En la especificación DTD debes establecer el Frameset, ello soluciona problemas de visualización de frames.
  #3 (permalink)  
Antiguo 07/08/2008, 08:50
Avatar de almagropaco_  
Fecha de Ingreso: marzo-2008
Ubicación: Mar del Plata
Mensajes: 854
Antigüedad: 9 años, 8 meses
Puntos: 25
Respuesta: agrege un frame y se fue todo

Y como se especifica, no faltan solo 3 frames (dos en un div y uno en otro) si no que tambien falta otro div , que adentro no tenia frames, solo información escrita..


Código HTML:
<div id="Layer4">
  <div align="center" class="Estilo1"><table background="verde.gif" height="10" width="600">
<tr>
<td><center>
  Bienvenidos a Tiburon MDP!
</center>

</td>

</tr>

</table>

</div> 
Dice solo el Bienvenido ! con un fondo atras, pero es porque la web ahora solo la estoy trabajando en diseño, va en lo que puedo de ello, no entiendo mucho:P

Bueno, el DTD ya se donde esXD pero me falta eso de la especificación que vos decis.. Muchas Gracias..


PD: probando la web me di cuenta qe el menu al estar en un frame los links se abren en el frame ese mismo, entonces queda reducido el tamaño, eso es obvio, pero no lo habia pensado.. aca les paso el HTML del css para que me digan como hacer para que los links se abran en una nueva pestaña,

Código HTML:
<ul class="menu3">
<li><a href="/home.php"><b>Home</b></a></li>
<li><a href="/elclub.php"><b>Historia Aldosivi</b></a></li>
<li><a href="/general.php"><b>Posiciones y etc..</b></a></li>
<li><a href="http://www.blogs.clarin.com/tiburonmdp/"><b>Blog</b></a></li>
<li><a href="/contacto.php"><b>Contacto</b></a></li>
<li><a href="/links.php"><b>Links</b></a></li>
<li><a href="/libro.php"><b>Libro de Visitas</b></a></li>
<li><a href="http://www.aldosivi.com/asociate.php"><b>Asociate</b></a></li>
<li><a href="/fixture.php"><b>Fixture Aldosivi</b></a></li>
</ul> 
Si no mal recuerdo era class="new" .. pero no recuerdo donde ni como va..

Última edición por almagropaco_; 07/08/2008 a las 08:58
  #4 (permalink)  
Antiguo 08/08/2008, 02:04
Avatar de NhB
NhB
 
Fecha de Ingreso: agosto-2008
Mensajes: 3
Antigüedad: 9 años, 4 meses
Puntos: 0
Respuesta: agrege un frame y se fue todo

Segun lo q entendi agregas el frame y se te borra marte de la web

bueno mira esto e ha pasado y lo soluciono cerrando la etiqueta iframe:

Código HTML:
<iframe src=" http://static.grazr.com/gzpanel.html?view=o&theme=home_black&file=http://www.ole.clarin.com/diario/hoy/home.rss?hl=es&ned=es&q=&ie=UTF-8&output=rss " width="150" height="300"></iframe>
<br>
<br>
<center>Ultimo momento Clarin</center>
<iframe src=" http://static.grazr.com/gzpanel.html?view=o&theme=home_black&file=http://www.clarin.com/diario/hoy/um/sumariorss.xml?hl=es&ned=es&q=Boca&ie=UTF-8&output=rss " width="150" height="300"></iframe>
<br>
</div>
<div id="Layer4">
  <div align="center" class="Estilo1"><table background="verde.gif" height="10" width="600"></iframe>
<tr>
<td><center>
  Bienvenidos a Tiburon MDP!
</center>

</td>

</tr>

</table>

</div>
  <font color="00000F" size="3"><center></center>
  </font></div>

<div id="Layer5">
  <iframe src="http://www.tiburonmdp.com.ar/derecha.php" width="203" height="1000"></iframe>
</div>

</body>
</html> 
  #5 (permalink)  
Antiguo 08/08/2008, 11:59
Avatar de almagropaco_  
Fecha de Ingreso: marzo-2008
Ubicación: Mar del Plata
Mensajes: 854
Antigüedad: 9 años, 8 meses
Puntos: 25
Respuesta: agrege un frame y se fue todo

ahora pruebo y edito poniendo como me fue. Nunca vi que habia que cerrarlasXD

sera que soy muy nuevo


Gracias a los dos

PD: Me fue perfecto y ahora solucione muchos mas problemas.. la web no es MUY vistosa, pero eh logrado que dentro de ese estilo quede bien..

Última edición por almagropaco_; 08/08/2008 a las 17:15
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:02.