Foros del Web » Creando para Internet » HTML »

alt, no funciona con explorer 8

Estas en el tema de alt, no funciona con explorer 8 en el foro de HTML en Foros del Web. Hola a todos He instalado la nueva version de explorer para windows vista y no me funciona el atributo "ALT". que debo hacer? Saludos y ...
  #1 (permalink)  
Antiguo 25/05/2009, 16:49
 
Fecha de Ingreso: abril-2009
Mensajes: 27
Antigüedad: 8 años, 7 meses
Puntos: 0
alt, no funciona con explorer 8

Hola a todos

He instalado la nueva version de explorer para windows vista y no me funciona el atributo "ALT". que debo hacer?

Saludos y gracias
  #2 (permalink)  
Antiguo 25/05/2009, 16:55
Avatar de hades87  
Fecha de Ingreso: diciembre-2007
Ubicación: Barcelona - España
Mensajes: 3.194
Antigüedad: 10 años
Puntos: 68
Respuesta: alt, no funciona con explorer 8

estás seguro de que no funcionan? no tendrás algo que lo bloquea o solo será una web?
__________________
No diseñes usando tablas.
  #3 (permalink)  
Antiguo 25/05/2009, 17:01
Avatar de webosiris
Moderador egiptólogo
 
Fecha de Ingreso: febrero-2002
Ubicación: Luxor, Egipto
Mensajes: 10.727
Antigüedad: 15 años, 10 meses
Puntos: 997
Respuesta: alt, no funciona con explorer 8

ALELUYA!! Por fin los de IE se dejaron de jodernos y van a usar el alt como lo que verdaderamente es, por fiiiiin!

flagbeer, el alt te funciona. Lo que quieres hacer no se hace con alt, se hace con title... el alt es solo para cuando las imágenes no cargan (alt = alternative text, texto alternativo) lo que pasa que IE toda la vida lo ha usado mal.
__________________
Pasamos tus PSD a HTML

Pobre del que lo sabe todo, porque no tiene nada más que aprender ni razón para vivir. -
  #4 (permalink)  
Antiguo 25/05/2009, 17:43
Avatar de -Defero-
Colaborador
 
Fecha de Ingreso: julio-2004
Ubicación: Guipúzcoa
Mensajes: 4.777
Antigüedad: 13 años, 5 meses
Puntos: 76
Respuesta: alt, no funciona con explorer 8

Cita:
Iniciado por webosiris Ver Mensaje
ALELUYA!! Por fin los de IE se dejaron de jodernos y van a usar el alt como lo que verdaderamente es, por fiiiiin! (...)
Sólo quería decir que al leer el mensaje yo también pensaba que ése era el problema, y que de ser así, suscribiré cada una de las palabras de Webosiris.
__________________
abogado en Errenteria + procuradora en San Sebastián = equipo imparable
  #5 (permalink)  
Antiguo 25/05/2009, 19:39
Avatar de chulifo  
Fecha de Ingreso: abril-2009
Ubicación: perdido en codigos del PHP, pero aprendo rapido!
Mensajes: 523
Antigüedad: 8 años, 8 meses
Puntos: 18
Respuesta: alt, no funciona con explorer 8

Cita:
Iniciado por webosiris Ver Mensaje
ALELUYA!! Por fin los de IE se dejaron de jodernos y van a usar el alt como lo que verdaderamente es, por fiiiiin!

flagbeer, el alt te funciona. Lo que quieres hacer no se hace con alt, se hace con title... el alt es solo para cuando las imágenes no cargan (alt = alternative text, texto alternativo) lo que pasa que IE toda la vida lo ha usado mal.


es verdad el ATl es en caso de que la imagen no carge XD pero nunk pense que IE estaba mal pero si me fije eso utimamente!
  #6 (permalink)  
Antiguo 26/05/2009, 00:00
Avatar de Triby
Mod on free time
 
Fecha de Ingreso: agosto-2008
Ubicación: $MX->Gto['León'];
Mensajes: 9.741
Antigüedad: 9 años, 4 meses
Puntos: 2113
Respuesta: alt, no funciona con explorer 8

Genial, va 1 en el contador, esperemos que sigan saliendo mas aciertos. (ojala no sea mucho pedir )
__________________
- León, Guanajuato
- GV-Foto
  #7 (permalink)  
Antiguo 26/05/2009, 01:16
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: alt, no funciona con explorer 8

He aquí una explicación:

Testing support

To test out the changed alt and added longdesc support a test page with some combinations of alt, longdesc and title was created.
The results were mixed:

* The alt is not displayed as a tooltip when using HTML 4.01 strict DOCTYPE or XHTML DOCTYPE’s.
* The alt is displayed as a tooltip when using a HTML 4.01 transitional DOCTYPE.
  #8 (permalink)  
Antiguo 26/05/2009, 01:26
Avatar de hades87  
Fecha de Ingreso: diciembre-2007
Ubicación: Barcelona - España
Mensajes: 3.194
Antigüedad: 10 años
Puntos: 68
Respuesta: alt, no funciona con explorer 8

Pues nunca pensé que IE lo interpretaba mal, además nunca me fijé. Tal vez sea por que no lo uso :P
__________________
No diseñes usando tablas.
  #9 (permalink)  
Antiguo 26/05/2009, 11:35
 
Fecha de Ingreso: enero-2009
Mensajes: 455
Antigüedad: 8 años, 10 meses
Puntos: 11
Respuesta: alt, no funciona con explorer 8

Cita:
ALELUYA!! Por fin los de IE se dejaron de jodernos y van a usar el alt como lo que verdaderamente es, por fiiiiin!
.................................................. .................................................. ..........................

porke tanta felicidad?
  #10 (permalink)  
Antiguo 26/05/2009, 14:09
Avatar de Triby
Mod on free time
 
Fecha de Ingreso: agosto-2008
Ubicación: $MX->Gto['León'];
Mensajes: 9.741
Antigüedad: 9 años, 4 meses
Puntos: 2113
Respuesta: alt, no funciona con explorer 8

Cita:
Iniciado por eulerss
porke tanta felicidad?
Supongo que se debe a que muchos creian que ALT no funcionaba en los navegadores de verdad, mientras que en IE < 8 muestra un lindo tooltip haciendo las funciones de TITLE que realmente no le corresponden... ademas... es una avance de IE respetando estandares.
__________________
- León, Guanajuato
- GV-Foto
  #11 (permalink)  
Antiguo 26/05/2009, 20:22
 
Fecha de Ingreso: octubre-2006
Ubicación: Quart de Poblet, Valencia
Mensajes: 767
Antigüedad: 11 años, 1 mes
Puntos: 8
Respuesta: alt, no funciona con explorer 8

Jajaja.

Menos mal que flagbeer ha sabido explicarse y webosiris "no ha tenido que intuir" dónde estaba el problema. ^^ Jajaja

Sinceramente, un aplauso a IE8. Espero más noticias buenas sobre este navegador.

Un saludo.
  #12 (permalink)  
Antiguo 27/05/2009, 01:47
Avatar de Corneja  
Fecha de Ingreso: febrero-2008
Ubicación: Senolaf
Mensajes: 268
Antigüedad: 9 años, 9 meses
Puntos: 8
Respuesta: alt, no funciona con explorer 8

Muchos de los demás fallos siguen estando, la forma de usar los margin, padding etc sigue siendo la misma. Seguiremos sufriendo un poco más
  #13 (permalink)  
Antiguo 27/05/2009, 04:55
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: alt, no funciona con explorer 8

De hecho a mi no me resulta nada importante que resuelvan precisamente eso: yo igualmente voy a poner siempre un alt y un title en mis imágenes, por ejemplo, así que me da un poco igual cuál use explorer para mostrar en su tooltip. No tengo por qué poner lo mismo en los dos, pero la verdad, IE que muestre lo que quiera, que ya no es asunto mio .
  #14 (permalink)  
Antiguo 28/05/2009, 21:25
Avatar de webosiris
Moderador egiptólogo
 
Fecha de Ingreso: febrero-2002
Ubicación: Luxor, Egipto
Mensajes: 10.727
Antigüedad: 15 años, 10 meses
Puntos: 997
Respuesta: alt, no funciona con explorer 8

Cita:
Iniciado por Mikmoro Ver Mensaje
De hecho a mi no me resulta nada importante que resuelvan precisamente eso
si si, yo no lo dije "por mi" sino porque es impresionante la cantidad de usuarios que preguntan por ejemplo "¿como hago un alt para firefox?" y cosas así o (peor) usuarios que preguntan como hacer tooltips y le responden "con alt"
__________________
Pasamos tus PSD a HTML

Pobre del que lo sabe todo, porque no tiene nada más que aprender ni razón para vivir. -
  #15 (permalink)  
Antiguo 29/05/2009, 01:15
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: alt, no funciona con explorer 8

Cita:
Iniciado por webosiris Ver Mensaje
si si, yo no lo dije "por mi" sino porque es impresionante la cantidad de usuarios que preguntan por ejemplo "¿como hago un alt para firefox?" y cosas así o (peor) usuarios que preguntan como hacer tooltips y le responden "con alt"
Sí, eso sí.
  #16 (permalink)  
Antiguo 29/05/2009, 13:05
Avatar de daPhyre
Colaborador
 
Fecha de Ingreso: marzo-2008
Ubicación: [email protected] (Redirects to 127.0.0.1)
Mensajes: 2.404
Antigüedad: 9 años, 9 meses
Puntos: 142
Respuesta: alt, no funciona con explorer 8

Cita:
Iniciado por webosiris Ver Mensaje
ALELUYA!! Por fin los de IE se dejaron de jodernos y van a usar el alt como lo que verdaderamente es, por fiiiiin!
Apoyo tu alegría. He notado que ya muchas cosas que hacía mal ahora las hace correcto (He tenido que cambiar muchos [if IE] a [if lte IE 7] ).

Quizá aun no admita todas las propiedades CSS que los otros si, pero al menos ya parece hacer todo lo que hace bien hecho, a ver con que nos sale ahora, por lo menos hasta ahora lo he visto muy bien (En comparación )
__________________
<signs>daPhyre</signs>
Jugaa.me


Adios al dolor de cabeza de IE...
  #17 (permalink)  
Antiguo 29/05/2009, 17:20
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: alt, no funciona con explorer 8

Mirando el test ACID es para llorar.
  #18 (permalink)  
Antiguo 29/05/2009, 18:22
Avatar de hades87  
Fecha de Ingreso: diciembre-2007
Ubicación: Barcelona - España
Mensajes: 3.194
Antigüedad: 10 años
Puntos: 68
Respuesta: alt, no funciona con explorer 8

Uf, ni lo había mirado Mikmoro, pero mejor que no lo hubiera hecho, nada mas inicar el ACid me han salido fallos de 2 scripts :S
__________________
No diseñes usando tablas.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:43.