Foros del Web » Creando para Internet » HTML »

AVG(q1) ... ¡qué lío!

Estas en el tema de AVG(q1) ... ¡qué lío! en el foro de HTML en Foros del Web. Estimados amigos, Deseo calcular la media aritmética de cuatro columnas; para ello empleo AVG(q1) ... strsql = "SELECT Avg(q1) as media1, Avg(q2) as media2, Avg(q3) ...
  #1 (permalink)  
Antiguo 13/04/2004, 15:07
AZP
 
Fecha de Ingreso: junio-2003
Mensajes: 83
Antigüedad: 14 años, 6 meses
Puntos: 0
AVG(q1) ... ¡qué lío!

Estimados amigos,

Deseo calcular la media aritmética de cuatro columnas; para ello empleo AVG(q1) ...

strsql = "SELECT Avg(q1) as media1, Avg(q2) as media2, Avg(q3) as media3, Avg(q4) as media4 from Encuesta"

-empleo la base de datos Access 2000-

El problema reside en que si algún individuo deja una pregunta sin señalar, la celda en la base de datos queda en blanco y me da error en la estimación de la media apareciendo este mensaje de error:

Microsoft OLE DB Provider for ODBC Drivers error '80040e07'

[Microsoft][ODBC Microsoft Access Driver] Data type mismatch in criteria expression.

No puedo poner ningún valor por defecto en la BD, porque desvirtuaría el valor de la media.

¿Qué hago?

Un saludo,

AZP
  #2 (permalink)  
Antiguo 13/04/2004, 15:17
AZP
 
Fecha de Ingreso: junio-2003
Mensajes: 83
Antigüedad: 14 años, 6 meses
Puntos: 0
Me he equivocado de foro; lo siento; me lo llevo a ASP.

Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:08.