Foros del Web » Creando para Internet » HTML »

ayuda

Estas en el tema de ayuda en el foro de HTML en Foros del Web. hola a todos soy nuevo en esto de los foros y nuevo en esto del html estoy creando una pagina con marcos un top, un ...
  #1 (permalink)  
Antiguo 23/06/2010, 13:38
 
Fecha de Ingreso: junio-2010
Mensajes: 5
Antigüedad: 7 años, 5 meses
Puntos: 0
ayuda

hola a todos soy nuevo en esto de los foros y nuevo en esto del html estoy creando una pagina con marcos un top, un left frame,button frame etc.

en mi left_frame tengo un swf que es mi menu este esta insertado dentro de una tabla de una columna y tres filas en mi segunda fila tengo insertado un pixel de imagen pra que se repita en mi tercer fila tengo otro swf pero almomento de publicar no me coloca mi elemento swf hasta abajo dejo parte de codigo de mi tabla

<body>
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td height="400"><object id="FlashID" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="145" height="400">
<param name="movie" value="prueba html/buena.swf" />
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="6.0.65.0" />
<!-- Esta etiqueta param indica a los usuarios de Flash Player 6.0 r65 o posterior que descarguen la versión más reciente de Flash Player. Elimínela si no desea que los usuarios vean el mensaje. -->
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<!-- La siguiente etiqueta object es para navegadores distintos de IE. Ocúltela a IE mediante IECC. -->
<!--[if !IE]>-->
<object type="application/x-shockwave-flash" data="prueba html/buena.swf" width="145" height="400">
<!--<![endif]-->
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="6.0.65.0" />
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<!-- El navegador muestra el siguiente contenido alternativo para usuarios con Flash Player 6.0 o versiones anteriores. -->
<div>
<h4>El contenido de esta página requiere una versión más reciente de Adobe Flash Player.</h4>
<p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Obtener Adobe Flash Player" width="112" height="33" /></a></p>
</div>
<!--[if !IE]>-->
</object>
<!--<![endif]-->
</object></td>
</tr>
<tr>
<td height="100%">&nbsp;</td>
</tr>
<tr>
<td height="200"><object id="FlashID2" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="145" height="200">
<param name="movie" value="prueba html/parte inferior.swf" />
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="6.0.65.0" />
<!-- Esta etiqueta param indica a los usuarios de Flash Player 6.0 r65 o posterior que descarguen la versión más reciente de Flash Player. Elimínela si no desea que los usuarios vean el mensaje. -->
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<!-- La siguiente etiqueta object es para navegadores distintos de IE. Ocúltela a IE mediante IECC. -->
<!--[if !IE]>-->
<object type="application/x-shockwave-flash" data="prueba html/parte inferior.swf" width="145" height="200">
<!--<![endif]-->
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="6.0.65.0" />
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<!-- El navegador muestra el siguiente contenido alternativo para usuarios con Flash Player 6.0 o versiones anteriores. -->
<div>
<h4>El contenido de esta página requiere una versión más reciente de Adobe Flash Player.</h4>
<p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Obtener Adobe Flash Player" width="112" height="33" /></a></p>
</div>
<!--[if !IE]>-->
</object>
<!--<![endif]-->
</object></td>
</tr>
</table>
  #2 (permalink)  
Antiguo 24/06/2010, 06:41
Avatar de _cronos2
Colaborador
 
Fecha de Ingreso: junio-2010
Mensajes: 2.062
Antigüedad: 7 años, 6 meses
Puntos: 309
Respuesta: ayuda

El fallo no sé dónde está pero los comentarios condicionales están mal usados. Hay una FAQ sobre ellos y enlaza a un tema en el que se debatió y se llegó a la conclusión de que no se podía poner !IE. Además estás poniéndolos mal porque los comentarios son
<!--[if IE]>
Tu c&oacute;digo
<![endif]-->

Y tú lo usas así
<!--[if !IE]>-->
Tu c&oacute;digo
<!--<![endif]-->

Visita esta página: http://www.webtaller.com/construccion/lenguajes/html/lessons/comentarios-condicionales-de-IE-html.php
Saludos (:
  #3 (permalink)  
Antiguo 24/06/2010, 18:27
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: ayuda

jerckvan

Tienes algunos erroes en la forma que insertas el object, pero no exactamente por los motivos que te señala _cronos2

Hace un tiempo hice una suerte de tutorial, puedes verlo en

http://foros.emprear.com/video/flash...script-dw.html

revisa tambien el método 2 y veras que tu <!--[if !IE]>--> no esta del todo mal. Prueba la página tanto en IE como en ópera y firefox y te daras cuenta.

Saludos

Etiquetas: Ninguno
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas




La zona horaria es GMT -6. Ahora son las 13:38.