Foros del Web » Creando para Internet » HTML »

Ayuda Codigo Adsense problemas

Estas en el tema de Ayuda Codigo Adsense problemas en el foro de HTML en Foros del Web. Coloco Adsense en mi blog y me dice que no es XHTML válido y con Internet explorer ya no me abre el blog mientras que ...
  #1 (permalink)  
Antiguo 12/09/2006, 03:20
Avatar de Azran1981  
Fecha de Ingreso: septiembre-2006
Mensajes: 10
Antigüedad: 11 años, 3 meses
Puntos: 0
Ayuda Codigo Adsense problemas

Coloco Adsense en mi blog y me dice que no es XHTML válido y con Internet explorer ya no me abre el blog mientras que con mozilla firefox si que lo abre.

Alguien tiene alguna idea de porque puede ser?

¿Porque los enlaces de videos youtube no son XHTML válido?

Gracias por leer.
  #2 (permalink)  
Antiguo 12/09/2006, 16:06
AlvaroG
Invitado
 
Mensajes: n/a
Puntos:
Supongo que estás usando XHTML 1.1 o 1.0 pero enviándolo como application/xhtml+xml, ¿no?

Bueno, si ese es el caso:
1.- El código de AdSense usa document.write, que NO es admitido para xml. Por lo tanto, no se interpreta, entonces el anuncio no aparece.
Solución: usar <object> para incluir una página externa que contenga el código de adsense.
2.- XML no permite & más que en entidades, por lo que en los enlaces, que pueden contener algo como ?var1=valor1&var2=valor2 da un error porque no reconoce ninguna entidad.
Solución: cambiar & por &amp; en los enlaces. Cuidado con los navegadores que no soportan XHTML (IE, Konqueror) porque pueden no servirles los enlaces cambiados.


Saludos.
  #3 (permalink)  
Antiguo 14/09/2006, 10:51
Avatar de Azran1981  
Fecha de Ingreso: septiembre-2006
Mensajes: 10
Antigüedad: 11 años, 3 meses
Puntos: 0
Gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:37.