Foros del Web » Creando para Internet » HTML »

Ayuda con regreso a un iframes

Estas en el tema de Ayuda con regreso a un iframes en el foro de HTML en Foros del Web. Hola , tengo un problema al momento de regresar un php a un iframe, el problema es el siguiente: tengo una tabla en la cual ...
  #1 (permalink)  
Antiguo 05/05/2006, 09:42
 
Fecha de Ingreso: abril-2003
Ubicación: Monterrey, Nuevo Leon Mex
Mensajes: 300
Antigüedad: 14 años, 8 meses
Puntos: 3
Ayuda con regreso a un iframes

Hola , tengo un problema al momento de regresar un php a un iframe, el problema es el siguiente: tengo una tabla en la cual dentro de esta tengo u1 iframe
Código:
<table width="750" border="0" align="center" >
  <tr>


<td vAlign="top" width="740" height="260" align="center" ><iframe src="progs/capcta.php" name="iframe" id="iframe" width="100%" height="100%" scrolling="auto" frameborder="0" allowtransparency="true"></iframe>
</td>

  </tr>
</table>
dentro de esta esta un codigo php , lo ejecuta muy bien y todo pero en este php tengo una salida a otro codigo php
Código:
<?php
require("../includes/conectar.php");
// Valida la cuenta y regresa al capturar mas movimientos
$rowcta = mysql_query("SELECT * FROM ctas where cta_cta = '$cta' and sct_cta = '$sct' and ssc_cta = '$ssc'",$Conexion);
$rowcta=mysql_fetch_array($rowcta);
if(!$rowcta)
 {
    mysql_query("INSERT INTO ctas (gpo_cta, cia_cta, cta_cta, sct_cta, ssc_cta, nom_cta, nat_cta, rubbal_cta, rubfis_cta) VALUES ('$gpo', '$cia', '$cta', '$sct', '$ssc', '$nomcta', '$nat', '$rubbal', '$rubfis');",$Conexion);
 }
 else
 {
    echo "<div align=\"center\">"
        ." <table width=\"253\" border=\"1\" bgcolor=\"#FF0000\">"
        ."   <tr>"
        ."    <td width=\"243\"><div align=\"center\" class=\"Estilo1\">"
        ."      <p>&nbsp;</p>"
        ."      <p>Cuenta ya Inexistente</p>"
        ."      <p>&nbsp; </p>"
        ."    </div></td>"
        ."  </tr>"
        ." </table>"
        ." </div>";
 } 
?>
<META HTTP-EQUIV="refresh"  content="0;URL=../index.php?sw=0" > 
todo funciona perfectamente pero al momento de regresar este script al script inicla me ejecuta el script dentro del iframe, la etiqueta que esta en negrita en el codigo de arriba es la que me lo esta enviando dentro del iframe, se que con target="_parent", me soluciona el problema pero no se donde va o como debe de ir en el meta de arriba,

Agradesco la ayuda que me puedan prindar, pàra solucionar mi problema
  #2 (permalink)  
Antiguo 05/05/2006, 12:58
Avatar de ludovico2000  
Fecha de Ingreso: noviembre-2003
Ubicación: Bizkaia
Mensajes: 1.315
Antigüedad: 14 años, 1 mes
Puntos: 2
Con un meta no puedes usar "target". Esa propiedad es para los href...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:17.