Foros del Web » Creando para Internet » HTML »

AYUDA!No se me activa el Javasscript de un XHTML

Estas en el tema de AYUDA!No se me activa el Javasscript de un XHTML en el foro de HTML en Foros del Web. Hola! He creado un archivo xhtml que contiene un javascript para validar con el netbeans. El caso es que lo pruebo con el firefox y ...
  #1 (permalink)  
Antiguo 25/12/2007, 12:11
 
Fecha de Ingreso: mayo-2007
Mensajes: 222
Antigüedad: 10 años, 6 meses
Puntos: 0
AYUDA!No se me activa el Javasscript de un XHTML

Hola!


He creado un archivo xhtml que contiene un javascript para validar con el netbeans. El caso es que lo pruebo con el firefox y el XHTML aparece, pero no me sale el cuadro amarillo de arriba que indica la activacion del javascript.

En el mozilla tengo instaladas herramientas de verificacion de xhtml, con el HTML Tidy y el Total Validator que me dicen que el codigo que he implementado esta correcto. Del javascript tambien tengo una herramienta llamada web developer que me dice que el javascritpt no tiene ningun error.

Pero ni se me activa el cuadro javascript, (a pesar de que el firefox tengo por defecto activado el javascript), ni cuando pulso el boton enviar me sale nada.

Agradeceria que alguien me echara una mano.

Os pongo el codigo del xhtml y del javascript debajo:

Código HTML:
<html>
 <head>
     <title>Control de acceso</title>
     <script type="text/javascript" src="Validacion.js"> 
</script>
    </head>
    <body>
      <h1> Identificacion mediante el NIF </h1>
<form id="frmAcceso" name="frmAcceso" method="get"
 action="http://google.es">
                
<table>
  <tr>
  <td> 
  DNI: 
  </td>
  <td>
 <input type="text" id="txtDni" name="txtDni" />
  </td>
  <td>
    Letra:
   </td>
    <td>
     <select id="sLetra" name="sLetra">
      <option id="A" value="A" selected="selected"> A  
     </option>
                                   ......
     <option id="Z" value="Z" selected="selected" > Z 
    </option>
     </select>       
    </td>
    </tr>
    <tr>
    <td>
<input type="button" id="enviar" name="enviar" value="ENVIAR" 
onclick="validate()" />
 </td>
 <td>
 <input type="reset" id="borrar" name="borrar" value="BORRAR"
 />
 </td>   
 </tr>            
</table>     
</form>
</body>
</html> 

Codigo del javascript:

function validate() {
if(noEntry(document.frmAcceso.txtDni) == false) return;
if(noLetras(document.frmAcceso.txtDni) == false) return;
if(calcularLetra()== false) return;
if(esNegativo(document.frmAcceso.txtDni)== false) return;

document.frmAcceso.submit();
}

function noEntry(field) {
var mt=field.value;
if (mt.length<1) {
confirm("Completar el campo txtDNI");
field.focus();
return false;
}
else
{
return true;
}
}

function noLetras(field)
{
var valid = "0123456789";
var ok = "yes";

var temp;
for (var i=0; i<field.value.length; i++) {
temp = "" + field.value.substring(i,i+1);
if (valid.indexOf(temp) == "-1") ok="no";
}
if (ok == "no") {
confirm("Teclear un DNI (sin letras, solo numeros)");
field.focus();
field.select();
return false;
}
else
return true;
}

function calcularLetra()
{
cadena ="TRWAGMYFPDXBNJZSQVHLCKE";
var numero=document.frmAcceso.txtDni.value;
var resultado=numero%23;
letra=cadena.charAt(resultado);
if (letra != document.frmAcceso.sLetra.value)
{
confirm("La letra del NIF es incorrecta. Seleccionar la letra " +letra);
return false;
}
else
{
return true;
}
}

function esNegativo(field)
{
if (field.value <0)
{
confirm("El dni es negativo, por favor cambialo");
return false;
}
else
return true;
}

S2!

Última edición por bladu; 25/12/2007 a las 12:26
  #2 (permalink)  
Antiguo 25/12/2007, 19:15
 
Fecha de Ingreso: noviembre-2007
Mensajes: 203
Antigüedad: 10 años
Puntos: 0
Re: AYUDA!No se me activa el Javasscript de un XHTML

Hola, firefox tiene la opcion "error console", uso firefox en ingles entonces no se como le dicen en español, pero debe ser algo como consola de errores, o visita addons.mozilla.org e instala el firebug y busca si hay algun error
  #3 (permalink)  
Antiguo 26/12/2007, 02:51
 
Fecha de Ingreso: mayo-2007
Mensajes: 222
Antigüedad: 10 años, 6 meses
Puntos: 0
Re: AYUDA!No se me activa el Javasscript de un XHTML

Cita:
Iniciado por mm55 Ver Mensaje
Hola, firefox tiene la opcion "error console", uso firefox en ingles entonces no se como le dicen en español, pero debe ser algo como consola de errores, o visita addons.mozilla.org e instala el firebug y busca si hay algun error

Hola! Gracias por responder.

El error console aparece con las herramientas webdeveloper, ya se lo he pasado pero me dice que no tengo ningun error.

Alguna sugerencia mas?

Gracias

S2!
  #4 (permalink)  
Antiguo 26/12/2007, 12:44
 
Fecha de Ingreso: noviembre-2007
Mensajes: 203
Antigüedad: 10 años
Puntos: 0
Re: AYUDA!No se me activa el Javasscript de un XHTML

hola de nuevo, programa tu web, declara el doctype (mas informacion en www.w3.org, o en google) y visita http://www.validator.w3.org, puedes elegir subir un archivo html o escribir directamente el codigo, si tu web ya esta publicada entonces escribe tu direccion y ellos te diran verdaderamente si hay errores.
saludos
  #5 (permalink)  
Antiguo 26/12/2007, 15:26
 
Fecha de Ingreso: mayo-2007
Mensajes: 222
Antigüedad: 10 años, 6 meses
Puntos: 0
Re: AYUDA!No se me activa el Javasscript de un XHTML

hola!

ya la he validado en el consorcio w3, la tengo perfecta. Pero el javascript no se me activa ese es el problema, y el consorcio w3 no valida javascript.

Alguna sugerencia mas.

S2!
  #6 (permalink)  
Antiguo 26/12/2007, 17:16
 
Fecha de Ingreso: noviembre-2007
Mensajes: 203
Antigüedad: 10 años
Puntos: 0
Re: AYUDA!No se me activa el Javasscript de un XHTML

el problema pasa con todos los navegadores?
  #7 (permalink)  
Antiguo 27/12/2007, 03:00
 
Fecha de Ingreso: mayo-2007
Mensajes: 222
Antigüedad: 10 años, 6 meses
Puntos: 0
Re: AYUDA!No se me activa el Javasscript de un XHTML

Cita:
Iniciado por mm55 Ver Mensaje
el problema pasa con todos los navegadores?

Hola!

Ocurre con el firefox.

El internet explorer no reconoce codigo XHTML, ya que IE no cumple con los estandares XHTML.
  #8 (permalink)  
Antiguo 27/12/2007, 13:07
 
Fecha de Ingreso: noviembre-2007
Mensajes: 203
Antigüedad: 10 años
Puntos: 0
Re: AYUDA!No se me activa el Javasscript de un XHTML

hola, he probado tu script y uso Firefox y el script si me trabaja perfectamente, que version de firefox tienes?
  #9 (permalink)  
Antiguo 27/12/2007, 14:07
 
Fecha de Ingreso: mayo-2007
Mensajes: 222
Antigüedad: 10 años, 6 meses
Puntos: 0
Re: AYUDA!No se me activa el Javasscript de un XHTML

Cita:
Iniciado por mm55 Ver Mensaje
hola, he probado tu script y uso Firefox y el script si me trabaja perfectamente, que version de firefox tienes?

Hola!

Gracias por contestar y por haberte molestado en probarlo. ¿Se te activa el Javascript?, puedes validar los campos. Tengo la version de Firefox 2.0.0.11. Que yo sepa tengo las opciones de Javsacript activadas. ¿que has hecho para que te funcione?

Un saludo.
  #10 (permalink)  
Antiguo 29/12/2007, 21:09
 
Fecha de Ingreso: noviembre-2007
Mensajes: 203
Antigüedad: 10 años
Puntos: 0
Re: AYUDA!No se me activa el Javasscript de un XHTML

hola, si todo me sirve bien, me pide que no deje el campo en blanco y que solo use numeros, si lo escribo bien envia el form correctamente.
tambien uso firefox 2.0.0.11, prueba desinstalandolo (limpia el registro, te recomiendo registry mechanic) y reinstala firefox de nuevo.
  #11 (permalink)  
Antiguo 31/12/2007, 06:22
 
Fecha de Ingreso: mayo-2007
Mensajes: 222
Antigüedad: 10 años, 6 meses
Puntos: 0
Re: AYUDA!No se me activa el Javasscript de un XHTML

Cita:
Iniciado por mm55 Ver Mensaje
hola, si todo me sirve bien, me pide que no deje el campo en blanco y que solo use numeros, si lo escribo bien envia el form correctamente.
tambien uso firefox 2.0.0.11, prueba desinstalandolo (limpia el registro, te recomiendo registry mechanic) y reinstala firefox de nuevo.
Hola! Eso tendre que hacerlo, a ver si funciona , la verdad es que ya es raro.

Feliz Año nuevo

Un saludo.
  #12 (permalink)  
Antiguo 31/12/2007, 12:14
 
Fecha de Ingreso: noviembre-2007
Mensajes: 203
Antigüedad: 10 años
Puntos: 0
Re: AYUDA!No se me activa el Javasscript de un XHTML

gracias, igualmente...
  #13 (permalink)  
Antiguo 02/01/2008, 06:45
 
Fecha de Ingreso: julio-2007
Mensajes: 30
Antigüedad: 10 años, 5 meses
Puntos: 1
Re: AYUDA!No se me activa el Javasscript de un XHTML

Hola,

prueba en:

Código:
<input type="button" id="enviar" name="enviar" value="ENVIAR" 
onclick="validate()" />
ponerlo así:

Código:
<input type="button" id="enviar" name="enviar" value="ENVIAR" 
onclick="javascript:validate();" />
Nunca se sabe...
  #14 (permalink)  
Antiguo 06/01/2008, 14:39
 
Fecha de Ingreso: noviembre-2007
Mensajes: 203
Antigüedad: 10 años
Puntos: 0
Re: AYUDA!No se me activa el Javasscript de un XHTML

hola, al poner un evento no es necesario poner javascript:validate(), pues al ser un evento los navegadores saben que lo que vas a ejecutar es javascript
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:56.