Foros del Web » Creando para Internet » HTML »

ayuda para mostrar imagen con <img>

Estas en el tema de ayuda para mostrar imagen con <img> en el foro de HTML en Foros del Web. Hola amigos, el problema que tengo es bastante simple, no puedo mostrar una foto dentro de la etiqueta img porque en vez de salir la ...
  #1 (permalink)  
Antiguo 23/01/2008, 12:35
 
Fecha de Ingreso: enero-2008
Mensajes: 84
Antigüedad: 9 años, 10 meses
Puntos: 0
No puedo mostrar imagen con la etiqueta img

Hola amigos, el problema que tengo es bastante simple, no puedo mostrar una foto dentro de la etiqueta img porque en vez de salir la imagen, sale un cuadrito. Yo trabajo con el wampserver asi que a lo mejor hay que activar alguna extencion o alguna funcion para poder visualizar las imagenes...no se....espero que alguien me pueda ayudar gracias por su ayuda. Soy nuevo en este foro y esta es mi primer consulta espero tener suerte.
  #2 (permalink)  
Antiguo 23/01/2008, 12:52
Avatar de skatomundo  
Fecha de Ingreso: junio-2002
Ubicación: Santiago - CL
Mensajes: 2.532
Antigüedad: 15 años, 5 meses
Puntos: 125
Re: No puedo mostrar imagen con la etiqueta img

Puedes acceder a tu servidor local, de manera o comúnmente:

http://localhost
?

direccionas correctamente en src el archivo de imagen?

creo que si no tienes acceso al server o servicio (localhost), puede que por eso no veas las imágenes. aunque, img es puro HTML.
  #3 (permalink)  
Antiguo 23/01/2008, 13:11
 
Fecha de Ingreso: enero-2008
Mensajes: 84
Antigüedad: 9 años, 10 meses
Puntos: 0
ayuda para mostrar imagen con <img>

Hola amigos, mi problema es simple, no puedo mostra una imagen con la etiqueta img porque, en vez de mostrarla, sale un cuadrito. La ruta que pongo en la propiedad src esta bien, asi que no se que puede ser. muchas gracias por su ayuda.
  #4 (permalink)  
Antiguo 23/01/2008, 13:15
Avatar de pzin
Moderata 😈
 
Fecha de Ingreso: julio-2002
Ubicación: Islas Canarias
Mensajes: 10.462
Antigüedad: 15 años, 4 meses
Puntos: 2100
Re: ayuda para mostrar imagen con <img>

Ésta no es una de PHP, más bien de HTML.

No obstante, seguramente no será la ruta correcta la cual introduces, ya que lo del cuadrito ocurre entonces.
Tal vez pudiera ser, si traes la ruta ed alguna forma de una base de datos o algo que la variable venga vacía o equivocada, se te haya olvidado alguna barra (/), etc...
  #5 (permalink)  
Antiguo 23/01/2008, 13:21
Avatar de aloqui  
Fecha de Ingreso: diciembre-2007
Mensajes: 973
Antigüedad: 10 años
Puntos: 24
Re: ayuda para mostrar imagen con <img>

Es una ruta absoluta o relativa ?
Si es relativa, comprueba si has definido correctamente (caso de usarlo) el elemento
<BASE HREF="URL">

En cualquier caso, te recomiendo que pongas la ruta absoluta. Y si sigue fallando, la pongas tal cual en el navegador y nos cuentas que ves.
__________________
Grupos de Música
Pop Music Stars
  #6 (permalink)  
Antiguo 23/01/2008, 13:30
Avatar de DoPeY-BBS  
Fecha de Ingreso: octubre-2005
Ubicación: Santo Domingo, Dominican Republic, Dominican Republic
Mensajes: 574
Antigüedad: 12 años, 1 mes
Puntos: 12
Re: No puedo mostrar imagen con la etiqueta img

Cita:
Iniciado por gerkin Ver Mensaje
Hola amigos, el problema que tengo es bastante simple, no puedo mostrar una foto dentro de la etiqueta img porque en vez de salir la imagen, sale un cuadrito. Yo trabajo con el wampserver asi que a lo mejor hay que activar alguna extencion o alguna funcion para poder visualizar las imagenes...no se....espero que alguien me pueda ayudar gracias por su ayuda. Soy nuevo en este foro y esta es mi primer consulta espero tener suerte.
Muestra el código a ver cual es el error.
__________________
http://www.htmldog.com/HTML, CSS, and JavaScript,

http://tutorialphp.net/
Aprende PHP en 12 capítulos
  #7 (permalink)  
Antiguo 23/01/2008, 13:34
Avatar de McBlink  
Fecha de Ingreso: noviembre-2006
Ubicación: $ARG->LaPampa()
Mensajes: 1.694
Antigüedad: 11 años, 1 mes
Puntos: 22
Re: ayuda para mostrar imagen con <img>

Poeque mejor no posteas el codigo y listo ;)
__________________
Recuerda usar el highlight para mostrar código
mauricioblint.com
  #8 (permalink)  
Antiguo 23/01/2008, 13:39
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 11 años, 6 meses
Puntos: 2122
Re: ayuda para mostrar imagen con <img>

Tema trasladado a HTML.

Por favor publica en los foros correctos.
  #9 (permalink)  
Antiguo 23/01/2008, 19:50
 
Fecha de Ingreso: enero-2008
Mensajes: 84
Antigüedad: 9 años, 10 meses
Puntos: 0
Re: ayuda para mostrar imagen con <img>

Muchas gracias por sus repuestas, la ruta que pongo esta bien porque intente mostrar varias imagenes y no pude mostrar ninguna, osea que no voy a poner mal todas la rutas. Yo trabajo con el wampserver no si eso es un dato importante pero se los doy ya que soy novato en esto. Otro dato es que si yo pongo este codigo html en un bloc de notas y lo guardo como html, cuando lo abro, ahi si muestra la foto osea que el codigo no esta mal. Y de paso les consulto algo que si tiene que ver con php, yo intente mostrar la imagen guardandola en una base de datos previamente y despues recuperarla de ahi para visualisarla, pero eso tampoco me funciona porque en lugar dela imagen muestra un monton de caracteres. A continuacion les pongo el codigo para que vean lo que hice:

if(!empty($_FILES['imagen']))
{

$destino = $_SERVER['DOCUMENT_ROOT']."/";
$destino .= basename($_FILES['imagen']['name']);
$temporal = $_FILES['imagen']['tmp_name'];
$name = $_FILES["imagen"]["name"];
$type = $_FILES["imagen"]["type"];
$tmp_name = $_FILES["imagen"]["tmp_name"];
$size = $_FILES["imagen"]["size"];

$fp = fopen($tmp_name, "rb");
$tfoto = fread($fp, filesize($tmp_name));
$tfoto = addslashes($tfoto);
fclose($fp);

@unlink($tmp_name);


}

if($NuevoContacto->Agregar_contacto($_POST['nombre'],$_POST['apellido'],$_POST['telefono'],$_POST['edad'],$_POST['dni'],$_POST['domicilio'],$_POST['rol'],$tfoto,$type,$_POST['usuario'],$_POST['contrasenia'])){

$Mensaje .= "El contacto fue ingresado exitosamente a la Base de Datos.<br><br>";
}else{
$Mensaje .= "Se produjo un error ingresando el contacto en la base de datos.<br><br>";
}

este pedazo de codigo guarda la imagen en la BD. A la imagen, la recibe por post entre otros datos, y la funcion contacto->agragar_contacto es la que guarda todos los datos recibidos por post en la BD incluido la imagen y su tipo. Ahora les muestro el archivo entero en donde se muestra la imagen:

<?php

include_once("seguridad.php");

include_once("Class.Contacto.php");

$conn = mysql_connect("localhost","root","");
mysql_select_db("contactos",$conn);

$res = mysql_query("select * from contactos where idContacto = '".$_GET['id']."'");

$fila = mysql_fetch_array($res);

header ('Content-type: ' . $fila['tipo_img']);
echo $fila['tipo_img'];

$archperfil= $fila['nombre']."_".$fila['apellido'].".txt";

$fp = fopen($_SERVER['DOCUMENT_ROOT']."/".$archperfil,"r");

?>
<html>
<head>
<title>Foto y Perfil</title>
</head>
<body>

<form name="FotoPefil" action = "#" method = "POST" enctype="multipart/form-data">

<table align="center" width="%80" cellspacing="2" cellpadding="2" border="0">
<tr>
<td align="center" >
<?php echo $fila['imagen']; ?>
</td>
</tr>
<tr>
<td align = center>
Perfil
</td>
</tr>
<tr>
<td>
<textarea name=editor rows = 10 cols = 50><?php fpassthru($fp)?></textarea>
</td>
</tr>
</table>

<h3 align="center"><A href= <?php echo "buscadoradm.php?cb=".$_GET['cb']."&pc=".$_GET['pc']; ?> >Volver</A></h3>

</form>
</body>
</html>

Este archivo se los muestro entero porque ahi me parece que puede estar el error. Si alguien puede decirme cual es se lo agredezco mucho, y si me pueden decir porque no me muestra la imagen con la etiqueta img tambien se los agradezco.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:41.