Foros del Web » Creando para Internet » HTML »

Caracter extraño en acentos

Estas en el tema de Caracter extraño en acentos en el foro de HTML en Foros del Web. Hola, que tal, sinceramente no se si estoy escribiendo en el lugar correcto, de antemano pido disculpas si asi es y si puede ser movido ...
  #1 (permalink)  
Antiguo 04/01/2007, 04:45
 
Fecha de Ingreso: noviembre-2003
Mensajes: 100
Antigüedad: 14 años, 1 mes
Puntos: 0
Caracter extraño en acentos

Hola, que tal, sinceramente no se si estoy escribiendo en el lugar correcto, de antemano pido disculpas si asi es y si puede ser movido al lugar correcto.

El problema me esta sucediendo con varias paginas, del mismo hosting, los del hosting me dijieron que modifique algo del charset, reemplazar UTF-8 por ISO-8859-1, en mi weblog wordpress hice ese cambio y luego funciono todo perfectamente.

Estoy haciendo un mirror igual a meneame (me baje el source), esta todo re bien instalado, el unic problema es este de mi hosting, los acentos me aparecen como caracteres extraños y ese codigo al principio de la web...
No se que otro problema esta causando esto, saludos!

Adjunto imagen.
  #2 (permalink)  
Antiguo 04/01/2007, 05:12
Avatar de sumolari  
Fecha de Ingreso: mayo-2006
Ubicación: localhost
Mensajes: 1.367
Antigüedad: 11 años, 7 meses
Puntos: 18
Re: Caracter extraño en acentos

En HTML los acentos no se escriben á é í ó ú, tampoco ñ ni ¿ y otros, se escriben así:

á é í ó ú ñ ¿

O eso o no sé que es, pon un link a la web para que la veamos...
  #3 (permalink)  
Antiguo 04/01/2007, 05:45
 
Fecha de Ingreso: noviembre-2003
Mensajes: 100
Antigüedad: 14 años, 1 mes
Puntos: 0
Re: Caracter extraño en acentos

http://malditaduda.com/videoneame/ < ese es el link para q puedan verlo
  #4 (permalink)  
Antiguo 04/01/2007, 08:14
 
Fecha de Ingreso: enero-2004
Ubicación: Medellin
Mensajes: 171
Antigüedad: 13 años, 11 meses
Puntos: 8
Re: Caracter extraño en acentos

ami hay veces me pasa lo mismo, pero es x la configuracion del firefox, ve a
View->Character encoding->
elije Westren (ISO-8859-1).

En Internet explorer se ve bien?
  #5 (permalink)  
Antiguo 04/01/2007, 20:33
 
Fecha de Ingreso: noviembre-2003
Mensajes: 100
Antigüedad: 14 años, 1 mes
Puntos: 0
Re: Caracter extraño en acentos

vicman, en internet explorer anda perfecto.

En el firefox me fije donde me dijiste y dice "Occidental ISO-8859-1", que debe ser lo que vos me decis, nada mas q el mio esta en español. en fin, sin embargo esta seleccionado desde siempre, y no funciona....
  #6 (permalink)  
Antiguo 05/01/2007, 02:42
Avatar de sumolari  
Fecha de Ingreso: mayo-2006
Ubicación: localhost
Mensajes: 1.367
Antigüedad: 11 años, 7 meses
Puntos: 18
Re: Caracter extraño en acentos

Yo en unicode UFT8 lo veo perfectamente...
  #7 (permalink)  
Antiguo 07/01/2007, 04:42
 
Fecha de Ingreso: marzo-2006
Mensajes: 41
Antigüedad: 11 años, 8 meses
Puntos: 0
Re: Caracter extraño en acentos

Esos 3 bytes raros que ves al comienzo del archivo indican que tu archivo está codificado como UTF8 con BOM.
La solución es que utilices CHARSET=UTF8 en el head de tu html y que elimines esa marca BOM (con un editor hexadecimal o como quieras, son los primeros 3 bytes).

De aca podes descargar un programa que hice para remover dicha marca.

ftp://anonymous%40clubdesarrolladore...re/utf8bom.rar

Cuando te pida la contraseña, no pongas nada y acepta.

Saludos.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:14.