Foros del Web » Creando para Internet » HTML »

caracteres erroneos en pantalla

Estas en el tema de caracteres erroneos en pantalla en el foro de HTML en Foros del Web. mi aicacion no regresa apropiadamente las letras ñ, Ñ. , letras acentuadas ¿quien sabe donde esta mi problema? estabvlezco la etiqueta: pero no em da ...
  #1 (permalink)  
Antiguo 16/11/2004, 14:06
 
Fecha de Ingreso: noviembre-2004
Mensajes: 25
Antigüedad: 13 años, 1 mes
Puntos: 0
caracteres erroneos en pantalla

mi aicacion no regresa apropiadamente las letras ñ, Ñ. , letras acentuadas
¿quien sabe donde esta mi problema?
estabvlezco la etiqueta: pero no em da resultado
<META HTTP-EQUIV= "Content-Type"CONTENT="text/html;charset= ISO-8859-1">
  #2 (permalink)  
Antiguo 16/11/2004, 14:39
Avatar de KnowDemon  
Fecha de Ingreso: julio-2004
Ubicación: Ciudad de México
Mensajes: 544
Antigüedad: 13 años, 5 meses
Puntos: 2
Hola,

Debes cerciorarte que, en efecto, esa es la codificación con la que estas guardando la página. Prueba UTF-8.

Otra solución es usar secuencias de escape para dichos carácteres. (Como &ntilde; etc...)
__________________
Mi pequeño espacio en la web: VisiónE
"El cosmos es todo lo que es, todo lo que fue, y todo lo que será alguna vez."

Última edición por KnowDemon; 16/11/2004 a las 14:44
  #3 (permalink)  
Antiguo 16/11/2004, 16:13
 
Fecha de Ingreso: octubre-2004
Ubicación: España
Mensajes: 894
Antigüedad: 13 años, 1 mes
Puntos: 3
En HTML debería funcionar. ¿Con qué navegador y sistema operativo te falla? ¿Es texto del HTML, o procede de javascript, o de un alert?
__________________
Angel :cool:
  #4 (permalink)  
Antiguo 18/11/2004, 14:14
 
Fecha de Ingreso: noviembre-2004
Mensajes: 25
Antigüedad: 13 años, 1 mes
Puntos: 0
Sonrisa

Ya habia resuelto parcialmente el problema antes de leer sus comentariospero gracias pro su atencion .
En cuanto a html (estaba guardando mis archivos-ficheros- con codificacion UTF-8, los he guardado con codificacion iso 8859-1 y ya esta se ven ñÑ y acentuadas).

Pero persiste el problema con los datos de tablas:
estoy bajo linux, consulto las tablas con mysql. he accesado a mi trabajo desde otros equipos y los caracteres ñ,Ñ,letras acentuadas de resultados de mis consultas siguen sin verse.

Última edición por principiantephp; 18/11/2004 a las 14:21
  #5 (permalink)  
Antiguo 18/11/2004, 14:20
 
Fecha de Ingreso: octubre-2004
Ubicación: España
Mensajes: 894
Antigüedad: 13 años, 1 mes
Puntos: 3
Suena a un problema de la codificación de MySQL. Prueba a preguntar en el foro de bases de datos.
Como última solución, podrías poner una función JS que te filtre los datos sustituyendo el código que venga por la letra correcta antes de mostrarlo en la tabla.
__________________
Angel :cool:
  #6 (permalink)  
Antiguo 18/11/2004, 14:24
 
Fecha de Ingreso: noviembre-2004
Mensajes: 25
Antigüedad: 13 años, 1 mes
Puntos: 0
tienes razon angsanchez, ahora caigo en cuenta de que eso debe ser, consultare mis manuales, gracias de nuevo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:14.