Foros del Web » Creando para Internet » HTML »

Codificación. Aparecen caracteres raros al principio

Estas en el tema de Codificación. Aparecen caracteres raros al principio en el foro de HTML en Foros del Web. Hola! Hace varios dias que vengo con un problema de codificación. Tengo una página que codifiqué (mediante meta http-equiv) en UTF-8. Pero tengo un problema: ...
  #1 (permalink)  
Antiguo 04/06/2008, 12:53
 
Fecha de Ingreso: octubre-2007
Mensajes: 23
Antigüedad: 10 años, 1 mes
Puntos: 0
Codificación. Aparecen caracteres raros al principio

Hola!

Hace varios dias que vengo con un problema de codificación.
Tengo una página que codifiqué (mediante meta http-equiv) en UTF-8. Pero tengo un problema: al abrirla en mozilla firefox me aparecen estos signos: "" al principio de todo, antes de la etiqueta <html>, y me fijo en el navegador la codificación y figura iso-8859-1 :S.
En internet explorer me pasa con algunas cosas lo mismo, pero no con todas :S

Espero que puedan ayudarme! Gracias!
  #2 (permalink)  
Antiguo 04/06/2008, 12:58
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Codificación. Aparecen caracteres raros al principio

Eso se llama el BOM (Byte Order Mark).

Hay muchos editores en los que a la hora de elegir la codificación para guardar un archivo tienes la posibilidad de hacerlo sin BOM. Fíjate en el que estás usando a ver si tienes esa opción.

Mikel.
  #3 (permalink)  
Antiguo 04/06/2008, 14:46
 
Fecha de Ingreso: octubre-2007
Mensajes: 23
Antigüedad: 10 años, 1 mes
Puntos: 0
Respuesta: Codificación. Aparecen caracteres raros al principio

Muchas gracias por responder Mikel.
Uso DreamWeaver. Me fijé eso que me dijiste y es verdad, aparece la opción, pero ya la tenía desactivada. Probé activándola a ver si cambiaba algo pero sigue igual que antes.
Me recomendarías algún otro editor?

Muchas gracias nuevamente
  #4 (permalink)  
Antiguo 06/06/2008, 00:58
 
Fecha de Ingreso: octubre-2007
Mensajes: 23
Antigüedad: 10 años, 1 mes
Puntos: 0
Respuesta: Codificación. Aparecen caracteres raros al principio

Mikel! Estuve investigando mas a fondo sobre lo que me dijiste de BOM, y me di cuenta que desde el DreamWeaver las páginas se me guardaban con esto desactivado, pero una vez subidas al servidor, al hacerle cambios los hacía desde el bloc de notas de Windows, y ahí se ve que se guardaban con BOM activado. Así que edité todo localmente con DreamWeaver y problema solucionado! Muchísimas gracias :D :D
  #5 (permalink)  
Antiguo 06/06/2008, 01:39
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Codificación. Aparecen caracteres raros al principio

De nada, es un placer. A veces las cosas más tontas nos vuelven locos hasta que damos con ellas. Es lo bueno de este foro: que muchos ojos mirando, acaban dando con la solución casi siempre.

Me alegro de que haya ido bien. Hasta la vista.

Mikel.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:21.