Foros del Web » Creando para Internet » HTML »

Comportamiento extraño html

Estas en el tema de Comportamiento extraño html en el foro de HTML en Foros del Web. Hola. Tengo una página html que carga una imagen de cabecera en JPG y debajo un flash SWF mediante swfobject. El problema que ocurre es ...
  #1 (permalink)  
Antiguo 25/09/2010, 05:41
 
Fecha de Ingreso: noviembre-2007
Mensajes: 17
Antigüedad: 10 años, 1 mes
Puntos: 0
Comportamiento extraño html

Hola.
Tengo una página html que carga una imagen de cabecera en JPG y debajo un flash SWF mediante swfobject.
El problema que ocurre es que al entrar en la página se carga la imagen, luego se queda parada unos 15 segundos y carga el archivo flash.
Aquí podeis ver el comportamiento.

http://www.kendomountain.com/panorama/pano001-4.html (prueba con encabezado)

El codigo que tengo es el siguiente:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
<head>
<title></title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<script type="text/javascript" src="script/swfobject.js"></script>
<script type="text/javascript">
var flashvars = {};
var params = {};
params.bgcolor = "#090e1e";
var attributes = {};
swfobject.embedSWF("flash/panorama001.swf", "miContenido", "980", "600", "9.0.0", "script/expressInstall.swf", flashvars, params, attributes);
</script>
<style type="text/css">
body {
background-color: #090e1e;
margin-top: 0px;
}
</style>
</head>
<body>
<center>
<img src="cabezapano.jpg" width="980" height="70" align="top" />
<div id="miContenido">
<a href="http://www.adobe.com/go/getflashplayer">
<img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" />
</a>
</div>
</center>
</body>
</html>



En cambio, si elimino la línea de la carga de la imagen:
<img src="cabezapano.jpg" width="980" height="70" align="top" />
Funciona correctamente, (borrad el cache entre una prueba y otra, sino funciona siempre bien).

http://www.kendomountain.com/panorama/pano001-5.html (prueba sin encabezado)

¿Me podeis ayudar a encontrar que es lo que estoy haciendo mal?

Un saludo,
  #2 (permalink)  
Antiguo 25/09/2010, 22:04
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Comportamiento extraño html

Rote:

Estuve por tu página y es evidente esa demora en la carga, el html está bien, y tu flash es de solo 17kb, así que lo único que se me ocurre es que la forma en que esta hecho dicho flash (panorama001.swf) no este un 100% bien, o que los elementos que carga, como el paisaje de la montaña, sean demasiado pesados.

Yo te recomendaría que traslades tu pregunta al Subforo de Flash de Foros del Web para analizar tu .fla


Saludos
__________________
La voz de las antenas va, sustituyendo a Dios.
Cuando finalice la mutación, nueva edad media habrá
S.R.
  #3 (permalink)  
Antiguo 26/09/2010, 16:58
Avatar de SDEK  
Fecha de Ingreso: diciembre-2009
Ubicación: MX
Mensajes: 156
Antigüedad: 8 años
Puntos: 8
Respuesta: Comportamiento extraño html

Creo que el origen tiene que ver con el flash. Por lo pronto aquí unos resultados de la evaluación de tu web.

http://achecker.ca/checker/index.php#output_div

http://wave.webaim.org/report?url=ht...01-4.html&js=2

http://fae.cita.uiuc.edu/report/12b500c566acbbc2/

Saludos,
__________________
Tecnologías de la Información
Karel Priego
| @karelpriego
  #4 (permalink)  
Antiguo 27/09/2010, 12:30
 
Fecha de Ingreso: noviembre-2007
Mensajes: 17
Antigüedad: 10 años, 1 mes
Puntos: 0
Respuesta: Comportamiento extraño html

Gracias por vuestra ayuda, la verdad es que yo ya no sé qué puede ser.
Os dejo el flash por si veis algo:

http://www.kendomountain.com/panorama/panorama.fla

El código está bajado de la página de riacodes que pogo seguidamente, sólo me he limitado a pegarlo y a cambiar la ruta de donde está la imagen fuente.

http://www.riacodes.com/flash/create-a-360-panorama-viewer-with-as3/

Lo único que he añadido, los títulos, los menús de navegación y una máscara para que no ocupe todo el año de la presentación.
  #5 (permalink)  
Antiguo 27/09/2010, 12:34
 
Fecha de Ingreso: noviembre-2007
Mensajes: 17
Antigüedad: 10 años, 1 mes
Puntos: 0
Respuesta: Comportamiento extraño html

Pregunté también en el foro de SWFobject por si el problema venía por allí y me han contestado lo siguiente:

I don't see a 15 sec delay (checked in IE and Chrome). What i do see (using
a http traffic monitor) is your sever taking a long time to deliver the swf
for some reason:

http://www.kendomountain.com/panorama/flash/panorama001.swf

(even though it is only 16kb, it seems to take ~4 - 5 sec to deliver. I have
25Mbit connection, so I would not expect to see these delays)

Aran


Me quedo igual..
  #6 (permalink)  
Antiguo 27/09/2010, 12:56
 
Fecha de Ingreso: noviembre-2007
Mensajes: 17
Antigüedad: 10 años, 1 mes
Puntos: 0
Respuesta: Comportamiento extraño html

Por último se me ha ocurrido poner la imagen del encabezado dentro del flash.

http://www.kendomountain.com/panorama/pano001-6.html

Así evito cargarla desde el html que me estaba dando ese comportamiento extraño.
Y misteriosamente funciona de manera correcta.

No me gusta la solución, ya que si hay que cambiar el encabezado supone editar todos los flash y volverlos a subir. Pero de momento prefiero esto a que se quede 15 segundos parado...

Etiquetas: extraño
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:53.