Foros del Web » Creando para Internet » HTML »

Conflicto input button y input submit

Estas en el tema de Conflicto input button y input submit en el foro de HTML en Foros del Web. Hola a todos, Tengo un formulario de este tipo: Código: <form method="POST" action="" name="form1" id="form1"> --- un poco texto y HTML simple aqui --- <input ...
  #1 (permalink)  
Antiguo 16/11/2006, 18:17
Avatar de Takitei  
Fecha de Ingreso: septiembre-2004
Ubicación: Venezuela
Mensajes: 1.231
Antigüedad: 13 años, 2 meses
Puntos: 5
Conflicto input button y input submit

Hola a todos,

Tengo un formulario de este tipo:

Código:
<form method="POST" action="" name="form1" id="form1">
--- un poco texto y HTML simple aqui ---
<input type="submit" name="submitxxx" value="Enviar" />
<input type="button" name="volverxxx" value="Atras" onclick="history.back()" />
</form>
Esto funciona perfecto en Internet Explorer. Pero cuando me voy a Firefox y doy click en "Enviar" me manda hacia la página anterior. O sea, en Firefox el "submit" hace el history.back al igual que el "button", ambos botones en Firefox me envian a la página anterior.

¿Por qué ocurre esto? Llevo horas dándole vueltas a esto y no encuentro la solución. Gracias de antemano!
__________________
Takitei
Ingeniarte.com
DannyHerran.com
"Dadme un punto de apoyo y moveré la tierra" - Arquímedes.
  #2 (permalink)  
Antiguo 17/11/2006, 01:47
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Hola Takitei

Acabo de probar tu código y me ha funcionado bien, el botón submit no envía a la página anterior. ¿No tendrás por ahí algún otro código que esté incordiando?

Saludos,
  #3 (permalink)  
Antiguo 17/11/2006, 01:59
Avatar de caricatos
Moderador
 
Fecha de Ingreso: abril-2002
Ubicación: Torremolinos (Málaga)
Mensajes: 19.544
Antigüedad: 15 años, 8 meses
Puntos: 1262
Hola:

Supongo que al hacer submit una vez va a la misma página (action="") pero con los parámetros, y el history.back() va a la misma página, pero en el estado anterior: sin los parámetros...

Saludos
__________________
Por favor:
No hagan preguntas de temas de foros en mensajes privados... no las respondo
  #4 (permalink)  
Antiguo 17/11/2006, 17:34
Avatar de Takitei  
Fecha de Ingreso: septiembre-2004
Ubicación: Venezuela
Mensajes: 1.231
Antigüedad: 13 años, 2 meses
Puntos: 5
Problema solucionado. Se debía a que tenía una etiqueta <label> encerrando a los input y por alguna razón esta etiqueta hacia que ambos botones hicieran el history.back().

Saludos y mil gracias!
__________________
Takitei
Ingeniarte.com
DannyHerran.com
"Dadme un punto de apoyo y moveré la tierra" - Arquímedes.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:20.