Foros del Web » Creando para Internet » HTML »

Crear el efecto alt pero en un link

Estas en el tema de Crear el efecto alt pero en un link en el foro de HTML en Foros del Web. Hola alguien sabe como se hace el mismo efecto de la etiqueta img alt, que hace que aparezca un texto en un cuadro amarillo pero ...
  #1 (permalink)  
Antiguo 03/12/2004, 07:02
 
Fecha de Ingreso: diciembre-2003
Ubicación: Quillota
Mensajes: 196
Antigüedad: 14 años
Puntos: 0
Crear el efecto alt pero en un link

Hola alguien sabe como se hace el mismo efecto de la etiqueta img alt, que hace que aparezca un texto en un cuadro amarillo pero en un link?
Me fije que esta web lo tiene cuando uno pone el mouse sobre el titulo de un post aparece un poco del texto. Vi el codigo pero no aparecia nada especial.

Ojala alguien sepa

Saludos
  #2 (permalink)  
Antiguo 03/12/2004, 07:07
Avatar de living  
Fecha de Ingreso: mayo-2004
Mensajes: 1.266
Antigüedad: 13 años, 6 meses
Puntos: 2
Utiliza la etiqueta title:

<a href="pagina.html" title="haz click aquí">link</a>
__________________
¿Te apasiona el mundo del guión? El portal del guión
  #3 (permalink)  
Antiguo 03/12/2004, 07:07
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Hola Scrubb

Tienes que usar title

<a href="pagina.html" title="lo que sea">Enlace</a>

Saludos,
  #4 (permalink)  
Antiguo 03/12/2004, 07:50
 
Fecha de Ingreso: diciembre-2003
Ubicación: Quillota
Mensajes: 196
Antigüedad: 14 años
Puntos: 0
Gracias por la ayuda
  #5 (permalink)  
Antiguo 03/12/2004, 09:49
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Me alegro de que te haya servido

living: esta vez te has adelantado por unas décimas
  #6 (permalink)  
Antiguo 03/12/2004, 11:10
Avatar de living  
Fecha de Ingreso: mayo-2004
Mensajes: 1.266
Antigüedad: 13 años, 6 meses
Puntos: 2
Si quiero llegar a tus 4000 mensajes me tengo que dar mucha prisa
__________________
¿Te apasiona el mundo del guión? El portal del guión
  #7 (permalink)  
Antiguo 03/12/2004, 11:23
 
Fecha de Ingreso: agosto-2003
Mensajes: 499
Antigüedad: 14 años, 3 meses
Puntos: 1
por cierto, siempre se debe usar title, el hecjho que IE muestre un tooltip también con alt el las imagenes es un bug.
__________________
Plaza Mozilla
http://www.chevrel.org/es/noticias/
  #8 (permalink)  
Antiguo 03/12/2004, 11:31
Avatar de living  
Fecha de Ingreso: mayo-2004
Mensajes: 1.266
Antigüedad: 13 años, 6 meses
Puntos: 2
Cita:
Iniciado por PascalC
por cierto, siempre se debe usar title, el hecjho que IE muestre un tooltip también con alt el las imagenes es un bug.
No es un bug amigo PascalC, de hecho para que una página xhtml sea válida la w3c obliga a ponerlo en todas las imagenes.

http://www.w3.org/QA/Tips/altAttribute
__________________
¿Te apasiona el mundo del guión? El portal del guión
  #9 (permalink)  
Antiguo 03/12/2004, 12:03
 
Fecha de Ingreso: noviembre-2004
Mensajes: 1
Antigüedad: 13 años
Puntos: 0
Cita:
Iniciado por living
No es un bug amigo PascalC, de hecho para que una página xhtml sea válida la w3c obliga a ponerlo en todas las imagenes.

http://www.w3.org/QA/Tips/altAttribute
Eso es verdad, pero lo que es incorrecto es que IE muestre el atributo ALT como un tooltip. ALT es lo que debe aparecer si la imagen no se muestra (por ejemplo, si el link a la imagen no funciona o el usuario tiene las imágenes deshabilitadas en su navegador). TITLE debería ser lo único que aparezca en el tooltip.

¡Saludos!
  #10 (permalink)  
Antiguo 03/12/2004, 12:16
 
Fecha de Ingreso: agosto-2003
Mensajes: 499
Antigüedad: 14 años, 3 meses
Puntos: 1
Obviamente la existencia del atributo Alt no es un bug, mostrarlo como si fuera un atributo title ES un bug.
__________________
Plaza Mozilla
http://www.chevrel.org/es/noticias/
  #11 (permalink)  
Antiguo 03/12/2004, 13:10
 
Fecha de Ingreso: diciembre-2003
Ubicación: Quillota
Mensajes: 196
Antigüedad: 14 años
Puntos: 0
Que bueno saber eso del Alt que se comporte como un bug.

En las imagenes tenia ese tipo para mostrar los titulos, los cambio altiro.

Saludos y gracias nuevamente a todos
  #12 (permalink)  
Antiguo 07/12/2004, 08:50
Avatar de living  
Fecha de Ingreso: mayo-2004
Mensajes: 1.266
Antigüedad: 13 años, 6 meses
Puntos: 2
Cita:
Iniciado por PascalC
Obviamente la existencia del atributo Alt no es un bug, mostrarlo como si fuera un atributo title ES un bug.
tienes toda la razón, siento la confusión
__________________
¿Te apasiona el mundo del guión? El portal del guión
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:39.