Foros del Web » Creando para Internet » HTML »

Duda sobre tilde en encabezado HTML

Estas en el tema de Duda sobre tilde en encabezado HTML en el foro de HTML en Foros del Web. Buenos días, Estoy desarrollando una web para mí un modesto intento de acercarme a HTML 5. La tengo casi lista, PERO me pasa una cosa ...
  #1 (permalink)  
Antiguo 07/11/2010, 04:13
 
Fecha de Ingreso: agosto-2009
Mensajes: 18
Antigüedad: 8 años, 4 meses
Puntos: 0
Duda sobre tilde en encabezado HTML

Buenos días,

Estoy desarrollando una web para mí un modesto intento de acercarme a HTML 5. La tengo casi lista, PERO me pasa una cosa curiosa con las tildes de los textos de las etiquetas <h2>...</h2> y es que no me pone la tilde y me la sustituye por un caracter extraño.

He probado a poner la tilde y a poner el famoso &acute; pero no lo pilla. En todo el fichero HTML me lo pilla bien, pero entre las etiquetas <h> no.

La codificación la tengo a UTF-8 pero cambiándola a ISO tampoco funciona.

Os adjunto una imagen del firebug a ver si véis alguna solución:

Arriba a la derecha está la palabra que quiero acentuar (Más) y mirad cómo me sale:


Os pongo el enlace por si queréis verlo más grande:
http://i53.tinypic.com/16bewyc.jpg

¿Alguna idea? Gracias
  #2 (permalink)  
Antiguo 07/11/2010, 04:45
Avatar de jomaruro
Colaborador
 
Fecha de Ingreso: junio-2002
Ubicación: Naboo
Mensajes: 5.442
Antigüedad: 15 años, 5 meses
Puntos: 361
Respuesta: Duda sobre tilde en encabezado HTML

Hola:

Establece en el head el charset en utf-8 y graba tus archivos como utf-8 sin BOM.

Saludos.

  #3 (permalink)  
Antiguo 07/11/2010, 06:09
 
Fecha de Ingreso: agosto-2009
Mensajes: 18
Antigüedad: 8 años, 4 meses
Puntos: 0
Respuesta: Duda sobre tilde en encabezado HTML

Cita:
Iniciado por jomaruro Ver Mensaje
Hola:

Establece en el head el charset en utf-8 y graba tus archivos como utf-8 sin BOM.

Saludos.

Hola,

Gracias por tu respuesta. En cuanto a lo que comentas, he puesto esto:

Código HTML:
[B]<head charset="utf-8">[/B]
<title>Sobre m&iacute; - Sobre m&iacute; | Fotogaler&iacute;a de Luis Fdez.</title>
<meta charset="utf-8"> 
Y he codificado con el Notepad++ el fichero a UTF-8 sin BOM pero o algo falla o algo falta, ya que sigue igual.

¿Estaré haciendo algo mal?
  #4 (permalink)  
Antiguo 07/11/2010, 13:01
Avatar de jomaruro
Colaborador
 
Fecha de Ingreso: junio-2002
Ubicación: Naboo
Mensajes: 5.442
Antigüedad: 15 años, 5 meses
Puntos: 361
Respuesta: Duda sobre tilde en encabezado HTML

Hola:

Mejor coloca esto:

Código HTML:
Ver original
  1. <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

Saludos.

  #5 (permalink)  
Antiguo 07/11/2010, 13:06
 
Fecha de Ingreso: abril-2009
Ubicación: En foros del web, normalmente en Web general, HTML y CSS.
Mensajes: 258
Antigüedad: 8 años, 7 meses
Puntos: 3
Respuesta: Duda sobre tilde en encabezado HTML

Prueba asi:

Código:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
EDITO: Ups, lo escribimos de forma simultánea.
__________________
¿Por qué Anónimo?, porque como está el mundo no podemos considerarnos humanos...
  #6 (permalink)  
Antiguo 08/11/2010, 09:15
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Duda sobre tilde en encabezado HTML

pudiera ser que la fuente tipografica que estas usando no tiene ciertos caracteres latinos. o en su lugar, la grafica (glyph) es otra en lugar de la adecuada. revisa si la fuente tipografica con un visor de fuentes si en realidad el glyph existe.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #7 (permalink)  
Antiguo 08/11/2010, 09:35
Avatar de innovanets  
Fecha de Ingreso: noviembre-2010
Ubicación: Diseño de Sitios web
Mensajes: 1
Antigüedad: 7 años, 1 mes
Puntos: 0
Respuesta: Duda sobre tilde en encabezado HTML

Se debe usar:
á -> &aacute;
é -> &eacute;
í -> &iacute;
ó -> &oacute;
ú -> &uacute;
ñ -> &ntilde;

Y si es para mayusculas cambias en los &uacute; por &Uacute; (en caso de la Ú) o &Ntilde; (para la Ñ)
  #8 (permalink)  
Antiguo 08/11/2010, 10:28
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Duda sobre tilde en encabezado HTML

@innovanets,

considero que deberias actualizarte. te recomiendo que leas los siguientes articulos:
http://www.w3.org/International/ques...ngelang=es#not
http://www.w3.org/International/O-ch...?changelang=es

no digo que esta mal utilizar entidades, pues siguen siendo totalmente valido. solo que basarse explicitamente en entidades trae otras complicaciones. por otro lado, fijate que el autor ha señalado que con dichas entidades no le muestra el caracter correcto. de ahi que hiciera mencion sobre verificar la fuente ya que en la captura muestra que esta usando cufon.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #9 (permalink)  
Antiguo 08/11/2010, 11:47
 
Fecha de Ingreso: agosto-2009
Mensajes: 18
Antigüedad: 8 años, 4 meses
Puntos: 0
Respuesta: Duda sobre tilde en encabezado HTML

Cita:
Iniciado por zerokilled Ver Mensaje
pudiera ser que la fuente tipografica que estas usando no tiene ciertos caracteres latinos. o en su lugar, la grafica (glyph) es otra en lugar de la adecuada. revisa si la fuente tipografica con un visor de fuentes si en realidad el glyph existe.
Joder, pues puede ser eso!!

Voy a probar y ya pongo el resultado. Gracias a todos
  #10 (permalink)  
Antiguo 08/11/2010, 13:37
 
Fecha de Ingreso: agosto-2009
Mensajes: 18
Antigüedad: 8 años, 4 meses
Puntos: 0
Respuesta: Duda sobre tilde en encabezado HTML

Resuelto.

Al final tenía razón zerokilled. Era problema de la fuente. Utilizo cufon y estaba cogiendo una fuente que no tenía ese caracter. He cambiado la fuente y perfecto.

Quizás tenía que haber comentado primero el uso de cufon, ya que no tiene nada que ver con UTF-8.

Lo dicho, muchas gracias por la ayuda
  #11 (permalink)  
Antiguo 08/11/2010, 14:11
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Duda sobre tilde en encabezado HTML

cufon en si no era el problema, sino la tipografia. con que comentara que utilizabas cufon, no creo que ayudara mucho. pero como se suele utilizar tipografia menos estandares, entonces suponia que ese era el problema.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #12 (permalink)  
Antiguo 09/01/2011, 11:01
 
Fecha de Ingreso: enero-2011
Ubicación: Por aquí ...
Mensajes: 1
Antigüedad: 6 años, 11 meses
Puntos: 0
Pregunta Respuesta: Duda sobre tilde en encabezado HTML

Hola a todos,

Este es mi primer post en este foro por lo que aprovecho para saludar a toda la comunidad .


Vamos con mi duda que finalemnte es la misma que la del amigo lfernapalacio aunque la solución aportada no resuelve en mi caso el problema.

- Los carécteres con tilde con los atributos del encabezado2 (h2) no aparecen. Utilizo el charset UTF-8 y un tipo de letra común (Arial, Helevtica, sans-serif pero he probado con Times New Roman & co). También he probado con la codificación "t&uacute;)

Estó es lo que tengo en DW ...



... y esto lo que obtengo en Firefox/Safari & co



El .html está aquí:
[URL]http://freetexthost.com/12evtrqwuv[/URL]

El .css está aquí:
[URL]http://freetexthost.com/5q03nccpn6[/URL]

Muchas gracias a todos ;)

EDIT: YA HE ENCONTRADO YO SOLITO LA RESPUESTA. EN MI CASO ES EL CUFÓN ...
DEJO EL POST SI A ALGUIÉN LE PASA LO MISMO ;)

Etiquetas: encabezado
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas




La zona horaria es GMT -6. Ahora son las 05:29.