Foros del Web » Creando para Internet » HTML »

Dudas con código

Estas en el tema de Dudas con código en el foro de HTML en Foros del Web. Hola amigos. Tengo un problemilla. Diseñé un sitio con DW 8 que incluye otro diseño en Flash. Creé una cuenta con un servicio de hosting, ...
  #1 (permalink)  
Antiguo 16/06/2010, 11:17
Avatar de biodesignr  
Fecha de Ingreso: enero-2004
Ubicación: santiago de chile... cerca del cerro
Mensajes: 153
Antigüedad: 13 años, 11 meses
Puntos: 0
Dudas con código

Hola amigos.

Tengo un problemilla. Diseñé un sitio con DW 8 que incluye otro diseño en Flash. Creé una cuenta con un servicio de hosting, donde me prestaron soporte para poder subir el sitio. Tuve dificultad para poder cargar mi sitio. El sitio, como dije antes, tiene una página principal creada en DW y dentro lleva el diseño en flash que contiene 6 películas que vendrían siendo las secciones del sitio. Esto quizá no sea relevante con mi pregunta.
Luego de mucho discutir con el soporte ellos me dicen que no pueden ayudarme más, que mi sitio contiene problemas de código. Ante lo cual me senti poco menos que estafado.

A continuación copio el código de la página principal que es donde se cargan las películas de flash :

Código HTML:
<body>
<table width="820" height="600" align="center" border="0" bgcolor="#FFFFFF">
  <!--DWLayoutTable-->
  <tr>
    <td width="814" height="150" align="center" valign="middle"><img src="up_site_gif.gif" width="800" height="150" longdesc="http://www.misitio.com"></td>
  </tr>
  <tr>
    <td><object classid="clsid:D27CDB6E-AE6D-11c<meta name="hostel greenhouse" content="warm and quiet place to stay" />
      <embed src="site_gh.swf" width="800" height="450" align="middle" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash"></embed>
    </object></td>
  </tr>
</table>
</body>
</html> 

Ahora bien, siempre me cargó todo bien en el navegador cuando hacía las pruebas. Con excepción de IE donde cargaba solamente la página principal, pero en Mozilla y Chrome cero problema. Me pregunto qué tiene de malo este código que la gente de soporte no pudo ayudarme.

Espero que alguien pueda darme algunas luces.

De antemano muchas gracias.
__________________
...the long and winding road...
...........................................
.cl
  #2 (permalink)  
Antiguo 16/06/2010, 16:43
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Dudas con código

Bio:
Estas seguro que el Dreamweaver te generó ese código?
Fijate, el tag <object> es el que usa internet Explorer, el <embed> lo pone el dreamweaver para compatibilidad con otros navegadores (Firefox, Opera, etc). En lo que pasaste, tu object no tiene ningun archivo flash definido, tan solo un <meta ... que no tengo idea como llego ahi...
lo correcto sería algo asi

Código HTML:
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="32" height="32" title="demo">
  <param name="movie" value="site_gh.swf" />
  <param name="quality" value="high" />
  <embed src="site_gh.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="32" height="32"></embed>
</object> 
dónde movie= y src= definen a tu archivo Flash site_gh.swf
Se entiende?


Saludos
  #3 (permalink)  
Antiguo 18/06/2010, 21:57
Avatar de biodesignr  
Fecha de Ingreso: enero-2004
Ubicación: santiago de chile... cerca del cerro
Mensajes: 153
Antigüedad: 13 años, 11 meses
Puntos: 0
Respuesta: Dudas con código

Tienes razón. Revisando el trabajo en DW veo que el código que genera es distinto al que copié en mi "post". Haciendo memoria pienso que eso lo saqué del mismo archivo .html que intentaba subir a través de la plataforma del hosting. ¿Crees que el código que genera DW debiera ser incluido en ese archivo .html ?
__________________
...the long and winding road...
...........................................
.cl
  #4 (permalink)  
Antiguo 19/06/2010, 01:53
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Dudas con código

biodesignr:
pongamos algunas cosas en claro, tu tienes un html, y en el quieres insertar una animación hecha en flash. concretamente para eso hay varias alternativas, más o menos prácticas, más o menos configurables. todo dependerá de lo que exija tu página. Puedes ver una explicación de dos de esos dos métodos, con o sin código generado por dreamweaver, puedes verlo en
http://foros.emprear.com/video/flash...script-dw.html

ni siquiera necesitas el dreamweaver, puedes analizar el código fuente y adaptarlo a tu flash. yo no uso mucho Flash en mis páginas, y si lo hago utilizo el método 2, si quieres algo mucho más configurable, utiliza el link que figura abajo del método 2 para utilizar SFWObject (aunque si tuviste problemas con lo actual, no te lo recomiendo, puede resultarte algo complejo). Hay una guia en español sobre SFWObject en http://www.mediavilla.name/index.php...swfobject_2/es

Saludos

Etiquetas: Ninguno
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:15.