Foros del Web » Creando para Internet » HTML »

Enviar simbolo & por formulario..

Estas en el tema de Enviar simbolo & por formulario.. en el foro de HTML en Foros del Web. Hola, tengo el problema de que cuando trato de enviar un formulario al cual le ingreso un simbolo en un input type text (ejemplo el ...
  #1 (permalink)  
Antiguo 07/10/2008, 11:15
Avatar de df_aguirre  
Fecha de Ingreso: agosto-2007
Ubicación: Colombia
Mensajes: 14
Antigüedad: 10 años, 3 meses
Puntos: 0
Enviar simbolo & por formulario..

Hola, tengo el problema de que cuando trato de enviar un formulario al cual le ingreso un simbolo en un input type text (ejemplo el simbolo &).. cuando lo recibo en la otra pagina no sale el simbolo sino sale algo como: %26

alguien sabe como se soluciona esto?
  #2 (permalink)  
Antiguo 07/10/2008, 11:21
Avatar de David
Moderador
 
Fecha de Ingreso: abril-2005
Ubicación: In this planet
Mensajes: 15.711
Antigüedad: 12 años, 7 meses
Puntos: 833
Pregunta Respuesta: Enviar simbolo & por formulario..

¿Con qué estás trabajando en el servidor para recibir los formularios? ¿ASP? ¿PHP?.
__________________
Por favor, antes de preguntar, revisa la Guía para realizar preguntas.
  #3 (permalink)  
Antiguo 07/10/2008, 11:38
Avatar de df_aguirre  
Fecha de Ingreso: agosto-2007
Ubicación: Colombia
Mensajes: 14
Antigüedad: 10 años, 3 meses
Puntos: 0
Respuesta: Enviar simbolo & por formulario..

Hola, es una tarea que consiste en capturar con un analizador de redes WireShark lo que se envia con un formulario modelo y en base a eso crear un propio formulario que realice la misma funcion!

cuando envio los datos con el formulario modelo el wireshark me dice que envia:

Hola&x=miciudad&y=miPais


Yo cree un formulario similar y le mando lo mismo.. pero cuando lo miro en el wireshark me muestra que envie es:

Hola%26x%25miciudad%26y%25miPais

En la tarea no podemos saber como el servidor destino procesa la informacion..

solo es necesario enviarla de manera correcta



estoy probando con un simple form un campo de text con el value="Hola&x=miciudad&y=miPais"

y un boton submit
  #4 (permalink)  
Antiguo 07/10/2008, 11:54
Avatar de David
Moderador
 
Fecha de Ingreso: abril-2005
Ubicación: In this planet
Mensajes: 15.711
Antigüedad: 12 años, 7 meses
Puntos: 833
Exclamación Respuesta: Enviar simbolo & por formulario..

Es que no es un único campo el que se envía en este caso. Se envía el campo "x" con el valor "miciudad", se envía el campo "y" con el valor "MiPais".
__________________
Por favor, antes de preguntar, revisa la Guía para realizar preguntas.
  #5 (permalink)  
Antiguo 07/10/2008, 14:06
Avatar de df_aguirre  
Fecha de Ingreso: agosto-2007
Ubicación: Colombia
Mensajes: 14
Antigüedad: 10 años, 3 meses
Puntos: 0
Respuesta: Enviar simbolo & por formulario..

Si tienes razon!.. deben ser campos ocultos y no me di cuenta!


Muchas gracias!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:54.