Foros del Web » Creando para Internet » HTML »

error en formulario

Estas en el tema de error en formulario en el foro de HTML en Foros del Web. alguien me podria ayudar con un formulario de envio de mail Resulta que agrego el formulario sin la estetica de la pagina y funciona bien, ...
  #1 (permalink)  
Antiguo 04/10/2007, 05:52
 
Fecha de Ingreso: enero-2006
Mensajes: 1
Antigüedad: 11 años, 11 meses
Puntos: 0
error en formulario

alguien me podria ayudar con un formulario de envio de mail
Resulta que agrego el formulario sin la estetica de la pagina y funciona bien, pero al agregarle toda la estetica, el formulario no se envia.




la pagina es: www.alepogo.com.ar y la pagina del formulario es por el sobresito que esta en la barra de memues.


este seria el codigo

/////////////////////////////////////////////////////

<html>
<head>
<title>Consultora Broker - Consultora Integral Empresaria - Juridica - Inmobiliaria - Economica</title>
<meta http-equiv="Content-Type" content="text/html; charset=Shift_JIS">
<script language="JavaScript">
<!--
function MM_preloadImages() { //v3.0
var d=document; if(d.images){ if(!d.MM_p) d.MM_p=new Array();
var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for(i=0; i<a.length; i++)
if (a[i].indexOf("#")!=0){ d.MM_p[j]=new Image; d.MM_p[j++].src=a[i];}}
}

function MM_swapImgRestore() { //v3.0
var i,x,a=document.MM_sr; for(i=0;a&&i<a.length&&(x=a[i])&&x.oSrc;i++) x.src=x.oSrc;
}

function MM_findObj(n, d) { //v4.0
var p,i,x; if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {
d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++) x=d.forms[i][n];
for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=MM_findObj(n,d.layers[i].document);
if(!x && document.getElementById) x=document.getElementById(n); return x;
}

function MM_swapImage() { //v3.0
var i,j=0,x,a=MM_swapImage.arguments; document.MM_sr=new Array; for(i=0;i<(a.length-2);i+=3)
if ((x=MM_findObj(a[i]))!=null){document.MM_sr[j++]=x; if(!x.oSrc) x.oSrc=x.src; x.src=a[i+2];}
}
//-->
</script>
</head>

<body bgcolor="#FFFFFF" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0" text="#333333" link="#FF9900" vlink="#0099FF" alink="#FF6600" background="image/bg_side.gif" onLoad="MM_preloadImages('image/bt_01_on.gif','image/bt_02_on.gif','image/bt_03_on.gif','image/bt_04_on.gif','image/bt_05_on.gif','image/bt_06_on.gif')">
<div align="center">
<table width="640" border="0" cellspacing="0" cellpadding="0" height="100%">
<tr>
<td background="image/bg_main.gif" valign="top" width="640">
<div align="center">

<table width="638" border="0" cellspacing="0" cellpadding="0" background="">
<tr>
<td width="640">
<table border="0" cellspacing="0" cellpadding="0" width="638">
<!--DWLayoutTable-->
<tr>
<td width="10" height="120"><img src="image/spacer.gif" width="10" height="10"></td>
<td width="220"><img src="image/logo.gif" width="180" height="120" longdesc="04"></td>
<td width="39"><img src="image/obj_top_left.gif" width="39" height="120" longdesc="03"></td>
<td width="20" valign="top"><img src="image/obj_top_center.gif" width="20" height="120" longdesc="02"></td>

<td width="349" valign="top"><img src="image/obj_top_right.jpg" width="349" height="120" longdesc="01"></td>
</tr>
</table>
</td>
</tr>
<tr>
<td bgcolor="#000000" width="640"><img src="image/spacer.gif" width="638" height="1"></td>
</tr>
<tr>
<td width="640">
<table width="638" border="0" cellspacing="0" cellpadding="0">

<tr background="image/obj_menu_center.gif">
<td width="5"><img src="image/obj_menu_left.gif" width="5" height="16"></td>
<td width="633" background="image/obj_menu_center.gif" align="right">
<table border="0" cellspacing="0" cellpadding="0" name="menubutton">
<tr>
<td><img src="image/obj_menu_right.gif" width="5" height="16"></td>
<td><a href="index.html" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Image1','','image/bt_01_on.gif',1)"><img src="image/bt_01_off.gif" height="16" border="0" name="Image1"></a></td>
<td><a href="html/inicio.html" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Image2','','image/bt_02_on.gif',1)"><img src="image/bt_02_off.gif" height="16" border="0" name="Image2"></a></td>
<td><a href="html/juridica.html" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Image3','','image/bt_03_on.gif',1)"><img src="image/bt_03_off.gif" height="16" border="0" name="Image3"></a></td>
<td><a href="html/economica.html" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Image4','','image/bt_04_on.gif',1)"><img src="image/bt_04_off.gif" height="16" border="0" name="Image4"></a></td>

<td><a href="html/inmobiliaria.html" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Image5','','image/bt_05_on.gif',1)"><img src="image/bt_05_off.gif" height="16" border="0" name="Image5"></a></td>
<td><a href="html/nuestos_c.html" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Image6','','image/bt_06_on.gif',1)"><img src="image/bt_06_off.gif" height="16" border="0" name="Image6"></a></td>
<td><a href="contacto.html" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Image7','','image/bt_07_on.gif',1)"><img src="image/bt_07_off.gif" name="Image7" width="23" height="16" border="0"></a></td>
</tr>
</table>
</td>
</tr>
</table>
</td>

</tr>
<tr>
<td width="640"><img src="image/obj_mennder.gif" width="638" height="9"></td>
</tr>
</table>
<br>
</div>
<div align="center">
<table width="600" border="0" cellspacing="0" cellpadding="2" background="">
<tr>

<td><!-- Formulario para completar con los datos -->
<form action="html/envia.php" method="POST">
<table border="0" whidth="100%">
<tr>
<td align="rigth" width="19%"><font face="Verdana, Arial, Helvetica, sans-serif"> Nombre: </font></td>
<td align="rigth" width="81%"> <input type="text" name="nombre" width="50" size=40></input><br/><br></td>
</tr>
<tr>

<td align="rigth" width="19%"><font face="Verdana, Arial, Helvetica, sans-serif"> Apelldido: </font></td>
<td align="rigth" width="81%"> <input type="text" name="apellido" width="50" size=40></input><br/><br></td>
</tr>
<tr>
<td align="rigth" width="19%"><font face="Verdana, Arial, Helvetica, sans-serif"> Direccion: </font></td>
<td align="rigth" width="81%"> <input type="text" name="direccion" width="50" size=50></input><br/><br></td>
</tr>

<tr>
<td align="rigth" width="19%"><font face="Verdana, Arial, Helvetica, sans-serif">Telefono: </font></td>
<td align="rigth" width="81%"><input type="text" name="telefono" width="50" size=40></input><br/><br></td>
</tr>
<tr>
<td align="rigth" width="19%"><font face="Verdana, Arial, Helvetica, sans-serif">Email: </font></td>
<td align="rigth" width="81%"><input type="text" name="email" width="50" size=40></input><br/><br></td>
</tr>
<tr>
<td align="rigth" width="19%"><font face="Verdana, Arial, Helvetica, sans-serif">Consulta:</font></td>

<td align="rigth" width="81%"> <textarea rows="9" name="consulta" cols="50"></textarea><br/><br></td>
</tr>


<!--FIN - Datos del formulario a completar -->
<tr>
<td width="19%"></td>
<td align="rigth" width="81%"> <input type="submit" value="Enviar e-mail" />
<input type="hidden" name="prioridad" value="3"/>

<input type="hidden" name="enviar" value="1"/></td>
</tr>
</table>
</form>
<!-- Fin Formulario para completar con los datos -->

</td>
</tr>
</table>
<table width="600" border="0" cellspacing="0" cellpadding="0" background="">
<tr>

<td width="77"><img src="image/obj_sba_topics.gif" width="77" height="16"></td>
<td width="523" background="image/obj_sba_line.gif"><img src="image/spacer.gif" width="523" height="16"></td>
</tr>
</table>
<table width="600" border="0" cellspacing="0" cellpadding="2" background="">
<tr>
<td><img src="image/line.gif" width="600" height="8"></td>
</tr>
<tr>

<td>
<table width="600" border="0" cellspacing="0" cellpadding="0">
<tr>
<td>&nbsp;</td>
<td align="right"><font size="1">Copyright (C)2007 AlePOGO</font></td>
</tr>
</table>
</td>

</tr>
</table>
</div>
</td>
</tr>
</table>
</div>
</body>
</html>
  #2 (permalink)  
Antiguo 04/10/2007, 09:17
 
Fecha de Ingreso: junio-2004
Mensajes: 616
Antigüedad: 13 años, 6 meses
Puntos: 25
Re: error en formulario

pero ¿no se envía? ¿o se envía pero no encuentra "html/envia.php"?

Piensa que si lo estás probando en dos servidores diferentes, es posible que haya dos configuraciones diferentes de php. Y si el de pruebas no tiene el register_globals a "on", recuerda que en PHP no puedes acceder al valor de la variable del formulario con $nombreVariable. Tendrás que hacerlo con $_POST['nombreVariable'].

Pero es sólo por dar ideas. Con lo que has puesto se debería poder enviar el formulario. Otra cosa es que haya un problema en la página que lo recoge o que directamente no la encuentra.

Espero haber sido de ayuda.

Un saludo
__________________
eContento
- Mis artículos, tutoriales y labs
- Mis jsfiddles
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:05.