Foros del Web » Creando para Internet » HTML »

Error en "<html>" con xhtml

Estas en el tema de Error en "<html>" con xhtml en el foro de HTML en Foros del Web. Estoy intentando validar una página xhtml por el validador de w3, el problema que antes de darme los posibles errores en su estructura me da ...
  #1 (permalink)  
Antiguo 25/10/2006, 05:54
 
Fecha de Ingreso: octubre-2006
Ubicación: Barcelona
Mensajes: 94
Antigüedad: 11 años, 1 mes
Puntos: 0
Error en "<html>" con xhtml

Estoy intentando validar una página xhtml por el validador de w3, el problema que antes de darme los posibles errores en su estructura me da este error y despues que por culpa de este error no puede mirar los demas.

¿A alguien le a dado este error en esta linea?

Cita:
Error Line 2 column 0: character "<" invalid: only delimiter ">", delimiter "[", system identifier, "CDATA", "NDATA", "SDATA" and parameter separators allowed.

<html xmlns="URL" xml:lang="es">
¿el CDATA etc no es para las posibles incompatibilidades con javascript?
  #2 (permalink)  
Antiguo 25/10/2006, 06:07
Avatar de tunait
Moderadora
 
Fecha de Ingreso: agosto-2001
Ubicación: Terok Nor
Mensajes: 16.805
Antigüedad: 16 años, 3 meses
Puntos: 380
mmm deberías dar más detalles ¿cómo estás sirviendo el documento? ¿como text/html o como application/xml o cómo?

déjanos ver cómo tienes esas líneas
  #3 (permalink)  
Antiguo 25/10/2006, 06:23
 
Fecha de Ingreso: octubre-2006
Ubicación: Barcelona
Mensajes: 94
Antigüedad: 11 años, 1 mes
Puntos: 0
Cita:
<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN">
<html xmlns="URL" xml:lang="es">
<head>

<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />

</head>
<body>
</body>
</html>
  #4 (permalink)  
Antiguo 25/10/2006, 06:30
Avatar de tunait
Moderadora
 
Fecha de Ingreso: agosto-2001
Ubicación: Terok Nor
Mensajes: 16.805
Antigüedad: 16 años, 3 meses
Puntos: 380
Pero lo tienes tal cual lo has puesto?

<html xmlns="URL" xml:lang="es">
  #5 (permalink)  
Antiguo 25/10/2006, 06:32
 
Fecha de Ingreso: octubre-2006
Ubicación: Barcelona
Mensajes: 94
Antigüedad: 11 años, 1 mes
Puntos: 0
si bueno, es esta URL "http: //www .w3 .org /1999/xhtml" el problema que como no llevo mas de 30 mensajes me aparece que no puedo poner una URL aqui, jeje
  #6 (permalink)  
Antiguo 25/10/2006, 06:38
Avatar de tunait
Moderadora
 
Fecha de Ingreso: agosto-2001
Ubicación: Terok Nor
Mensajes: 16.805
Antigüedad: 16 años, 3 meses
Puntos: 380
Ah, ok.

Pues así a ojo y sin ver qué más hay no puedo decirte mucho. Déjame la url que te da el error (escríbela sin las www y eso y ya lo pego en el navegador)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:39.